You are not logged in.

#1 2018-04-04 20:19:59

Jubijub
Member
From: Lausanne, Switzerland
Registered: 2018-04-04
Posts: 10
Website

Nerd fonts unusable in Gnome-Terminal

Hello,

I am trying to use Nerd fonts https://github.com/ryanoasis/nerd-fonts which are fonts patched with Glyphs, with the intention to use them in Zsh / Oh-my-szh / Powerline9K.

Note : this is known to work, I routinely use this under Ubuntu 17.10 with Gnome-Terminal, as well as under Windows with ConEmu

How I have installed the fonts :
- Go to Git hub
- Download the font using the Download button
- move the font to ~/.local/share/fonts
- run fc-cache -vf
- mkfontscale
- mkfontdir
- clapped my hand and made 3 turns on my chair

Actual result :
- in Gnome terminal, I cannot see the fonts
- I can see them in Firefox for instance (I can set my default font as Fura Code for instance).
- I can also see them in Terminator, and in Konsole (although I have to deactivate the filter on monospace font, which is weird because the fonts I want to install are monospace)

Expected result :
- I would like to be able to chose them in Gnome-terminal

Note : I suspect Ubuntu GNOME-terminal has extra patches because the box to deactive monospace fonts filter exists there...

Offline

#2 2018-04-04 20:27:02

HalosGhost
Forum Moderator
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,585
Website

Re: Nerd fonts unusable in Gnome-Terminal

Have you tried using the AUR package instead?

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#3 2018-04-04 20:31:09

Jubijub
Member
From: Lausanne, Switzerland
Registered: 2018-04-04
Posts: 10
Website

Re: Nerd fonts unusable in Gnome-Terminal

I did try smile

However :
- only a subset of the fonts have been packaged
- some of those packages are outdated
- there seem to be one that does a full install, but it weights 2Gb because it downloads all fonts, in all variantsm which I don really need.

Also, I looked at what the AUR package do, and they do exactly the same steps.

Offline

#4 2018-04-04 21:53:43

seth
Member
Registered: 2012-09-03
Posts: 7,888

Re: Nerd fonts unusable in Gnome-Terminal

fc-list | grep -i nerd

Edit, scratch that - just saw that the fonts work. They're apparently just not flagged monospace and gnome-terminal filters them.
Did you try to configure the font directly using dconf?

Last edited by seth (2018-04-04 21:58:02)

Online

#5 2018-04-21 16:37:07

ubone
Member
Registered: 2014-08-31
Posts: 40

Re: Nerd fonts unusable in Gnome-Terminal

tell fontconfig to prefer it for monospace

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
  <!-- ## monospace ## -->
  <alias>
    <family>monospace</family>
    <prefer>
      <family>nerd</family>
      <family>xos4 terminus</family>
      <family>liberation mono</family>
    </prefer>
  </alias>
</fontconfig>

Offline

#6 2018-05-10 22:04:30

Jubijub
Member
From: Lausanne, Switzerland
Registered: 2018-04-04
Posts: 10
Website

Re: Nerd fonts unusable in Gnome-Terminal

None of this worked...

For some reasons, only BitStreamVera and SauceCode work as is...
The font work in non-GTK console widget based terminals (like Konsole under KDE)

Offline

#7 2018-08-11 13:17:06

clouduan
Member
Registered: 2018-08-10
Posts: 1

Re: Nerd fonts unusable in Gnome-Terminal

I run into this problem just yesterday when I install vim plugin devicons. After installing nerd fonts in my Ubuntu 18, I found that these nerd fonts were not listed in the gnome terminal.
I did many searches in google, and finally found this method worked for me. Here is the link Link
Steps:

1. Install GNOME Tweaks
2. Set the system monospace font to your nerd font
3. In the Terminal's Font Preference, I leave the Custom Font option unchecked, .i.e use system font.

Offline

Board footer

Powered by FluxBB