You are not logged in.

#51 2018-06-16 09:04:28

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,537
Website

Re: The IWD thread

amish wrote:

Nope - it seems that you are probably not using iwd. Hence do not know what has happened.

https://git.archlinux.org/svntogit/comm … ckages/iwd


Yes, because--as per Arch packaging policy--it is following upstream. Look at their git log.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#52 2018-06-16 09:11:04

amish
Member
Registered: 2014-05-10
Posts: 356

Re: The IWD thread

No he did not follow upstream... thats why I am complaining.

He removed upstream service file first (which was not required) .. introduced his own method of forcing user to use interface files instead.

Now he brings back upstream file (which is still not fixed correctly) - but thats ok.

But there was no need to remove interface service file which he introduced earlier.

So he broke things twice which could have been avoided by keeping both service files. (see my earlier post where I had asked why iwd.service file was removed)

Last edited by amish (2018-06-16 09:12:48)


Forum signature: I discuss. I put my thoughts strongly. But I definitely respect all developers and time they put in.

Offline

#53 2018-07-11 15:06:14

illis
Member
Registered: 2013-09-23
Posts: 12

Re: The IWD thread

Has anyone got connman working with iwd (without wpa_supplicant installed)? I've tried launching connmand on the command line with

connmand --wifi=iwd_agent -n

but can't get scanning to work (No Carrier Error).

After spamming a few disable/enable/scan wifi commands I do get this in the journal.

dbus-daemon[488]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.941" (uid=0 pid=7349 comm="connmand --debug=VERBOSE --wifi=iwd_agent -n ") interface="fi.w1.wpa_supplicant1" member="CreateInterface" error name="(unset)" requested_reply="0" destination="fi.w1.wpa_supplicant1" (uid=0 pid=5268 comm="/usr/bin/wpa_supplicant -u ")

Seems like its still trying to use wpa_supplicant?  I've installed connman via normal community package, which according to the PKGBUILD is supposed to have iwd enabled.

Can't seem to work this one out, any help would be much appreciated!

Offline

#54 2018-07-12 06:29:31

illis
Member
Registered: 2013-09-23
Posts: 12

Re: The IWD thread

Nevermind, managed to get it going. Had a couple of things I needed to do:
- Ignore the `scan wifi`
- Install the iwd-git from the aur, as the 0.3-1 version was giving me grief trying to connect to my 2.4GHz network - 5GHz worked fine.

Offline

#55 2018-07-28 09:43:04

duffydack
Member
Registered: 2012-06-17
Posts: 3

Re: The IWD thread

iwd from repo worked until I rebooted and ended up with a different interface name (the old wlan0).  iwd-git fixed that.  will test few days and then switch if no issues.

Offline

#56 2018-07-28 11:10:40

amish
Member
Registered: 2014-05-10
Posts: 356

Re: The IWD thread

iwd should not (not supposed to) change interface names. It must be something else.


Forum signature: I discuss. I put my thoughts strongly. But I definitely respect all developers and time they put in.

Offline

#57 2018-07-28 14:04:51

duffydack
Member
Registered: 2012-06-17
Posts: 3

Re: The IWD thread

amish wrote:

iwd should not (not supposed to) change interface names. It must be something else.

Yeah, someone earlier mentioned same thing, possibly running before udev renames the if.  Well something got fixed within the last 3 days since the last release was 3 days ago.  I'll stick to -git until repo gets release update.

EDIT: ah crap, it's still failing to rename from wlan0 (systemd-udev saying device or resource busy).  Rare but happens.

Last edited by duffydack (2018-08-11 18:56:23)

Offline

#58 2018-08-12 19:08:25

Sullome
Member
Registered: 2018-08-12
Posts: 2

Re: The IWD thread

I'm having some strange issues with IWD and PEAP-MSCHAPV2.

Previously I used ConnMan + WPA Supplicant. My connection was configured as a separate config file:

% cat /var/lib/connman/<SSID>.config
[service_<SSID>]
Type=wifi
Name=<SSID>
EAP=peap
Phase2=MSCHAPV2
Identity=<LOGIN>
Passphrase=<PASSWORD>
%

And this worked quite well.

I decided to check how IWD works. So I disabled ConnMan and WPA Supplicant (uninstalled it). And also modified .service file for iwd:

% cat /etc/systemd/system/iwd.service 
[Unit]
Description=Wireless service
Before=network.target
Wants=network.target

[Service]
ExecStart=/usr/lib/iwd/iwd
LimitNPROC=1

[Install]
Alias=multi-user.target.wants/iwd.service
%

And configured my connection this way (took this as an example):

% cat /var/lib/iwd/<SSID>.8021x
[Security]
EAP-Method=PEAP
EAP-Identity=anonymous
EAP-PEAP-Phase2-Method=MSCHAPV2
EAP-PEAP-Phase2-Identity=<LOGIN>
EAP-PEAP-Phase2-Password=<PASSWORD>

[Settings]
Autoconnect=True
% 

Well, it failed. Here's the log lines about the connection:

авг 11 19:24:47 chromebook iwd[249]: PEAP TLS tunnel has disconnected with alert: 80
авг 11 19:24:48 chromebook iwd[249]: EAP completed with eapFail
авг 11 19:24:48 chromebook iwd[249]: 4-Way handshake failed for ifindex: 2, reason: 23

If I leave EAP-Identity empty, same thing happens, but without the first line about alert 80. And I think that it's because when it is empty, it fails to initiate PEAP, but with something in this field it does it, but fails to authorize with MSCHAPV2. Not sure about it.
Reason code 23, as far as I managed to find with google, says that there are some authorization errors.

I've already tried to remove Phase2 Identity and Password from the file and connect manually with iwctl — no success, same errors.

Can someone help me with this case?

Offline

#59 2018-08-12 19:53:01

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,761

Re: The IWD thread

Which version of iwd are you using?

0.5 was very quickly superseded by 0.6 to fix some critical bugs.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#60 2018-08-12 21:40:48

Sullome
Member
Registered: 2018-08-12
Posts: 2

Re: The IWD thread

Slithery wrote:

Which version of iwd are you using?

0.5 was very quickly superseded by 0.6 to fix some critical bugs.

0.4
I think I'll wait for 0.6 and try again, then.

Offline

Board footer

Powered by FluxBB