You are not logged in.

#1 2017-10-07 21:20:41

Fred7109
Member
Registered: 2015-05-17
Posts: 134

[SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Hello

I have just reinstalled Arch on my new laptop, and has, on the old laptop, been using Teamviewer without any problems. However, on the new install, after starting the teamviewerd service, I can't start Teamviewer.

When I try to run teamviewer, the following happens:

$ teamviewer

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

It don't continue after "Launching TeamViewer GUI ...".

Any idea on why this happens would be greatly appreciated.

Last edited by Fred7109 (2017-10-08 16:16:55)

Offline

#2 2017-10-08 09:33:12

Boring_nick
Member
Registered: 2017-05-06
Posts: 13

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Same problem here

Offline

#3 2017-10-08 13:35:45

satriani
Member
Registered: 2015-06-26
Posts: 26

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

signed
I have not tried it yet, but let's try the following

teamviewer –daemon start
teamviewer &

let me know if it works

Offline

#4 2017-10-08 14:42:05

firice
Member
Registered: 2017-10-08
Posts: 1

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

This error is posted in the AUR comment section. Take these steps as the work around:
(from here: https://aur.archlinux.org/packages/team … ments=all)

1. clone lib32-freetype:
$ asp checkout lib32-freetype2
$ cd lib32-freetype2/trunk

2: checkout last 2.8 revision:
$ git checkout 3746440f041493db9cb4ada7f328412da9880322

3. build:
$ makepkg -s

3. copy library to Teamviewer's library path:
$ sudo cp pkg/lib32-freetype2/usr/lib32/libfreetype.so.6.14.0 /opt/teamviewer/tv_bin/RTlib/libfreetype.so.6

Offline

#5 2017-10-08 14:57:33

Boring_nick
Member
Registered: 2017-05-06
Posts: 13

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

fixed the problem by installing lib32-freetype2 2.8-2 downloaded from archive

Offline

#6 2017-10-08 16:15:53

Fred7109
Member
Registered: 2015-05-17
Posts: 134

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Thank you for the help Boring_nick, I also got the problem solved by installing lib32-freetype2 2.8-2 downloaded from the archive.

firice wrote:

This error is posted in the AUR comment section. Take these steps as the work around:
(from here: https://aur.archlinux.org/packages/team … ments=all)

Thank you for pointing out it stood in the comment section, which I hadn't seen unfortunately.

satriani wrote:

signed
I have not tried it yet, but let's try the following

teamviewer –daemon start
teamviewer &

let me know if it works

I had started the daemon, however, thank you for pointing it out, as it could have been the problem.

Offline

#7 2017-10-09 14:43:48

telis80
Member
Registered: 2015-03-26
Posts: 90

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Steps to solve:
1) Download https://archive.archlinux.org/packages/ … pkg.tar.xz
2) Move to the folder you downloaded the package.
3) sudo pacman -U lib32-freetype2-2.8-2-x86_64.pkg.tar.xz


I live at the Internet
-Edward Snowden

Offline

#8 2017-10-12 11:06:41

elton35@gmail.com
Member
Registered: 2017-10-12
Posts: 1

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

those steps work for me indeed, thank you!


telis80 wrote:

Steps to solve:
1) Download https://archive.archlinux.org/packages/ … pkg.tar.xz
2) Move to the folder you downloaded the package.
3) sudo pacman -U lib32-freetype2-2.8-2-x86_64.pkg.tar.xz

Offline

#9 2017-10-14 14:55:31

glcv
Member
Registered: 2017-10-14
Posts: 1

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

telis80's commands work for me too !
After a restart ! Thanks a lot guys !

Last edited by glcv (2017-10-14 15:06:01)

Offline

#10 2017-10-23 20:14:01

Argonitious
Member
Registered: 2017-10-23
Posts: 2

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

telis80 wrote:

Steps to solve:
1) Download https://archive.archlinux.org/packages/ … pkg.tar.xz
2) Move to the folder you downloaded the package.
3) sudo pacman -U lib32-freetype2-2.8-2-x86_64.pkg.tar.xz

Thank you so much! This is exactly what I needed to get Teamviewer running again after a recent update.

Offline

#11 2017-11-02 17:49:56

grego1422
Member
From: Argentina
Registered: 2012-07-16
Posts: 5
Website

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Don't forget to also add lib32-freetype2 to IgnorePkgs in /etc/pacman.conf!


Visiten mi blog! Blog para geeks

Offline

#12 2017-11-06 21:53:11

Argonitious
Member
Registered: 2017-10-23
Posts: 2

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

grego1422 wrote:

Don't forget to also add lib32-freetype2 to IgnorePkgs in /etc/pacman.conf!

Oh, that would probably explain why I have to reinstall lib32-freetype2 every time I update. Thanks for the tip! smile

Offline

#13 2017-12-07 10:44:19

Purgator
Member
Registered: 2016-03-02
Posts: 102

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Thank you very much !

Offline

#14 2018-01-25 10:09:19

Gunther74
Member
Registered: 2018-01-21
Posts: 31

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

I had the had the same problem.

That workaround did the trick for me aswell.
Im not sure however that this lib is the real problem.

Before this workaround i did:
# sudo systemctl restart teamviewerd.service
After that i could connect teamviewer aswell. Only i had to do this after every reboot.

I hope this info helps for a permanent fix.

Last edited by Gunther74 (2018-01-25 10:09:56)

Offline

#15 2018-03-31 13:11:01

franco4657
Member
From: Italy
Registered: 2006-10-24
Posts: 11

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Hi, I have same proble with teamviewer13 from aur:

$ teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

and doesn't continue

I have installed freetype2-2.2.9-2, lib32-freetype2-2.9-2, fontconfig 2.13.0+10+g58f5285-1 and lib32-fontconfig 2.13.0+10+g58f5285-1 but it doesn't work even with previous versions freetype2-2.8-2 & fontconfig2.12.6-1

teamviewerd is enabled and started

Any ideas?

Thanks in advance :-D

Last edited by franco4657 (2018-03-31 13:11:32)

Offline

#16 2018-04-02 19:17:40

franco4657
Member
From: Italy
Registered: 2006-10-24
Posts: 11

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Solved with lightdm, teamviewer start only with a DM....at this time

Thanks :-D

Offline

#17 2018-04-20 15:27:41

Qik000
Member
Registered: 2017-09-23
Posts: 61

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

What if i cant downgrad efreetype because of steam ?

Offline

#18 2018-04-20 15:30:28

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,244

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

You do the more sane thing and only provide the old dependency to the old utility https://bbs.archlinux.org/viewtopic.php … 4#p1779224

Offline

#19 2018-06-12 20:35:07

asbachb
Member
Registered: 2016-07-04
Posts: 2

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

The proposed work around does not work for me:

pacman -Q | grep freetype
freetype2 2.9.1-1
lib32-freetype2 2.8-2

systemctl status teamviewerd.service
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/usr/lib/systemd/system/teamviewerd.service; disabled; vendo>
   Active: active (running) since Tue 2018-06-12 21:54:13 CEST; 6min ago
  Process: 2182 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, s>
Main PID: 2184 (teamviewerd)
    Tasks: 16 (limit: 4915)
   Memory: 14.6M
   CGroup: /system.slice/teamviewerd.service
           └─2184 /opt/teamviewer/tv_bin/teamviewerd -d

Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: Starting TeamViewer remote co>
Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: teamviewerd.service: Can't op>
Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: Started TeamViewer remote con>
lines 1-13/13 (END)...skipping...
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/usr/lib/systemd/system/teamviewerd.service; disabled; vendor preset: disabled)
   Active: active (running) since Tue 2018-06-12 21:54:13 CEST; 6min ago
  Process: 2182 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 2184 (teamviewerd)
    Tasks: 16 (limit: 4915)
   Memory: 14.6M
   CGroup: /system.slice/teamviewerd.service
           └─2184 /opt/teamviewer/tv_bin/teamviewerd -d

Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: Starting TeamViewer remote control daemon...
Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: teamviewerd.service: Can't open PID file /var/run/teamviewerd.pid (yet?) after start: No such file or directory
Jun 12 21:54:13 desktop-hp-8200-elite systemd[1]: Started TeamViewer remote control daemon.

teamviewer                                                                                                                                                                  sad

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

Any ideas?

Offline

#20 2018-06-13 08:27:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,244

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

https://wiki.archlinux.org/index.php/Sy … nsupported

Follow the link in my previous post instead.

Offline

#21 2018-08-28 12:54:30

Allexj
Member
Registered: 2015-07-11
Posts: 23

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

If you encounter a dependences problem, it's because you did not enable multilib support. Just follow this: https://wiki.archlinux.org/index.php/of … g_multilib


And then you can install the lib with: sudo pacman -U lib32-freetype2-2.8-2-x86_64.pkg.tar.xz

Offline

#22 2018-08-28 21:17:24

Annoyingduck
Member
Registered: 2016-08-02
Posts: 153

Re: [SOLVED]Teamviewer doesn't continue from "Launching TeamViewer GUI..."

Why is this still being talked about? 32bit libraries are no longer needed. Last post is incorrect information. Unless you are rocking a 32bit system, Teamviewer 13 is pure 64bit and does not require multilib.

Offline

Board footer

Powered by FluxBB