You are not logged in.

#1 2018-07-22 09:31:19

mipi
Member
From: Germany
Registered: 2018-01-03
Posts: 22

System hangs during boot from time to time

Hi,
I installed Arch Linux on my laptop (it's an HP Elitebook 850 G1). From time to time, the boot hangs. To investigate the problem in more detail, I enabled debug, but unfortunately this did not help to figure out the root cause. When the problem occurs, the system seems to be in an endless loop. The following messages are printed on the screen endlessly:

[  250.982527] systemd-journal[301]: Journal effective settings seal=no compress=yes compress_threshold_byte=512B

Of course, the number at the beginning is different for each of these rows.

From time to time, such a row is printed:

[  250.982527] systemd-journal[301]: Sent WATCHDOG=1 notification.

I looked at the debug messages that have been printed before, but I couldn't see any strange things. Last activity that seemed to be done before these message started was the wlan setup, which was OK (no warnings or errors).

What can I do to find out the cause of that behavior?

Thanks,
- mipi

Offline

#2 2018-09-01 14:39:53

skiguy0123
Member
Registered: 2011-01-22
Posts: 9

Re: System hangs during boot from time to time

hi mipi,

Did you make any progress on this issue? I have it as well. (Almost?) every time I have this problem while trying to boot. I managed to get it to boot with systemd.unit=multi-user.target, so i suspect that problem has something to do with gnome/gdm, but I haven't gotten around to investigate it too closely yet.

Offline

#3 2018-09-06 01:51:40

skiguy0123
Member
Registered: 2011-01-22
Posts: 9

Re: System hangs during boot from time to time

Followup, the problem for me was this issue https://bbs.archlinux.org/viewtopic.php?id=238602

TL;DR, uncomment the "WaylandEnable=false" line in /etc/gdm/custom.conf  https://bbs.archlinux.org/viewtopic.php … 9#p1796289

Not sure if that'll fix your problem though.

Offline

#4 2018-09-06 02:01:17

mipi
Member
From: Germany
Registered: 2018-01-03
Posts: 22

Re: System hangs during boot from time to time

Hi skiguy0123,
I did not find out the root cause of the problem. It only occurred from time to time during boot, and was not really reproducible. Now, after upgrading to kernel 4.18 it seems to be solved. Thanks for posting your solution.
-mipi

Last edited by mipi (2018-09-06 02:01:55)

Offline

Board footer

Powered by FluxBB