You are not logged in.

#1 2018-09-14 09:42:11

tallero
Member
Registered: 2018-09-14
Posts: 4

Pulseaudio keep autospawning despite its settings

I've put

autospawn = no"

in both

~/.config/pulse/client.conf

and

/etc/pulse/client.conf

Despite this, pulseaudio continue to restart itself after giving

$ pulseaudio -k

Apparently another person reported the same problem an year ago without receiving feedback from the community.

To reproduce the problem, just put

autospawn = no

in the previously indicated files and try to kill pulseaudio with

$ pulseaudio -k

A new pulseaudio process will start thereafter.
I'm using GNOME in X.org, started through .xinitrc.

I've linked this discussion on the wiki.

Regards, Tallero.

Last edited by tallero (2018-09-14 09:43:02)

Offline

#2 2018-09-14 09:51:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,240

Re: Pulseaudio keep autospawning despite its settings

The client.conf is mostly obsolete, apart from specifiyng a remote server to connect to.  pulseaudio is being started and controlled by a systemd user unit, to disable autospawning you can issue

systemctl --user mask pulseaudio.socket
systemctl --user stop pulseaudio
systemctl --user unmask pulseaudio.socket #To reenable autospawning

which is also mentioned in https://wiki.archlinux.org/index.php/Pulseaudio#Running

Last edited by V1del (2018-09-14 09:52:18)

Offline

#3 2018-09-14 10:05:12

tallero
Member
Registered: 2018-09-14
Posts: 4

Re: Pulseaudio keep autospawning despite its settings

Sorry, until now I always tried to skip learning systemd apart from basic commands, so I skipped that section and I directly clicked on the 'more information' link to the official pulse webpage, which still mentions 'autospawn option' as a *live* option. Also I read outdated info on the troubleshoot page. I'm gonna fix it.

EDIT: fix'd

Last edited by tallero (2018-09-14 11:51:26)

Offline

Board footer

Powered by FluxBB