You are not logged in.

#1 2018-11-09 22:01:17

simplisticways
Member
Registered: 2015-12-03
Posts: 37

Encfs and Pam_mount doesnt seem to work?

Hi guys!


So I started using Encfs, but I felt its kinda tedious to always mount manually and put password.


<volume user="mike" fstype="fuse" path="/home/mike/Cloud/.encrypted" mountpoint="/home/mike/Decrypted" options="nonempty" />


I rebooted computer and its still not doing anything. The passhphrase is the same as the password of the login.

Should there be some additional steps?


Source: https://wiki.archlinux.org/index.php/En … _pam_mount

Offline

#2 2018-11-10 00:27:07

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 438

Re: Encfs and Pam_mount doesnt seem to work?

simplisticways wrote:
<volume user="mike" fstype="fuse" path="/home/mike/Cloud/.encrypted" mountpoint="/home/mike/Decrypted" options="nonempty" />
wiki wrote:
<volume fstype="fuse" path="encfs#/path/to/encfs/encrypted/data" mountpoint="/path/to/decrypted/data/mountpoint" options="nonempty" />

There are some distinct differences between the Wiki example you linked and your configs. Are you using the encfs# prefix in your path value, for example? Your path itself also looks odd to me, I would not expect to see a dot folder underneath your home folder there, but that could be OK, if you know what you're doing.

Offline

#3 2018-11-10 06:05:12

simplisticways
Member
Registered: 2015-12-03
Posts: 37

Re: Encfs and Pam_mount doesnt seem to work?

Hi!

The reason why I have a dot is cos its a hidden directory. Wanted it to not appear on my directory unless I wanted to see it.

I tried with encfs# prefix and without yet it had no effect so I guessed thats working like a comment or something. Tried without the user attribute and also fstype tried auto also without any changes. Almost feels like they are not doing anything.

Offline

Board footer

Powered by FluxBB