You are not logged in.

#1 2019-02-10 14:05:41

K3N8
Member
From: The Netherlands
Registered: 2011-11-02
Posts: 57

[Solved] Error lastest pambase version

Hi guys,

After updating my server I ran into authorisation problems for dovecot with the latest pambase version 20190105.1-1. I got the following error from dovecot:

auth-worker(882): Error: pam([account info],<...>): pam_open_session() failed: Cannot make/remove an entry for the specified session

After I rolled pambase back to the previous version. The problem was gone.

Alexander

Last edited by K3N8 (2019-02-11 10:57:26)


Arch Linux x86_64 LTS

Offline

#2 2019-02-10 16:31:45

K3N8
Member
From: The Netherlands
Registered: 2011-11-02
Posts: 57

Re: [Solved] Error lastest pambase version

I changed /etc/pam.d/dovecot:

from:

auth    required        pam_unix.so nullok
account required        pam_unix.so 

to:

auth     required        pam_unix.so nullok
account  required        pam_unix.so 
password  required        pam_unix.so 
session  required        pam_unix.so 

That seems to fix all the issues with the latest version of pambase!


Arch Linux x86_64 LTS

Offline

#3 2019-02-10 17:40:55

toogy
Member
From: Vancouver, Canada
Registered: 2013-10-25
Posts: 36
Website

Re: [Solved] Error lastest pambase version

Thanks, had the same problem and your fix worked smile


water vapor is invisible

Offline

#4 2019-02-11 09:25:22

K3N8
Member
From: The Netherlands
Registered: 2011-11-02
Posts: 57

Re: [Solved] Error lastest pambase version

Now I have issues with vsftpd.

vsftpd[###]: pam_warn(ftp:auth): function=[pam_sm_authenticate] flags=0 service=[ftp]

I tried to make a file /etc/pam.d/vsftpd with the same information as above but that doesn't work. Any suggestions? This issue will probably effect all applications where you need to authenticate.

Last edited by K3N8 (2019-02-11 10:44:20)


Arch Linux x86_64 LTS

Offline

#5 2019-02-11 10:58:57

K3N8
Member
From: The Netherlands
Registered: 2011-11-02
Posts: 57

Re: [Solved] Error lastest pambase version

This made me think:

pam_warn(ftp:auth)

So I created a /etc/pam.d/ftp instead of /etc/pam.d/vsftpd. That worked!


Arch Linux x86_64 LTS

Offline

#6 2019-03-06 13:17:36

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,811

Re: [Solved] Error lastest pambase version

Thanks man, i was just having the same problem with vsftpd.

Offline

Board footer

Powered by FluxBB