You are not logged in.

#1 2013-10-04 16:11:31

sh_baboli
Member
Registered: 2013-10-04
Posts: 2

netctl works, netctl-auto strikes

Hi everyone!

I switched from wicd to netctl, because wicd did not work well on my notebook, so I generated some wireless profiles using wifi-menu and successfully used them with 'netctl start [profile]' and 'netctl enable [profile]'. Then I wanted to try out netctl-auto, so I installed wpa_actiond and ifplugd and tried 'netctl-auto start [profile]'. There was always this error:

1)
Successfully initialized wpa_supplicant
nl80211: Could not configure driver to use managed mode
Could not read interface [profile] flags: No such device
Could not read interface [profile] flags: No such device
WEXT: Could not set interface '[profile]' UP
[profile]: Failed to initialize driver interface

even with disabled/stopped profiles
(with stopped netctl.service: ’/run/network' no such file or directory)

All my profiles seem to be compatible with netctl-auto.
My wifi-driver is iwlwifi. Google was not able to tell me how to deal with the second line of the error. I tried to load iwlwifi with some other options, but nothing worked. Enabling profiles and using systemd to enable profiles of course does not work too.

'netctl-auto list' is always empty

Are there any options to make netctl-auto work?

Offline

#2 2013-10-05 12:06:10

gandro
Member
From: Switzerland
Registered: 2007-12-22
Posts: 4

Re: netctl works, netctl-auto strikes

netctl-auto works quite differently than netctl. If you'll take a look at the manpage netctl-auto(1), you'll see that netctl-auto start isn't supposed to be called be the user. The start command is used to start the service for a specified interface, not to start a network profile. The commands of netctl-auto look similar to those of netctl, but most of them behave slightly differently, so always check the manpage first.

To enable netctl-auto for your wireless interface, you'll have to start the netctl-auto service using systemctl start netctl-auto@<interface>. netctl-auto will then spawn a wpa_supplicant deamon which will automatically connect to any profile in reach, you don't have to select a profile manually. If you wish to connect to a specific profile when using netctl-auto, just use netctl-auto switch-to [profile].

Last edited by gandro (2013-10-05 12:08:26)

Offline

#3 2013-10-05 15:39:06

sh_baboli
Member
Registered: 2013-10-04
Posts: 2

Re: netctl works, netctl-auto strikes

nice, by reading the man-page I found the right command. I remeber that I tried 'sudo systemctl start netctl-auto@wlp3s0.service' before because one of my profiles generated by wifi-menu had the entry 'interface=wlp3s0'. This still is not working. Now I know all my other profiles had the entry 'interface=wls1' (also generated by wifi-menu). So now netctl-auto works with profiles with the wls1 interface. I think now it will be easy to add those with wlp3s0 to the netctl-auto list too smile
As the service generated with 'sudo systemctl start netctl-auto@wlp3s0.service' used the 'netctl-auto start' command I thought by using it myself I could get any infomation about the error. Next time I will check the man-page first! So at gandro: Thank you very much!! problem solved

Offline

#4 2019-02-12 06:53:24

GSokol
Member
Registered: 2019-02-12
Posts: 1

Re: netctl works, netctl-auto strikes

Check your interfaces using 'ip link'

Offline

#5 2019-02-12 09:33:48

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,581
Website

Re: netctl works, netctl-auto strikes

Please don't necrobump, GSokol. Also note that OP has solved their problem.

https://wiki.archlinux.org/index.php/Co … bumping%22

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB