You are not logged in.

#1 2019-07-11 13:47:16

Themaister
Member
From: Trondheim, Norway
Registered: 2008-07-21
Posts: 652
Website

[RESOLVED] Anyone got AMD RX 5700 (XT) to work?

This is bleeding edge hardware on a new architecture, so I expect having to build a lot of stuff from Git. Got various links which apparently worked for some people, but I had no luck.
Has anyone gotten these cards to work yet on Arch?

Some links I got if anyone wants to try at their own risk:
Linux repo: https://cgit.freedesktop.org/~agd5f/linux/. There are some branches here. I tried drm-next as it seemed most recent. I hacked up the linux-git PKGBUILD and pointed to this branch.
Firmware: https://people.freedesktop.org/~agd5f/r … de/navi10/. Copy-pasted this to /lib/firmware/amdgpu/.

I end up crashing somewhere on boot in the amdgpu module, and dmesg detects something, so it's definitely detecting the card.

Last edited by Themaister (2019-07-24 11:32:38)

Offline

#2 2019-07-11 14:40:32

loqs
Member
Registered: 2014-03-06
Posts: 8,823

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Please post the dmesg output.

Offline

#3 2019-07-12 14:37:12

Themaister
Member
From: Trondheim, Norway
Registered: 2008-07-21
Posts: 652
Website

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Ok, some success! I built the linux-drm-next-git package from AUR instead, and this time I can boot into graphics with llvmpipe. Time to figure out Mesa, but promising now.

Offline

#4 2019-07-12 17:04:47

blisbell
Member
Registered: 2014-08-02
Posts: 15

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Just to add I am having the same issue in dmesg amdgpu is crashing trying to load the firmware.this is the error it gives. I am using LordHeavy mesa repo and built the same drm-next kernel.
amdgpu 0000:0e:00.0: Direct firmware load for amdgpu/navi10_me.bin failed with error -2

Offline

#5 2019-07-12 17:23:43

Themaister
Member
From: Trondheim, Norway
Registered: 2008-07-21
Posts: 652
Website

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Right, for that issue you need to download the firmware from https://people.freedesktop.org/~agd5f/r … de/navi10/, place it in /lib/firmware/amdgpu and re-run mkinitcpio.
Hacking away this branch might also be necessary. https://cgit.freedesktop.org/~agd5f/lin … avi10#n265 I didn't have to do that though ...

Last edited by Themaister (2019-07-12 18:11:57)

Offline

#6 2019-07-12 19:57:13

blisbell
Member
Registered: 2014-08-02
Posts: 15

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

I have  linux-drm-next-git from aur lordheavy mesa-git repo firmware from agd5f. Tried re-run mkinitcpio also. This is my dmesg for error.

amdgpu 0000:09:00.0: Direct firmware load for amdgpu/navi10_me.bin failed with error -2
[    3.656364] amdgpu 0000:09:00.0: gfx10: Failed to load firmware "amdgpu/navi10_me.bin"
[    3.656433] [drm:gfx_v10_0_sw_init.cold [amdgpu]] *ERROR* Failed to load gfx firmware!
[    3.656490] [drm:amdgpu_device_init.cold [amdgpu]] *ERROR* sw_init of IP block <gfx_v10_0> failed -2
[    3.656493] amdgpu 0000:09:00.0: amdgpu_device_ip_init failed
[    3.656495] amdgpu 0000:09:00.0: Fatal error during GPU init
[    3.656497] [drm] amdgpu: finishing device.
[    3.656861] ------------[ cut here ]------------
[    3.656861] Memory manager not clean during takedown.
[    3.656880] WARNING: CPU: 13 PID: 445 at drivers/gpu/drm/drm_mm.c:939 drm_mm_takedown+0x1f/0x30 [drm]
[    3.656880] Modules linked in: amdgpu(+) xfs edac_mce_amd fuse libcrc32c kvm irqbypass amd_iommu_v2 gpu_sched i2c_algo_bit ttm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel drm_kms_helper snd_hda_codec_hdmi snd_hda_intel drm snd_hda_codec snd_hda_core eeepc_wmi asus_wmi snd_hwdep sparse_keymap rfkill aesni_intel snd_pcm joydev agpgart input_leds mousedev aes_x86_64 led_class syscopyarea crypto_simd video evdev wmi_bmof sysfillrect mac_hid sysimgblt snd_timer cryptd r8169 fb_sys_fops glue_helper sp5100_tco i2c_piix4 snd realtek libphy soundcore pcspkr k10temp ccp rng_core wmi button pcc_cpufreq acpi_cpufreq sch_fq_codel it87(O) hwmon_vid ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 hid_logitech_hidpp hid_logitech_dj hid_generic usbhid hid sd_mod ahci libahci xhci_pci crc32c_intel libata xhci_hcd usbcore scsi_mod usb_common
[    3.656902] CPU: 13 PID: 445 Comm: systemd-udevd Tainted: G           O      5.2.0-rc5-drm-next-git-1f9a5dce3548+ #1
[    3.656902] Hardware name: System manufacturer System Product Name/PRIME B350-PLUS, BIOS 5007 06/19/2019
[    3.656910] RIP: 0010:drm_mm_takedown+0x1f/0x30 [drm]
[    3.656911] Code: e9 ec fd ff ff e8 21 05 29 f3 90 0f 1f 44 00 00 48 8b 47 38 48 83 c7 38 48 39 c7 75 01 c3 48 c7 c7 30 86 e3 c0 e8 f0 07 29 f3 <0f> 0b c3 66 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 00 0f 1f 44 00 00
[    3.656911] RSP: 0018:ffffb6720264f9a0 EFLAGS: 00010286
[    3.656912] RAX: 0000000000000000 RBX: ffff8b7a38844218 RCX: 0000000000000006
[    3.656913] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff8b7a4e957440
[    3.656913] RBP: ffff8b7a38844088 R08: 00000000000003b0 R09: 0000000000000004
[    3.656914] R10: 0000000000000000 R11: 0000000000000001 R12: ffff8b7a47b6b600
[    3.656914] R13: ffff8b7a47b6b6e8 R14: 0000000000000170 R15: 0000000000000000
[    3.656915] FS:  00007f9bd0330840(0000) GS:ffff8b7a4e940000(0000) knlGS:0000000000000000
[    3.656915] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    3.656916] CR2: 00005579dfafc000 CR3: 000000040936a000 CR4: 00000000003406e0
[    3.656916] Call Trace:
[    3.656963]  amdgpu_vram_mgr_fini+0x2d/0xa0 [amdgpu]
[    3.656968]  ttm_bo_clean_mm+0x9f/0xb0 [ttm]
[    3.657010]  amdgpu_ttm_fini+0x71/0xd0 [amdgpu]
[    3.657053]  amdgpu_bo_fini+0xe/0x30 [amdgpu]
[    3.657101]  gmc_v10_0_sw_fini+0x2e/0x40 [amdgpu]
[    3.657160]  amdgpu_device_fini+0x24f/0x475 [amdgpu]
[    3.657202]  amdgpu_driver_unload_kms+0x4a/0x90 [amdgpu]
[    3.657260]  amdgpu_driver_load_kms.cold+0x8f/0xb1 [amdgpu]
[    3.657268]  drm_dev_register+0x111/0x150 [drm]
[    3.657310]  amdgpu_pci_probe+0xbd/0x120 [amdgpu]
[    3.657312]  ? __pm_runtime_resume+0x49/0x60
[    3.657314]  local_pci_probe+0x42/0x80
[    3.657316]  ? pci_match_device+0xd7/0x100
[    3.657316]  pci_device_probe+0x112/0x190
[    3.657318]  really_probe+0xf0/0x390
[    3.657320]  driver_probe_device+0xb6/0x100
[    3.657321]  device_driver_attach+0x53/0x60
[    3.657322]  __driver_attach+0x8a/0x150
[    3.657323]  ? device_driver_attach+0x60/0x60
[    3.657324]  bus_for_each_dev+0x78/0xc0
[    3.657325]  bus_add_driver+0x14a/0x1e0
[    3.657326]  driver_register+0x6c/0xb0
[    3.657327]  ? 0xffffffffc0bc4000
[    3.657329]  do_one_initcall+0x46/0x224
[    3.657332]  ? kmem_cache_alloc_trace+0x169/0x1c0
[    3.657333]  ? do_init_module+0x23/0x230
[    3.657334]  do_init_module+0x5c/0x230
[    3.657335]  load_module+0x22c1/0x28a0
[    3.657338]  ? vmap_page_range_noflush+0x23c/0x350
[    3.657339]  ? __do_sys_init_module+0x169/0x190
[    3.657340]  __do_sys_init_module+0x169/0x190
[    3.657342]  do_syscall_64+0x4e/0x120
[    3.657344]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[    3.657345] RIP: 0033:0x7f9bd1b19b3e
[    3.657346] Code: 48 8b 0d 55 f3 0b 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa 49 89 ca b8 af 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 22 f3 0b 00 f7 d8 64 89 01 48
[    3.657347] RSP: 002b:00007fffd9f79ad8 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
[    3.657348] RAX: ffffffffffffffda RBX: 00005579df2c89a0 RCX: 00007f9bd1b19b3e
[    3.657348] RDX: 00005579df2b9d30 RSI: 0000000000828ec0 RDI: 00005579dfcc1d00
[    3.657348] RBP: 00005579df2b9d30 R08: 000000000000005f R09: 00005579df2c1670
[    3.657349] R10: 00005579df2a5010 R11: 0000000000000246 R12: 00005579dfcc1d00
[    3.657349] R13: 00005579df2e4760 R14: 0000000000020000 R15: 00005579df2c89a0
[    3.657350] ---[ end trace 3b5a3e4441e00ce8 ]---
[    3.657356] [TTM] Finalizing pool allocator
[    3.657357] [TTM] Finalizing DMA pool allocator
[    3.657380] [TTM] Zone  kernel: Used memory at exit: 50 KiB
[    3.657381] [TTM] Zone   dma32: Used memory at exit: 0 KiB
[    3.657381] [drm] amdgpu: ttm finalized
[    3.657396] ------------[ cut here ]------------
[    3.657396] sysfs group 'fw_version' not found for kobject '0000:09:00.0'
[    3.657400] WARNING: CPU: 13 PID: 445 at fs/sysfs/group.c:254 sysfs_remove_group+0x74/0x80
[    3.657400] Modules linked in: amdgpu(+) xfs edac_mce_amd fuse libcrc32c kvm irqbypass amd_iommu_v2 gpu_sched i2c_algo_bit ttm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel drm_kms_helper snd_hda_codec_hdmi snd_hda_intel drm snd_hda_codec snd_hda_core eeepc_wmi asus_wmi snd_hwdep sparse_keymap rfkill aesni_intel snd_pcm joydev agpgart input_leds mousedev aes_x86_64 led_class syscopyarea crypto_simd video evdev wmi_bmof sysfillrect mac_hid sysimgblt snd_timer cryptd r8169 fb_sys_fops glue_helper sp5100_tco i2c_piix4 snd realtek libphy soundcore pcspkr k10temp ccp rng_core wmi button pcc_cpufreq acpi_cpufreq sch_fq_codel it87(O) hwmon_vid ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 hid_logitech_hidpp hid_logitech_dj hid_generic usbhid hid sd_mod ahci libahci xhci_pci crc32c_intel libata xhci_hcd usbcore scsi_mod usb_common
[    3.657412] CPU: 13 PID: 445 Comm: systemd-udevd Tainted: G        W  O      5.2.0-rc5-drm-next-git-1f9a5dce3548+ #1
[    3.657413] Hardware name: System manufacturer System Product Name/PRIME B350-PLUS, BIOS 5007 06/19/2019
[    3.657414] RIP: 0010:sysfs_remove_group+0x74/0x80
[    3.657414] Code: ff 5b 48 89 ef 5d 41 5c e9 89 bc ff ff 48 89 ef e8 61 b9 ff ff eb cc 49 8b 14 24 48 8b 33 48 c7 c7 d8 2e e5 b4 e8 fb af d6 ff <0f> 0b 5b 5d 41 5c c3 0f 1f 44 00 00 0f 1f 44 00 00 48 85 f6 74 31
[    3.657415] RSP: 0018:ffffb6720264fa18 EFLAGS: 00010286
[    3.657415] RAX: 0000000000000000 RBX: ffffffffc1142ba0 RCX: 0000000000000006
[    3.657416] RDX: 0000000000000007 RSI: 0000000000000086 RDI: ffff8b7a4e957440
[    3.657416] RBP: 0000000000000000 R08: 00000000000003f1 R09: 0000000000000004
[    3.657416] R10: 0000000000000000 R11: 0000000000000001 R12: ffff8b7a4ba420b0
[    3.657417] R13: ffff8b7a3884ffd0 R14: ffff8b7a48f601b0 R15: 0000000000000000
[    3.657418] FS:  00007f9bd0330840(0000) GS:ffff8b7a4e940000(0000) knlGS:0000000000000000
[    3.657418] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    3.657419] CR2: 00005579dfafc000 CR3: 000000040936a000 CR4: 00000000003406e0
[    3.657419] Call Trace:
[    3.657478]  amdgpu_device_fini+0x441/0x475 [amdgpu]
[    3.657520]  amdgpu_driver_unload_kms+0x4a/0x90 [amdgpu]
[    3.657578]  amdgpu_driver_load_kms.cold+0x8f/0xb1 [amdgpu]
[    3.657586]  drm_dev_register+0x111/0x150 [drm]
[    3.657627]  amdgpu_pci_probe+0xbd/0x120 [amdgpu]
[    3.657628]  ? __pm_runtime_resume+0x49/0x60
[    3.657629]  local_pci_probe+0x42/0x80
[    3.657630]  ? pci_match_device+0xd7/0x100
[    3.657631]  pci_device_probe+0x112/0x190
[    3.657632]  really_probe+0xf0/0x390
[    3.657633]  driver_probe_device+0xb6/0x100
[    3.657635]  device_driver_attach+0x53/0x60
[    3.657636]  __driver_attach+0x8a/0x150
[    3.657636]  ? device_driver_attach+0x60/0x60
[    3.657637]  bus_for_each_dev+0x78/0xc0
[    3.657638]  bus_add_driver+0x14a/0x1e0
[    3.657639]  driver_register+0x6c/0xb0
[    3.657640]  ? 0xffffffffc0bc4000
[    3.657641]  do_one_initcall+0x46/0x224
[    3.657642]  ? kmem_cache_alloc_trace+0x169/0x1c0
[    3.657643]  ? do_init_module+0x23/0x230
[    3.657644]  do_init_module+0x5c/0x230
[    3.657645]  load_module+0x22c1/0x28a0
[    3.657646]  ? vmap_page_range_noflush+0x23c/0x350
[    3.657648]  ? __do_sys_init_module+0x169/0x190
[    3.657649]  __do_sys_init_module+0x169/0x190
[    3.657650]  do_syscall_64+0x4e/0x120
[    3.657652]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[    3.657652] RIP: 0033:0x7f9bd1b19b3e
[    3.657653] Code: 48 8b 0d 55 f3 0b 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa 49 89 ca b8 af 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 22 f3 0b 00 f7 d8 64 89 01 48
[    3.657654] RSP: 002b:00007fffd9f79ad8 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
[    3.657654] RAX: ffffffffffffffda RBX: 00005579df2c89a0 RCX: 00007f9bd1b19b3e
[    3.657655] RDX: 00005579df2b9d30 RSI: 0000000000828ec0 RDI: 00005579dfcc1d00
[    3.657655] RBP: 00005579df2b9d30 R08: 000000000000005f R09: 00005579df2c1670
[    3.657655] R10: 00005579df2a5010 R11: 0000000000000246 R12: 00005579dfcc1d00
[    3.657656] R13: 00005579df2e4760 R14: 0000000000020000 R15: 00005579df2c89a0
[    3.657657] ---[ end trace 3b5a3e4441e00ce9 ]---
[    3.657769] amdgpu: probe of 0000:09:00.0 failed with error -2

Offline

#7 2019-07-12 21:17:01

blisbell
Member
Registered: 2014-08-02
Posts: 15

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Some success agd5f has new firmware dated today copied those and built latest drm-next from agd5f. I now have it running but having graphical glitches with chrome and cinnamon de has major problems.
Swtch to mate de and seems to be working fine  untill anything using qt5 is opened then de starts flickering and graphical glitches are back.

Last edited by blisbell (2019-07-12 21:17:41)

Offline

#8 2019-07-13 08:41:15

Themaister
Member
From: Trondheim, Norway
Registered: 2008-07-21
Posts: 652
Website

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Alright, managed to build llvm-git and mesa-git and I'm getting something. Just like you, there's a ton of glitches, and not really usable yet. GNOME 3 glitches out completely. Kind of expected I guess considering how early days it is.
The steps seem to be then:
- Download firmware files and place them in /lib/firmware/amdgpu.
- Build linux-drm-next-git
- This should now boot and detect the GPU.
- Build llvm-git (I had to use --nocheck, ymmv).
- Build mesa-git.

Offline

#9 2019-07-13 11:53:03

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,300

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

You could try with llvm-minimal-git .
Mesa-git lists some of the differences between llvm-git & llvm-minimal-git.
(I haven't gotten around to adding such info to llvm-git & llvm-minimal-git pages yet).


Gnome relies heavily on mutter for graphics support, you may need a development version of mutter.
The same will probably apply to KDE - Kwin, for testing I'd suggests something like openbox or twm .


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#10 2019-07-18 17:59:47

abihf
Member
Registered: 2019-07-18
Posts: 1

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Does anyone here able to run vulkan application on RX 5700 xt?
I use linux-amd-staging-drm-next-git, and mesa-git that I build my self. I also tried to use vulkan-amdgpu-pro, but no luck.

Offline

#11 2019-07-18 18:18:31

progandy
Member
Registered: 2012-05-17
Posts: 3,547

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

You can try the open source amdvlk drivers maintained by AMD. https://github.com/GPUOpen-Drivers/AMDVLK

The closed source variant doesn't mention the RX 5700 yet.

For the mesa RADV driver, is it enabled in your git build and do you have to install a split package like vulkan-radeon-git? That driver should be part of the coming 19.2 release.

Last edited by progandy (2019-07-18 18:22:54)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#12 2019-07-20 02:15:08

blisbell
Member
Registered: 2014-08-02
Posts: 15

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

A update with linux-and-git from aur tagged with  drm-next-5.3-2019-07-18 commit lordheavy's mesa-git repo and firmware everything but steam is stable now.
opening steam linux brings back the glicthes,but steam in wine runs fine and some games will run with dxvk. not with steam linux though.

Offline

#13 2019-07-20 13:37:40

Themaister
Member
From: Trondheim, Norway
Registered: 2008-07-21
Posts: 652
Website

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

That is encouraging, I'll try rebuilding kernel and see where that leads.
EDIT: Woo! big_smile The flickering is gone now.

Last edited by Themaister (2019-07-20 14:05:12)

Offline

#14 2019-07-25 16:18:03

sirn
Member
Registered: 2009-06-23
Posts: 7

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Just want to mention that I managed to port DKMS package from Radeon Software for Linux 19.30 to work on Arch:
https://aur.archlinux.org/packages/amdgpu-dkms/

I've been experimenting it with dual Radeon RX 5700XT (and 3900X) for few days before releasing it on AUR (with libgl from amdgpu-pro-* packages by Ashark) and it has working relatively stable so far. I haven't tried using it with mesa-git, however…

Edit: I just tried amdgpu-dkms + mesa-git from lordheavy's repo and it seems to be working!

Last edited by sirn (2019-07-26 08:33:19)

Offline

#15 2019-07-28 09:57:15

dllu
Member
Registered: 2015-10-11
Posts: 9

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

the linux-amd-staging-drm-next-git kernel with lordheavy's mesa-git as well as agd5f's latest firmware (from 2019-07-23) work wonderfully! I am getting good framerates in both Dota 2 (running natively) as well as Starcraft II (running in Wine with d9vk + radv).

Unfortunately the card is severely prone to overheating:

https://pics.dllu.net/file/dllu-sc/TfDSs7MbHWtHwltx.png

any ideas? It seems like I may have to get that Arctic Accelero Xtreme IV...


moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by 2ManyDogs (2019-07-28 14:06:54)

Offline

#16 2019-07-28 11:09:14

progandy
Member
Registered: 2012-05-17
Posts: 3,547

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#17 2019-07-29 08:14:04

sirn
Member
Registered: 2009-06-23
Posts: 7

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

AFAIK, SMC fan control is still disabled in SMU v11 code on all drm-next branches (amdgpu-19.30 doesn't have temperature reading via hwmon at all). Though it's possible to patch smu_v11_0.c  to enable fan control support. See the bottom of this Reddit post https://www.reddit.com/r/linux_gaming/c … is_usable/

Offline

#18 2019-08-02 22:52:18

dllu
Member
Registered: 2015-10-11
Posts: 9

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Someone wrote a kernel patch to enable fan control for the 5700 XT https://www.reddit.com/r/Amd/comments/c … ustom_fan/

It seems to be  basically the same as the patch linked in the previous comment above.

I noticed that by default, my card's fan was only spinning up to 2000 rpm out of a maximum of 4750 rpm.

Also, recent kernel updates seems to make idle power consumption of the 5700 XT vastly better, down to around 9 to 10 W instead of 30 W. hooray!

Last edited by dllu (2019-08-02 22:55:41)

Offline

#19 2019-08-03 03:59:35

sirus20x6
Member
Registered: 2014-07-11
Posts: 16

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

does anyone have a copy of the firmware from 7/23? the one from 8/2 is broken and I didnt leave myself a backup. it appears it's just on a file server too and not in the git so I can't just redownload old versions.

[    2.201254] amdgpu 0000:0a:00.0: VRAM: 8176M 0x0000008000000000 - 0x00000081FEFFFFFF (8176M used)
[    2.201255] amdgpu 0000:0a:00.0: GART: 512M 0x0000000000000000 - 0x000000001FFFFFFF
[    2.201261] [drm] Detected VRAM RAM=8176M, BAR=256M
[    2.201262] [drm] RAM width 256bits GDDR6
[    2.201505] [TTM] Zone  kernel: Available graphics memory: 16428414 KiB
[    2.201506] [TTM] Zone   dma32: Available graphics memory: 2097152 KiB
[    2.201507] [TTM] Initializing pool allocator
[    2.201510] [TTM] Initializing DMA pool allocator
[    2.201531] [drm] amdgpu: 8176M of VRAM memory ready
[    2.201533] [drm] amdgpu: 8176M of GTT memory ready.
[    2.201544] [drm] GART: num cpu pages 131072, num gpu pages 131072
[    2.201652] [drm] PCIE GART of 512M enabled (table at 0x0000008000000000).
[    2.201846] [drm] ppt_offset_bytes: 3
[    2.201846] [drm] ppt_size_bytes: 262912
[    2.201965] amdgpu 0000:0a:00.0: gfx10: Failed to load firmware "amdgpu/navi10_ce.bin"
[    2.202057] [drm:gfx_v10_0_sw_init.cold [amdgpu]] *ERROR* Failed to load gfx firmware!
[    2.202111] [drm:amdgpu_device_init.cold [amdgpu]] *ERROR* sw_init of IP block <gfx_v10_0> failed -22
[    2.202112] amdgpu 0000:0a:00.0: amdgpu_device_ip_init failed
[    2.202113] amdgpu 0000:0a:00.0: Fatal error during GPU init
[    2.202115] [drm] amdgpu: finishing device.

Last edited by sirus20x6 (2019-08-03 04:02:38)

Offline

#20 2019-08-03 08:04:05

progandy
Member
Registered: 2012-05-17
Posts: 3,547

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Fedora has the versions from 2019-07-15 in their firmware package package: https://koji.fedoraproject.org/koji/bui … ID=1314657
It is enough to download the source package instead of the full build.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#21 2019-08-04 10:43:02

blisbell
Member
Registered: 2014-08-02
Posts: 15

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Here are the firmware from 2019-7-23 https://www.sendspace.com/file/oxgatp

Offline

#22 2019-08-09 12:59:13

thagabe
Member
Registered: 2019-08-09
Posts: 2

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Hello friends,

I will have to ask for forgiveness for being slow to understand, please forgive my soul.

I have:

1) used yay -G linux-git to only get metadata for the build (Mainly pkgbuild)
2) edited pkgbuild to point to git://people.freedesktop.org/~agd5f/linux#branch=drm-next
3) Downloaded sources to the default /src folder
4) Downloaded @blisbell 2019-7-23 firmware blobs (13 in total) and copied content inside /src/linux/lib/firmware/amdgpu
5) cwd to ~/linux-git/ and ran $ makepkg -s to build firmware

build succeeded but I see things like "usr/lib/modules/5.2.0-rc5-gb136e8671542/build/tools/objtool/objtool" and "linux-git drm.next.5.4.2019.08.06.r4.g6edb98330e88-1" but I'm pretty sure I'm trying to build kernel 5.3 with a custom firmware binary so I'm not sure what exactly is going on.

I have not installed my kernel yet and I have not build llvm-git (or llvm-minimal-git) or mesa-git. I will do this once I can see the kernel pick up the card. I guess now I am asking you all if I did the build correctly, what should I have done, and what should I do to improve my builds? Also would the linux-git pkgbuild grab my current kernel-config? or do I need manually tell it where to look?

Again sorry if any questions are noob-ish!

Offline

#23 2019-08-09 14:11:19

loqs
Member
Registered: 2014-03-06
Posts: 8,823

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

thagabe wrote:

build succeeded but I see things like "usr/lib/modules/5.2.0-rc5-gb136e8671542/build/tools/objtool/objtool" and "linux-git drm.next.5.4.2019.08.06.r4.g6edb98330e88-1" but I'm pretty sure I'm trying to build kernel 5.3 with a custom firmware binary so I'm not sure what exactly is going on.

I believe you built https://cgit.freedesktop.org/~agd5f/lin … 4ef5104dbf in which the latest tag is drm-next-5.4-2019-08-06 with 4 additional revisions which explains  "linux-git drm.next.5.4.2019.08.06.r4.g6edb98330e88-1"
The version string 5.2.0-rc5 comes from https://cgit.freedesktop.org/~agd5f/lin … 4ef5104dbf but b136e8671542 is a different commit https://cgit.freedesktop.org/~agd5f/lin … 20f2469012

Offline

#24 2019-08-09 18:27:32

thagabe
Member
Registered: 2019-08-09
Posts: 2

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

loqs wrote:

I believe you built https://cgit.freedesktop.org/~agd5f/lin … 4ef5104dbf in which the latest tag is drm-next-5.4-2019-08-06 with 4 additional revisions which explains  "linux-git drm.next.5.4.2019.08.06.r4.g6edb98330e88-1"
The version string 5.2.0-rc5 comes from https://cgit.freedesktop.org/~agd5f/lin … 4ef5104dbf but b136e8671542 is a different commit https://cgit.freedesktop.org/~agd5f/lin … 20f2469012


I see, so this means that the kernel that was built should be fine albeit more bleeding edge compared to 5.3 per say?

Offline

#25 2019-08-09 18:42:34

loqs
Member
Registered: 2014-03-06
Posts: 8,823

Re: [RESOLVED] Anyone got AMD RX 5700 (XT) to work?

Newer amdgpu while the rest of the kernel is from 5.2 release candidate 5 so missing the commits from release candidates 6 and 7,
the actual 5.2,  the commits up to v5.3-rc3 from mainline or the commits up to v5.2.7 from stable.

Offline

Board footer

Powered by FluxBB