You are not logged in.

#1 2019-08-13 18:46:52

buttcake
Member
Registered: 2016-10-16
Posts: 34

[Solved][x220] wifi not working on bootup most of the time

I've had this bug for a while but recently it god a lot worse.
Whenever I boot up my x220, wlan is either not present at all or DOWN and DORMANT and I cannot bring it up. The only thing that works is restarting.
This scenario fits fine with this part from the iwlegacy driver:
>If you have problems connecting to networks in general, random failures with your card on bootup
so I tried creating /etc/modprobe.d/iwlwifi.conf with options iwlwifi 11n_disable=1 but it solves nothing.

How can I get to the bottom of this ? It's really wierd.

Last edited by buttcake (2019-08-14 08:19:55)

Offline

#2 2019-08-13 18:49:32

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,112
Website

Re: [Solved][x220] wifi not working on bootup most of the time

Anything in dmesg, or your journal?

Are you dual booting with Windows?


Moving to NC...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#3 2019-08-13 23:18:45

buttcake
Member
Registered: 2016-10-16
Posts: 34

Re: [Solved][x220] wifi not working on bootup most of the time

I am not dual booting with windows.
Here's dmesg and journalctl when it starts down and dormant:
http://0x0.st/zVfQ.txt
http://0x0.st/zVfj.txt
and here they are when is starts up and dormant:
http://0x0.st/zVf2.txt
http://0x0.st/zVfe.txt

I mean there's no difference that's why I said I don't know how to tackle this.

Last edited by buttcake (2019-08-13 23:22:02)

Offline

#4 2019-08-13 23:23:16

loqs
Member
Registered: 2014-03-06
Posts: 9,056

Re: [Solved][x220] wifi not working on bootup most of the time

The links you provides only contain 9 or 10 lines of content rather than a whole dmesg or the whole journal for one boot which would include the dmesg.

Offline

#5 2019-08-13 23:25:49

buttcake
Member
Registered: 2016-10-16
Posts: 34

Re: [Solved][x220] wifi not working on bootup most of the time

I am sorry I was under the impression only the information regarding iwlwifi is needed.

Last edited by buttcake (2019-08-14 08:20:14)

Offline

#6 2019-08-13 23:30:27

loqs
Member
Registered: 2014-03-06
Posts: 9,056

Re: [Solved][x220] wifi not working on bootup most of the time

Offline

#7 2019-08-13 23:44:27

buttcake
Member
Registered: 2016-10-16
Posts: 34

Re: [Solved][x220] wifi not working on bootup most of the time

Ok, got the full dmesg.
First case where it works: http://0x0.st/zVff.txt
Second case where it doesn't: http://0x0.st/zVfO.txt

Offline

#8 2019-08-14 00:07:16

loqs
Member
Registered: 2014-03-06
Posts: 9,056

Re: [Solved][x220] wifi not working on bootup most of the time

Entropy issue?
On the failure case

[  107.245491] random: crng init done

While on the successful case it is much earlier

[    9.045300] random: crng init done

If the system supports RDRAND you could try adding the boot parameter random.trust_cpu=on if it does not try installing and enabling haveged.

Offline

#9 2019-08-14 08:19:17

buttcake
Member
Registered: 2016-10-16
Posts: 34

Re: [Solved][x220] wifi not working on bootup most of the time

Holy shit that was it I would have never thought about that. All this time wasted on trying out different combinations of modprobe options. Thank you a lot.

Offline

Board footer

Powered by FluxBB