You are not logged in.

#1 2004-03-16 04:40:27

Guest
Guest

cant connect to the internet!!

Hi i am trying to connect to the internet with arch but i really cant.

im using a router and dhcp, this is my rc.conf networking part:

HOSTNAME="myhost"

lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)

gateway="default gw 192.168.200.254"
ROUTES=(!gateway)

DAEMONS=(syslogd klogd !pcmcia network netfs crond)

i got the drivers, 8139too, installed through modprobe,
an alias in modules.conf, 
and when running ifconfig eth0 up i get nothing returned so i thing it is working
i also tried the command dhcpcd and it says that it is already running

Then when i do a pacman -sy pacman i get nothing
what should i do?

Thanks a lot in advance Daniel
dsk1985@hotmail.com

#2 2004-03-16 06:49:45

yak8998
Member
Registered: 2004-03-01
Posts: 143

Re: cant connect to the internet!!

so

ifconfig eth0

returns nothing? if thats the case than something is wrong

have you tried modprobing the drivers after boot to make sure theyre loading? And are you sure you have your aliases defined right?


"Ignorance is bliss, for stupid people."
"open-source is [...] programming Darwinism."
Vaughan-Nichols

Offline

#3 2004-03-16 10:33:20

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: cant connect to the internet!!

How about putting your modules (8139) in rc.conf ?

ping -c 3 www.google.com ?

Search forum for post on dhcp there are many !

Mr Green


Mr Green

Offline

#4 2004-03-16 11:59:50

Shemeta
Member
Registered: 2004-02-11
Posts: 117

Re: cant connect to the internet!!

i think he meant that

ifconfig eth0 up

didn't show anything. & then after that if you do

ifconfig

or

ifconfig eth0

you can see what is working & what not.

Offline

#5 2004-03-17 03:48:16

cartridge
Member
From: Porto Alegre, Brazil
Registered: 2003-02-07
Posts: 45
Website

Re: cant connect to the internet!!

try :
modprobe 8139too
dhcpcd eth0

Offline

Board footer

Powered by FluxBB