You are not logged in.

#1 2019-11-25 18:53:48

mchoji
Member
Registered: 2019-11-25
Posts: 4

[SOLVED] Archlinux domain hanging on IPv6 access

Hi, guys

Recently my ISP enabled IPv6 addresses, so I decided to try it.
I have setup both router and host, and everything looks fine (passed all the web tests about ipv6 connectivity).

However, when I try to access archlinux.org domain the connection hangs indefinitely. I have found a workaround for Firefox which consists of setting `network.dns.ipv4OnlyDomains` so I think there could be some issue with the arch server, since most of websites simply fallback to IPv4 by default.

Running a wget gives this:

--2019-11-25 12:40:04--  http://archlinux.org/
Resolving archlinux.org (archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://archlinux.org/ [following]
--2019-11-25 12:40:05--  https://archlinux.org/
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.

Using `--inet4-only` returns the page correctly as setting that Firefox parameter...

Last edited by mchoji (2019-11-28 01:33:34)

Offline

#2 2019-11-25 19:08:25

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,870

Re: [SOLVED] Archlinux domain hanging on IPv6 access

Was that the complete output?  What happens if you try to wget the redirect address it gives you?
On my system, it redirects and downloads from the secure site. ewaller@odin/home/ewaller/tmp % wget http://archlinux.org

--2019-11-25 11:05:23--  http://archlinux.org/
Resolving archlinux.org (archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://archlinux.org/ [following]
--2019-11-25 11:05:24--  https://archlinux.org/
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.archlinux.org/ [following]
--2019-11-25 11:05:24--  https://www.archlinux.org/
Resolving www.archlinux.org (www.archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to www.archlinux.org (www.archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 24322 (24K) [text/html]
Saving to: ‘index.html’

index.html                               100%[===============================================================================>]  23.75K  --.-KB/s    in 0s

2019-11-25 11:05:26 (87.0 MB/s) - ‘index.html’ saved [24322/24322]

ewaller@odin/home/ewaller/tmp %

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-11-25 23:17:19

mchoji
Member
Registered: 2019-11-25
Posts: 4

Re: [SOLVED] Archlinux domain hanging on IPv6 access

Yes, that was the complete ouptut by that time. After the message saying it was connected the terminal hanged until get interrupted manually. In fact, even upgrading AUR packages was not working.
Luckily my terminal was still open and I could get the output from `yay -Syu`:

:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
Get https://aur.archlinux.org/rpc.php?arg%5B%5D=ccls&arg%5B%5D=clamav-unofficial-sigs&arg%5B%5D=conky-nvidia&arg%5B%5D=customizepkg&arg%5B%5D=evince-light&type=info&v=5: net/http: TLS handshake timeout

For any reason, the requests are ok by now. See output from `wget archlinux.org`

URL transformed to HTTPS due to an HSTS policy
--2019-11-25 16:57:36--  https://archlinux.org/
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving archlinux.org (archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.archlinux.org/ [following]
--2019-11-25 16:57:37--  https://www.archlinux.org/
Resolving www.archlinux.org (www.archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to www.archlinux.org (www.archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 24022 (23K) [text/html]
Saving to: ‘index.html’

index.html                                      100%[====================================================================================================>]  23.46K  --.-KB/s    in 0s      

2019-11-25 16:57:39 (163 MB/s) - ‘index.html’ saved [24022/24022]

As you may see, there is this new message at the beginning "URL transformed to HTTPS due to an HSTS policy". Browsers and yay are also reaching archlinux.org without issues now. No change was made in my system.

Offline

#4 2019-11-25 23:20:10

fukawi2
Administrator
From: .vic.au
Registered: 2007-09-28
Posts: 5,781
Website

Re: [SOLVED] Archlinux domain hanging on IPv6 access

I'd say the issue is/was with your ISP if they've only just rolled out IPv6 (yay for them!).

IPv6 is working fine from here also, and has been deployed on the Arch servers for quite some time:

$ wget -L archlinux.org >/dev/null
--2019-11-26 10:18:55--  http://archlinux.org/
Resolving archlinux.org (archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://archlinux.org/ [following]
--2019-11-26 10:18:55--  https://archlinux.org/
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Connecting to archlinux.org (archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.archlinux.org/ [following]
--2019-11-26 10:18:57--  https://www.archlinux.org/
Resolving www.archlinux.org (www.archlinux.org)... 2a01:4f8:172:1d86::1, 138.201.81.199
Connecting to www.archlinux.org (www.archlinux.org)|2a01:4f8:172:1d86::1|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 24018 (23K) [text/html]
Saving to: ‘index.html’

index.html                         100%[================================================================>]  23.46K  --.-KB/s    in 0.03s   

2019-11-26 10:18:59 (824 KB/s) - ‘index.html’ saved [24018/24018]

EDIT: If you continue to have issue, jump on #archlinux-devops on Freenode and one of us can try debugging with you live if we're available.

Last edited by fukawi2 (2019-11-25 23:21:00)

Offline

#5 2019-11-28 01:32:59

mchoji
Member
Registered: 2019-11-25
Posts: 4

Re: [SOLVED] Archlinux domain hanging on IPv6 access

Yeah, no more issues since then and still using IPv6....who knows what happened...
Anyway, thanks for your attention guys! I took note of the irc channel for the next time smile

Offline

Board footer

Powered by FluxBB