You are not logged in.

#1 2019-12-16 19:00:47

matcharles
Member
From: Canada
Registered: 2015-03-08
Posts: 19

[SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

I'm having a similar problem but not related to Uranium per se. I just can't seem to get out of this. Removing either of them doesn't work because of dependencies.

┌[~] 
└─> sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra                                                                                                                                                           1646.7 KiB  7.88 MiB/s 00:00 [######################################################################################################################] 100%
 community                                                                                                                                                          4.8 MiB  51.2 MiB/s 00:00 [######################################################################################################################] 100%
 multilib is up to date
:: Starting full system upgrade...
warning: deluge: ignoring package upgrade (1.3.15+18+ge050905b2-1 => 2.0.3+23+g5f1eada3e-1)
warning: python-msgpack: ignoring package upgrade (0.5.6-2 => 0.6.2-3)
warning: python2-msgpack: ignoring package upgrade (0.5.6-2 => 0.6.2-3)
resolving dependencies...
looking for conflicting packages...
:: python2-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python2-pyqt5 and pyqt5-common are in conflict

pactree for both is pretty intimidating. I'm lost any help appreciated! Thanks!

┌[~] 
└─> pactree pyqt5-common
pyqt5-common
└─qt5-base
  ├─libjpeg-turbo
  ├─xcb-util-keysyms
  │ └─libxcb provides libxcb>=1.7
  │   ├─xcb-proto provides xcb-proto>=1.12
  │   ├─libxdmcp
  │   │ ├─xorgproto provides xproto
  │   │ └─glibc
  │   │   ├─linux-api-headers provides linux-api-headers>=4.10
  │   │   ├─tzdata
  │   │   └─filesystem
  │   │     └─iana-etc
  │   └─libxau
  │     ├─glibc
  │     └─xorgproto provides xproto
  ├─xcb-util-renderutil
  │ └─libxcb provides libxcb>=1.7
  ├─libglvnd provides libgl
  │ ├─libxext
  │ │ ├─libx11
  │ │ │ ├─libxcb
  │ │ │ ├─xorgproto provides xproto
  │ │ │ └─xorgproto provides kbproto
  │ │ └─xorgproto provides xextproto
  │ ├─mesa
  │ │ ├─libdrm
  │ │ │ └─libpciaccess
  │ │ │   └─glibc
  │ │ ├─wayland
  │ │ │ ├─glibc
  │ │ │ ├─libffi
  │ │ │ │ └─glibc
  │ │ │ ├─expat
  │ │ │ │ └─glibc
  │ │ │ └─libxml2
  │ │ │   ├─zlib
  │ │ │   │ └─glibc
  │ │ │   ├─readline
  │ │ │   │ ├─glibc
  │ │ │   │ ├─ncurses
  │ │ │   │ │ ├─glibc
  │ │ │   │ │ └─gcc-libs
  │ │ │   │ │   └─glibc provides glibc>=2.27
  │ │ │   │ └─ncurses provides libncursesw.so=6-64
  │ │ │   ├─ncurses
  │ │ │   ├─xz
  │ │ │   │ └─bash provides sh
  │ │ │   │   ├─readline provides readline>=7.0
  │ │ │   │   ├─glibc
  │ │ │   │   └─ncurses
  │ │ │   └─icu
  │ │ │     ├─gcc-libs
  │ │ │     └─bash provides sh
  │ │ ├─libxxf86vm
  │ │ │ ├─libxext
  │ │ │ └─xorgproto provides xf86vidmodeproto
  │ │ ├─libxdamage
  │ │ │ ├─libxfixes provides libxfixes>=4.0.4
  │ │ │ │ ├─libx11
  │ │ │ │ └─xorgproto provides fixesproto
  │ │ │ └─xorgproto provides damageproto
  │ │ ├─libxshmfence
  │ │ │ └─glibc
  │ │ ├─libelf
  │ │ │ ├─gcc-libs
  │ │ │ ├─zlib
  │ │ │ ├─bzip2
  │ │ │ │ ├─glibc
  │ │ │ │ └─bash provides sh
  │ │ │ └─xz
  │ │ ├─libomxil-bellagio
  │ │ │ └─glibc
  │ │ ├─libunwind
  │ │ │ ├─glibc
  │ │ │ └─xz
  │ │ ├─llvm-libs
  │ │ │ ├─gcc-libs
  │ │ │ ├─zlib
  │ │ │ ├─libffi
  │ │ │ ├─libedit
  │ │ │ │ └─ncurses
  │ │ │ ├─ncurses
  │ │ │ └─libxml2
  │ │ ├─lm_sensors
  │ │ │ └─perl
  │ │ │   ├─gdbm provides gdbm>=1.17
  │ │ │   │ ├─glibc
  │ │ │   │ └─bash provides sh
  │ │ │   ├─db
  │ │ │   │ ├─gcc-libs
  │ │ │   │ └─bash provides sh
  │ │ │   └─glibc
  │ │ └─libglvnd
  │ └─mesa provides opengl-driver
  ├─fontconfig
  │ ├─expat
  │ └─freetype2
  │   ├─zlib
  │   ├─bzip2
  │   ├─bash provides sh
  │   ├─libpng
  │   │ ├─zlib
  │   │ └─bash provides sh
  │   └─harfbuzz
  │     ├─glib2
  │     │ ├─pcre
  │     │ │ ├─gcc-libs
  │     │ │ ├─readline
  │     │ │ ├─zlib
  │     │ │ ├─bzip2
  │     │ │ └─bash
  │     │ ├─libffi
  │     │ ├─libutil-linux
  │     │ └─zlib
  │     ├─freetype2
  │     └─graphite
  │       └─gcc-libs
  ├─xdg-utils
  │ ├─bash provides sh
  │ ├─which
  │ │ ├─glibc
  │ │ └─bash
  │ ├─file
  │ │ ├─glibc
  │ │ └─zlib
  │ ├─xorg-xset
  │ │ └─libxmu
  │ │   ├─libxext
  │ │   └─libxt
  │ │     ├─libsm
  │ │     │ ├─libice
  │ │     │ │ ├─glibc
  │ │     │ │ └─xorgproto provides xproto
  │ │     │ └─libutil-linux
  │ │     └─libx11
  │ └─xorg-xprop
  │   └─libx11
  ├─shared-mime-info
  │ ├─libxml2
  │ └─glib2
  ├─xcb-util-wm
  │ └─libxcb provides libxcb>=1.7
  ├─libxrender
  │ ├─libx11 provides libx11>=1.3.4
  │ └─xorgproto provides renderproto
  ├─libxi
  │ ├─libxext
  │ └─xorgproto provides inputproto
  ├─sqlite
  │ ├─readline
  │ └─zlib
  ├─xcb-util-image
  │ ├─libxcb provides libxcb>=1.7
  │ └─xcb-util provides xcb-util>=0.3.9
  │   └─libxcb provides libxcb>=1.7
  ├─mesa
  ├─tslib
  │ └─glibc
  ├─libinput
  │ ├─mtdev
  │ │ └─glibc
  │ ├─systemd
  │ │ ├─acl
  │ │ │ └─attr
  │ │ │   └─glibc
  │ │ ├─bash
  │ │ ├─cryptsetup
  │ │ │ ├─device-mapper
  │ │ │ │ ├─glibc
  │ │ │ │ └─systemd-libs
  │ │ │ │   ├─glibc
  │ │ │ │   ├─libcap
  │ │ │ │   │ ├─glibc
  │ │ │ │   │ └─attr
  │ │ │ │   ├─libgcrypt
  │ │ │ │   │ └─libgpg-error
  │ │ │ │   │   ├─glibc
  │ │ │ │   │   └─bash provides sh
  │ │ │ │   ├─lz4
  │ │ │ │   │ └─glibc
  │ │ │ │   └─xz
  │ │ │ ├─openssl
  │ │ │ │ └─perl
  │ │ │ ├─popt
  │ │ │ │ └─glibc
  │ │ │ ├─libutil-linux
  │ │ │ ├─json-c
  │ │ │ │ └─glibc
  │ │ │ └─argon2
  │ │ │   └─glibc
  │ │ ├─dbus
  │ │ │ ├─systemd-libs
  │ │ │ ├─expat
  │ │ │ └─audit
  │ │ │   ├─krb5
  │ │ │   │ ├─e2fsprogs
  │ │ │   │ │ ├─bash provides sh
  │ │ │   │ │ └─libutil-linux
  │ │ │   │ ├─libldap
  │ │ │   │ │ ├─libsasl
  │ │ │   │ │ │ └─openssl
  │ │ │   │ │ └─e2fsprogs
  │ │ │   │ └─keyutils
  │ │ │   │   ├─glibc
  │ │ │   │   └─bash provides sh
  │ │ │   └─libcap-ng
  │ │ │     └─glibc
  │ │ ├─iptables
  │ │ │ ├─libnftnl
  │ │ │ │ └─libmnl
  │ │ │ │   └─glibc
  │ │ │ ├─libpcap
  │ │ │ │ ├─glibc
  │ │ │ │ ├─libnl
  │ │ │ │ │ └─glibc
  │ │ │ │ ├─bash provides sh
  │ │ │ │ ├─libusb provides libusbx
  │ │ │ │ │ ├─glibc
  │ │ │ │ │ └─systemd-libs
  │ │ │ │ └─dbus
  │ │ │ ├─libnfnetlink
  │ │ │ │ └─glibc
  │ │ │ ├─libnetfilter_conntrack
  │ │ │ │ ├─libnfnetlink
  │ │ │ │ └─libmnl
  │ │ │ └─bash
  │ │ ├─kbd
  │ │ │ ├─glibc
  │ │ │ └─pam
  │ │ │   ├─glibc
  │ │ │   ├─cracklib
  │ │ │   │ ├─glibc
  │ │ │   │ └─zlib
  │ │ │   ├─libtirpc
  │ │ │   │ └─krb5
  │ │ │   └─pambase
  │ │ ├─kmod
  │ │ │ ├─glibc
  │ │ │ ├─zlib
  │ │ │ ├─openssl
  │ │ │ └─xz
  │ │ ├─hwids
  │ │ ├─libcap
  │ │ ├─libgcrypt
  │ │ ├─systemd-libs
  │ │ ├─libidn2
  │ │ │ └─libunistring
  │ │ │   └─glibc
  │ │ ├─libidn2 provides libidn2.so=0-64
  │ │ ├─lz4
  │ │ ├─pam
  │ │ ├─libelf
  │ │ ├─libseccomp
  │ │ │ └─glibc
  │ │ ├─util-linux
  │ │ │ ├─pam
  │ │ │ ├─shadow
  │ │ │ │ ├─pam
  │ │ │ │ ├─acl
  │ │ │ │ ├─audit
  │ │ │ │ └─audit provides libaudit.so=1-64
  │ │ │ ├─coreutils
  │ │ │ │ ├─glibc
  │ │ │ │ ├─acl
  │ │ │ │ ├─attr
  │ │ │ │ ├─gmp
  │ │ │ │ │ ├─gcc-libs
  │ │ │ │ │ └─bash provides sh
  │ │ │ │ ├─libcap
  │ │ │ │ └─openssl
  │ │ │ ├─systemd-libs
  │ │ │ ├─libcap-ng
  │ │ │ └─libutil-linux
  │ │ ├─xz
  │ │ ├─pcre2
  │ │ │ ├─gcc-libs
  │ │ │ ├─readline
  │ │ │ ├─zlib
  │ │ │ ├─bzip2
  │ │ │ └─bash
  │ │ └─audit
  │ ├─libevdev
  │ │ └─glibc
  │ └─libwacom
  │   ├─glib2
  │   ├─systemd
  │   └─libgudev
  │     ├─systemd-libs
  │     └─glib2
  ├─libxkbcommon-x11
  │ ├─libxkbcommon
  │ │ ├─xkeyboard-config
  │ │ └─glibc
  │ └─libxcb
  ├─libproxy
  │ └─gcc-libs
  ├─libcups
  │ ├─gnutls
  │ │ ├─gcc-libs
  │ │ ├─libtasn1
  │ │ │ └─glibc
  │ │ ├─readline
  │ │ ├─zlib
  │ │ ├─nettle
  │ │ │ └─gmp
  │ │ ├─p11-kit
  │ │ │ ├─glibc
  │ │ │ ├─libtasn1
  │ │ │ ├─libffi
  │ │ │ └─systemd
  │ │ ├─libidn2
  │ │ ├─libidn2 provides libidn2.so=0-64
  │ │ └─libunistring
  │ ├─libtiff provides libtiff>=4.0.0
  │ │ ├─libjpeg-turbo provides libjpeg
  │ │ ├─zlib
  │ │ ├─xz
  │ │ └─zstd
  │ │   ├─zlib
  │ │   ├─xz
  │ │   └─lz4
  │ ├─libpng provides libpng>=1.5.7
  │ ├─krb5
  │ ├─avahi
  │ │ ├─expat
  │ │ ├─libdaemon
  │ │ ├─glib2
  │ │ ├─libcap
  │ │ ├─gdbm
  │ │ └─dbus
  │ └─libusb
  └─double-conversion
    └─gcc-libs

┌[~] 
└─> pactree python2-pyqt5
python2-pyqt5
├─python2-sip-pyqt5
│ └─python2
│   ├─bzip2
│   │ ├─glibc
│   │ │ ├─linux-api-headers provides linux-api-headers>=4.10
│   │ │ ├─tzdata
│   │ │ └─filesystem
│   │ │   └─iana-etc
│   │ └─bash provides sh
│   │   ├─readline provides readline>=7.0
│   │   │ ├─glibc
│   │   │ ├─ncurses
│   │   │ │ ├─glibc
│   │   │ │ └─gcc-libs
│   │   │ │   └─glibc provides glibc>=2.27
│   │   │ └─ncurses provides libncursesw.so=6-64
│   │   ├─glibc
│   │   └─ncurses
│   ├─expat
│   │ └─glibc
│   ├─gdbm
│   │ ├─glibc
│   │ └─bash provides sh
│   ├─libffi
│   │ └─glibc
│   ├─libnsl
│   │ └─libtirpc
│   │   └─krb5
│   │     ├─e2fsprogs
│   │     │ ├─bash provides sh
│   │     │ └─libutil-linux
│   │     ├─libldap
│   │     │ ├─libsasl
│   │     │ │ └─openssl
│   │     │ │   └─perl
│   │     │ │     ├─gdbm provides gdbm>=1.17
│   │     │ │     ├─db
│   │     │ │     │ ├─gcc-libs
│   │     │ │     │ └─bash provides sh
│   │     │ │     └─glibc
│   │     │ └─e2fsprogs
│   │     └─keyutils
│   │       ├─glibc
│   │       └─bash provides sh
│   ├─openssl
│   ├─sqlite
│   │ ├─readline
│   │ └─zlib
│   │   └─glibc
│   └─zlib
├─pyqt5-common
│ └─qt5-base
│   ├─libjpeg-turbo
│   ├─xcb-util-keysyms
│   │ └─libxcb provides libxcb>=1.7
│   │   ├─xcb-proto provides xcb-proto>=1.12
│   │   ├─libxdmcp
│   │   │ ├─xorgproto provides xproto
│   │   │ └─glibc
│   │   └─libxau
│   │     ├─glibc
│   │     └─xorgproto provides xproto
│   ├─xcb-util-renderutil
│   │ └─libxcb provides libxcb>=1.7
│   ├─libglvnd provides libgl
│   │ ├─libxext
│   │ │ ├─libx11
│   │ │ │ ├─libxcb
│   │ │ │ ├─xorgproto provides xproto
│   │ │ │ └─xorgproto provides kbproto
│   │ │ └─xorgproto provides xextproto
│   │ ├─mesa
│   │ │ ├─libdrm
│   │ │ │ └─libpciaccess
│   │ │ │   └─glibc
│   │ │ ├─wayland
│   │ │ │ ├─glibc
│   │ │ │ ├─libffi
│   │ │ │ ├─expat
│   │ │ │ └─libxml2
│   │ │ │   ├─zlib
│   │ │ │   ├─readline
│   │ │ │   ├─ncurses
│   │ │ │   ├─xz
│   │ │ │   │ └─bash provides sh
│   │ │ │   └─icu
│   │ │ │     ├─gcc-libs
│   │ │ │     └─bash provides sh
│   │ │ ├─libxxf86vm
│   │ │ │ ├─libxext
│   │ │ │ └─xorgproto provides xf86vidmodeproto
│   │ │ ├─libxdamage
│   │ │ │ ├─libxfixes provides libxfixes>=4.0.4
│   │ │ │ │ ├─libx11
│   │ │ │ │ └─xorgproto provides fixesproto
│   │ │ │ └─xorgproto provides damageproto
│   │ │ ├─libxshmfence
│   │ │ │ └─glibc
│   │ │ ├─libelf
│   │ │ │ ├─gcc-libs
│   │ │ │ ├─zlib
│   │ │ │ ├─bzip2
│   │ │ │ └─xz
│   │ │ ├─libomxil-bellagio
│   │ │ │ └─glibc
│   │ │ ├─libunwind
│   │ │ │ ├─glibc
│   │ │ │ └─xz
│   │ │ ├─llvm-libs
│   │ │ │ ├─gcc-libs
│   │ │ │ ├─zlib
│   │ │ │ ├─libffi
│   │ │ │ ├─libedit
│   │ │ │ │ └─ncurses
│   │ │ │ ├─ncurses
│   │ │ │ └─libxml2
│   │ │ ├─lm_sensors
│   │ │ │ └─perl
│   │ │ └─libglvnd
│   │ └─mesa provides opengl-driver
│   ├─fontconfig
│   │ ├─expat
│   │ └─freetype2
│   │   ├─zlib
│   │   ├─bzip2
│   │   ├─bash provides sh
│   │   ├─libpng
│   │   │ ├─zlib
│   │   │ └─bash provides sh
│   │   └─harfbuzz
│   │     ├─glib2
│   │     │ ├─pcre
│   │     │ │ ├─gcc-libs
│   │     │ │ ├─readline
│   │     │ │ ├─zlib
│   │     │ │ ├─bzip2
│   │     │ │ └─bash
│   │     │ ├─libffi
│   │     │ ├─libutil-linux
│   │     │ └─zlib
│   │     ├─freetype2
│   │     └─graphite
│   │       └─gcc-libs
│   ├─xdg-utils
│   │ ├─bash provides sh
│   │ ├─which
│   │ │ ├─glibc
│   │ │ └─bash
│   │ ├─file
│   │ │ ├─glibc
│   │ │ └─zlib
│   │ ├─xorg-xset
│   │ │ └─libxmu
│   │ │   ├─libxext
│   │ │   └─libxt
│   │ │     ├─libsm
│   │ │     │ ├─libice
│   │ │     │ │ ├─glibc
│   │ │     │ │ └─xorgproto provides xproto
│   │ │     │ └─libutil-linux
│   │ │     └─libx11
│   │ └─xorg-xprop
│   │   └─libx11
│   ├─shared-mime-info
│   │ ├─libxml2
│   │ └─glib2
│   ├─xcb-util-wm
│   │ └─libxcb provides libxcb>=1.7
│   ├─libxrender
│   │ ├─libx11 provides libx11>=1.3.4
│   │ └─xorgproto provides renderproto
│   ├─libxi
│   │ ├─libxext
│   │ └─xorgproto provides inputproto
│   ├─sqlite
│   ├─xcb-util-image
│   │ ├─libxcb provides libxcb>=1.7
│   │ └─xcb-util provides xcb-util>=0.3.9
│   │   └─libxcb provides libxcb>=1.7
│   ├─mesa
│   ├─tslib
│   │ └─glibc
│   ├─libinput
│   │ ├─mtdev
│   │ │ └─glibc
│   │ ├─systemd
│   │ │ ├─acl
│   │ │ │ └─attr
│   │ │ │   └─glibc
│   │ │ ├─bash
│   │ │ ├─cryptsetup
│   │ │ │ ├─device-mapper
│   │ │ │ │ ├─glibc
│   │ │ │ │ └─systemd-libs
│   │ │ │ │   ├─glibc
│   │ │ │ │   ├─libcap
│   │ │ │ │   │ ├─glibc
│   │ │ │ │   │ └─attr
│   │ │ │ │   ├─libgcrypt
│   │ │ │ │   │ └─libgpg-error
│   │ │ │ │   │   ├─glibc
│   │ │ │ │   │   └─bash provides sh
│   │ │ │ │   ├─lz4
│   │ │ │ │   │ └─glibc
│   │ │ │ │   └─xz
│   │ │ │ ├─openssl
│   │ │ │ ├─popt
│   │ │ │ │ └─glibc
│   │ │ │ ├─libutil-linux
│   │ │ │ ├─json-c
│   │ │ │ │ └─glibc
│   │ │ │ └─argon2
│   │ │ │   └─glibc
│   │ │ ├─dbus
│   │ │ │ ├─systemd-libs
│   │ │ │ ├─expat
│   │ │ │ └─audit
│   │ │ │   ├─krb5
│   │ │ │   └─libcap-ng
│   │ │ │     └─glibc
│   │ │ ├─iptables
│   │ │ │ ├─libnftnl
│   │ │ │ │ └─libmnl
│   │ │ │ │   └─glibc
│   │ │ │ ├─libpcap
│   │ │ │ │ ├─glibc
│   │ │ │ │ ├─libnl
│   │ │ │ │ │ └─glibc
│   │ │ │ │ ├─bash provides sh
│   │ │ │ │ ├─libusb provides libusbx
│   │ │ │ │ │ ├─glibc
│   │ │ │ │ │ └─systemd-libs
│   │ │ │ │ └─dbus
│   │ │ │ ├─libnfnetlink
│   │ │ │ │ └─glibc
│   │ │ │ ├─libnetfilter_conntrack
│   │ │ │ │ ├─libnfnetlink
│   │ │ │ │ └─libmnl
│   │ │ │ └─bash
│   │ │ ├─kbd
│   │ │ │ ├─glibc
│   │ │ │ └─pam
│   │ │ │   ├─glibc
│   │ │ │   ├─cracklib
│   │ │ │   │ ├─glibc
│   │ │ │   │ └─zlib
│   │ │ │   ├─libtirpc
│   │ │ │   └─pambase
│   │ │ ├─kmod
│   │ │ │ ├─glibc
│   │ │ │ ├─zlib
│   │ │ │ ├─openssl
│   │ │ │ └─xz
│   │ │ ├─hwids
│   │ │ ├─libcap
│   │ │ ├─libgcrypt
│   │ │ ├─systemd-libs
│   │ │ ├─libidn2
│   │ │ │ └─libunistring
│   │ │ │   └─glibc
│   │ │ ├─libidn2 provides libidn2.so=0-64
│   │ │ ├─lz4
│   │ │ ├─pam
│   │ │ ├─libelf
│   │ │ ├─libseccomp
│   │ │ │ └─glibc
│   │ │ ├─util-linux
│   │ │ │ ├─pam
│   │ │ │ ├─shadow
│   │ │ │ │ ├─pam
│   │ │ │ │ ├─acl
│   │ │ │ │ ├─audit
│   │ │ │ │ └─audit provides libaudit.so=1-64
│   │ │ │ ├─coreutils
│   │ │ │ │ ├─glibc
│   │ │ │ │ ├─acl
│   │ │ │ │ ├─attr
│   │ │ │ │ ├─gmp
│   │ │ │ │ │ ├─gcc-libs
│   │ │ │ │ │ └─bash provides sh
│   │ │ │ │ ├─libcap
│   │ │ │ │ └─openssl
│   │ │ │ ├─systemd-libs
│   │ │ │ ├─libcap-ng
│   │ │ │ └─libutil-linux
│   │ │ ├─xz
│   │ │ ├─pcre2
│   │ │ │ ├─gcc-libs
│   │ │ │ ├─readline
│   │ │ │ ├─zlib
│   │ │ │ ├─bzip2
│   │ │ │ └─bash
│   │ │ └─audit
│   │ ├─libevdev
│   │ │ └─glibc
│   │ └─libwacom
│   │   ├─glib2
│   │   ├─systemd
│   │   └─libgudev
│   │     ├─systemd-libs
│   │     └─glib2
│   ├─libxkbcommon-x11
│   │ ├─libxkbcommon
│   │ │ ├─xkeyboard-config
│   │ │ └─glibc
│   │ └─libxcb
│   ├─libproxy
│   │ └─gcc-libs
│   ├─libcups
│   │ ├─gnutls
│   │ │ ├─gcc-libs
│   │ │ ├─libtasn1
│   │ │ │ └─glibc
│   │ │ ├─readline
│   │ │ ├─zlib
│   │ │ ├─nettle
│   │ │ │ └─gmp
│   │ │ ├─p11-kit
│   │ │ │ ├─glibc
│   │ │ │ ├─libtasn1
│   │ │ │ ├─libffi
│   │ │ │ └─systemd
│   │ │ ├─libidn2
│   │ │ ├─libidn2 provides libidn2.so=0-64
│   │ │ └─libunistring
│   │ ├─libtiff provides libtiff>=4.0.0
│   │ │ ├─libjpeg-turbo provides libjpeg
│   │ │ ├─zlib
│   │ │ ├─xz
│   │ │ └─zstd
│   │ │   ├─zlib
│   │ │   ├─xz
│   │ │   └─lz4
│   │ ├─libpng provides libpng>=1.5.7
│   │ ├─krb5
│   │ ├─avahi
│   │ │ ├─expat
│   │ │ ├─libdaemon
│   │ │ ├─glib2
│   │ │ ├─libcap
│   │ │ ├─gdbm
│   │ │ └─dbus
│   │ └─libusb
│   └─double-conversion
│     └─gcc-libs
└─python2-enum34
  └─python2

Last edited by matcharles (2019-12-17 01:21:18)


The good thing about science is that it's true whether or not you believe in it.
    - Neil DeGrasse Tyson

Offline

#2 2019-12-16 19:54:33

loqs
Member
Registered: 2014-03-06
Posts: 9,607

Re: [SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

warning: deluge: ignoring package upgrade (1.3.15+18+ge050905b2-1 => 2.0.3+23+g5f1eada3e-1)
warning: python-msgpack: ignoring package upgrade (0.5.6-2 => 0.6.2-3)
warning: python2-msgpack: ignoring package upgrade (0.5.6-2 => 0.6.2-3)

Why are those packages not being upgraded?

Offline

#3 2019-12-16 20:04:05

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,307
Website

Re: [SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

I think this problem is sufficiently different to warrant it's own thread.

Mod note: Split from https://bbs.archlinux.org/viewtopic.php?id=251356


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2019-12-17 00:09:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,403

Re: [SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

The problem is that you're answering "N" to the question. If course it can't continue.

Last edited by Scimmia (2019-12-17 00:09:55)

Offline

#5 2019-12-17 01:20:23

matcharles
Member
From: Canada
Registered: 2015-03-08
Posts: 19

Re: [SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

Scimmia wrote:

The problem is that you're answering "N" to the question. If course it can't continue.

Wow. Call me silly but I'm sure I had tried the obvious. Well in any case, this fixed it. Sorry folks!


loqs wrote:

Why are those packages not being upgraded?

For unrelated reasons, I need to have those specific versions installed on my system.


The good thing about science is that it's true whether or not you believe in it.
    - Neil DeGrasse Tyson

Offline

#6 2019-12-17 01:21:57

Trilby
Banned
Registered: 2011-11-29
Posts: 22,631
Website

Re: [SOLVED]Cannot upgrade: python2-pyqt5 and pyqt5-common are in conflict

And your pactree output is irrelevant.  The results of `pactree -r` could be argued to be relevant (though not needed here at all), but normal pactree output certainly isn't.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB