You are not logged in.

#1 2020-01-27 17:46:14

y7dk9
Member
Registered: 2020-01-27
Posts: 2

wpa_dbus_property_changed errors

Recently (since last few kernel upgrades), I've been getting (every hour or so) errors:

wpa_supplicant[855]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/0
wpa_supplicant[855]: dbus: wpa_dbus_property_changed: no property RoamTime in object /fi/w1/wpa_supplicant1/Interfaces/0
wpa_supplicant[855]: dbus: wpa_dbus_property_changed: no property RoamComplete in object /fi/w1/wpa_supplicant1/Interfaces/0

while wifi mostly works (although I seem to experience some delays every now and then in loading pages).
Is this bug known?

Offline

#2 2020-01-28 10:38:03

gilcu3
Member
Registered: 2011-04-12
Posts: 9

Re: wpa_dbus_property_changed errors

I am having the same problem here. Every now and then, network stops working, although wifi is supposed to be connected. Reconnecting fixes the issue for me.

dmesg output:

$ dmesg -wH
[Jan28 12:05] wlp2s0: disassociated from 58:97:bd:62:d6:1d (Reason: 1=UNSPECIFIED)
[  +1.539488] wlp2s0: authenticate with 58:97:bd:66:9e:e2
[  +0.004125] wlp2s0: send auth to 58:97:bd:66:9e:e2 (try 1/3)
[  +0.001008] wlp2s0: authenticated
[  +0.001995] wlp2s0: associate with 58:97:bd:66:9e:e2 (try 1/3)
[  +0.001202] wlp2s0: RX AssocResp from 58:97:bd:66:9e:e2 (capab=0x431 status=0 aid=4)
[  +0.001210] wlp2s0: associated
[  +0.125558] wlp2s0: Limiting TX power to 4 dBm as advertised by 58:97:bd:66:9e:e2

Last edited by gilcu3 (2020-01-28 11:16:59)

Offline

#3 2020-01-28 16:49:11

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,175
Website

Re: wpa_dbus_property_changed errors

It's traditional to include details of the hardware in threads like this. Don't get me wrong, I love a challenge, but guessing gets boring after a while.

The connection method is also particularly relevant, a list of enabled services will show that (along with any potential conflicts):

systemctl list-unit-files --state=enabled

And my standard advice is to at least try the LTS kernel, because regressions.

Offline

#4 2020-01-29 13:07:14

gilcu3
Member
Registered: 2011-04-12
Posts: 9

Re: wpa_dbus_property_changed errors

Head_on_a_Stick wrote:

It's traditional to include details of the hardware in threads like this. Don't get me wrong, I love a challenge, but guessing gets boring after a while.

The connection method is also particularly relevant, a list of enabled services will show that (along with any potential conflicts):

systemctl list-unit-files --state=enabled

And my standard advice is to at least try the LTS kernel, because regressions.

Ups yeah, I should have put more system info.

$ systemctl list-unit-files --state=enabled
NIT FILE                                   STATE  
org.cups.cupsd.path                         enabled
acpid.service                               enabled
autovt@.service                             enabled
avahi-daemon.service                        enabled
bluetooth.service                           enabled
dbus-org.bluez.service                      enabled
dbus-org.freedesktop.Avahi.service          enabled
dbus-org.freedesktop.ModemManager1.service  enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
display-manager.service                     enabled
getty@.service                              enabled
gpm.service                                 enabled
haveged.service                             enabled
lightdm.service                             enabled
ModemManager.service                        enabled
NetworkManager-dispatcher.service           enabled
NetworkManager.service                      enabled
org.cups.cupsd.service                      enabled
sshd.service                                enabled
systemd-timesyncd.service                   enabled
tlp.service                                 enabled
avahi-daemon.socket                         enabled
org.cups.cupsd.socket                       enabled
remote-fs.target                            enabled
fstrim.timer                                enabled
$ lspci -k
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
	Kernel driver in use: skl_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 05)
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: Micro-Star International Co., Ltd. [MSI] HD Graphics 630
	Kernel driver in use: i915
	Kernel modules: i915
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] 100 Series/C230 Series Chipset Family Thermal Subsystem
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] 100 Series/C230 Series Chipset Family MEI Controller
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation HM170/QM170 Chipset SATA Controller [AHCI Mode] (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] HM170/QM170 Chipset SATA Controller [AHCI Mode]
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #1 (rev f1)
	Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #4 (rev f1)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation HM175 Chipset LPC/eSPI Controller (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] HM175 Chipset LPC/eSPI Controller
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] 100 Series/C230 Series Chipset Family Power Management Controller
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] CM238 HD Audio Controller
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
	Subsystem: Micro-Star International Co., Ltd. [MSI] 100 Series/C230 Series Chipset Family SMBus
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] GP107M [GeForce GTX 1050 Mobile]
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia
02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3168NGW [Stone Peak] (rev 10)
	Subsystem: Intel Corporation Dual Band Wireless-AC 3168NGW [Stone Peak]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
03:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)
	Subsystem: Micro-Star International Co., Ltd. [MSI] QCA8171 Gigabit Ethernet
	Kernel driver in use: alx
	Kernel modules: alx

Offline

#5 2020-01-29 19:11:00

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,175
Website

Re: wpa_dbus_property_changed errors

Okay gilcu3, well done for hijacking y7dk9's thread. Now try connecting manually, I think NetworkManager has been having problems recently. Search the boards for more details.

EDIT otherwise see https://wiki.archlinux.org/index.php/Ne … ss#iwlwifi

Last edited by Head_on_a_Stick (2020-01-29 19:36:07)

Offline

#6 2020-01-31 13:17:15

gilcu3
Member
Registered: 2011-04-12
Posts: 9

Re: wpa_dbus_property_changed errors

Head_on_a_Stick wrote:

Okay gilcu3, well done for hijacking y7dk9's thread. Now try connecting manually, I think NetworkManager has been having problems recently. Search the boards for more details.

EDIT otherwise see https://wiki.archlinux.org/index.php/Ne … ss#iwlwifi

I have tried to get the same behavior today, but it's not happening, maybe it was fixed already, or maybe there was a problem with this specific wifi. I will test both of your workarounds if the problem appears again. Thank you. As far I am concerned this thread should be closed now.

Offline

#7 2020-02-10 10:51:33

y7dk9
Member
Registered: 2020-01-27
Posts: 2

Re: wpa_dbus_property_changed errors

For me, downgrading to wpa_supplicant-2:2.9-3 makes the errrors disappear, while keeping everything else (kernel, networkmanager, dhcpcd) unchanged.
(Already wpa_supplicant-2:2.9-4 gives the errors.)

$ systemctl list-unit-files --state=enabled
UNIT FILE                                  STATE
org.cups.cupsd.path                        enabled
autovt@.service                            enabled
dbus-org.freedesktop.nm-dispatcher.service enabled
dbus-org.freedesktop.timesync1.service     enabled
getty@.service                             enabled
NetworkManager-dispatcher.service          enabled
NetworkManager-wait-online.service         enabled
NetworkManager.service                     enabled
org.cups.cupsd.service                     enabled
systemd-timesyncd.service                  enabled
tlp.service                                enabled
org.cups.cupsd.socket                      enabled
pcscd.socket                               enabled
remote-fs.target                           enabled

14 unit files listed.

Offline

Board footer

Powered by FluxBB