You are not logged in.

#1 2020-02-12 23:00:16

ism
Member
From: California
Registered: 2019-11-24
Posts: 9

[SOLVED] Installing rEFInd in chroot

I reinstalled Arch today (havent rebooted yet, no bootloader installed) and I'd like to use rEFInd over GRUB but after running the refind-install script I noticed this warning on the wiki: "Warning: When refind-install is run in chroot (e.g. in live system when installing Arch Linux) /boot/refind_linux.conf is populated with kernel options from the live system not the one on which it is installed. You will need to edit /boot/refind_linux.conf and adjust the kernel options manually. See #refind_linux.conf for an example."

After checking the refind_linux.conf file, and like the warning would suggest, my parameters appear to be pointing to the ISO on my flash drive. What exactly do I need my config file to look like before I can boot properly? Looks like I need the PART-UUID for root and I'm assuming the rootfstype would be ext4? Can't really seem to find a concrete example of what I should be looking for. Any help would be appreciated. Thanks.

Edit: Found my UUID and modified my .conf, still getting a kernel panic on boot

unable to mount root fs on unknown-block(0 0)

Last edited by ism (2020-02-13 23:20:52)

Offline

#2 2020-02-13 07:10:50

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 188

Re: [SOLVED] Installing rEFInd in chroot

The wiki has an example: https://wiki.archlinux.org/index.php/RE … linux.conf (there's was even a link to it in the paragraph you quoted).
Make sure to read the note and warning below the example.

Offline

#3 2020-02-13 23:17:52

ism
Member
From: California
Registered: 2019-11-24
Posts: 9

Re: [SOLVED] Installing rEFInd in chroot

Yes I realize there was an example, I read the wiki. I just wanted to confirm that my .conf was correct.

Anyways, I figured it out, I should have run the refind-install script with the --root option since I was installing in a live environment. After running that command I was still running into an issue - the script was trying to create the .conf file in the /EFI/boot directory, which did not exist. After creating the directory and running the script again it properly detected my config and created a working .conf file.

For anyone who might be looking at this in the future and having the same issue, just remember to use the "--root /mountpoint" option when running refind install. /mountpoint is obviously wherever you mounted your EFI partition. In my case, /efi

Offline

Board footer

Powered by FluxBB