You are not logged in.

#1 2020-02-29 09:01:32

mephostophilis
Member
Registered: 2011-01-23
Posts: 27

Can't get ubuntu KVM guest to mount NFS directory [SOLVED]

ubuntu client showmount:

~$ showmount -e 192.168.1.240
Export list for 192.168.1.240:
/srv/nfs/NFS-tixati 192.168.1.111

When attempting to mount a directory on ubuntu client I get:

sudo mount -t nfs 192.168.1.240:/srv/nfs/NFS-tixati ~/trans
mount.nfs: access denied by server while mounting (null)

arch server /etc/export file:

/srv/nfs/NFS-tixati 192.168.1.111(rw,sync,no_subtree_check)

arch server exportfs output:

sudo exportfs -avrf
exporting 192.168.1.111:/srv/nfs/NFS-tixati

Firewalls on server and client are turned off and AppArmor is off on the ubuntu client.
The only way I can get it to work and not get "mount.nfs: access denied by server" is when I change the export file to this:

/srv/nfs/NFS-tixati *(rw,sync,no_subtree_check)

Problem solved I did not have the correct client IP address in the /etc/export file.

Last edited by mephostophilis (2020-03-01 08:32:09)

Offline

Board footer

Powered by FluxBB