You are not logged in.

#1 2020-03-22 02:52:54

Registered: 2020-03-22
Posts: 2

[SOLVED] Using Vulkan/AMDGPU-Pro with an AMD Radeon HD 7850

Hey there!
First of all, sorry if I am using the wrong subforum. I am pretty new to it all smile

Four days ago I installed Arch Linux (with lightDM, i3-gaps, polybar) in order to port
my tiny game engine to xcb + vulkan.

However, I cannot get vulkan to work properly on my system.

I installed, according to the wiki, 'vulkan-icd-loader', 'vulkan-amdgpu-pro', 'vulkan-tools', 'vulkan-headers', 'vulkan-validation-layers'.

Additionally I updated my GRUB to contain the following line

GRUB_CMDLINE_LINUX="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1"

and updated my grub config.


lshw -c video

, however, yields

configuration: driver=radeon latency=0

Next on running 'vulkaninfo'.

Explicitly setting 'VK_ICD_FILENAMES' to 'usr/share/vulkan/icd.d/amd_pro_icd64.json' I receive the following output:

amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x.
WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 0.  Skipping ICD.
Cannot create Vulkan instance.
This problem is often caused by a faulty installation of the Vulkan driver or attempting to use a GPU that does not support Vulkan.
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.135/vulkaninfo/vulkaninfo.h:624:vkCreateInstance failed with ERROR_INCOMPATIBLE_DRIVER

Setting it to '/usr/share/vulkan/icd.d/radeon_icd.x86_64.json' I receive the only this output:

ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.135/vulkaninfo/vulkaninfo.h:240:vkEnumerateInstanceExtensionProperties failed with ERROR_INITIALIZATION_FAILED

I am pretty certain that my device supports Vulkan.

Are there any crucial steps I am missing?

Thanks in advance.

P.S.: I am a newbie, please go easy on me.


I had to create two files in '/etc/modprobe.d', namely:
- amdgpu.conf:

options amdgpu si_support=1
options amdgpu cik_support=0

- radeon.conf

options radeon si_support=0
options radeon cik_support=0

All other approaches for setting these kernel parameters did NOT work. Also note that the german arch wiki is slightly outdated on that topic.

Last edited by Decker (2020-03-22 18:41:00)


#2 2020-03-22 11:43:48

From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,841

Re: [SOLVED] Using Vulkan/AMDGPU-Pro with an AMD Radeon HD 7850

Welcome to archlinux forums.

For archlinux users vulkan-radeon is the best choice, amdvlk is good in certain usecases and vulkan-amdgpu-pro is last resort.

What distros / users do you expect to run this game engine ?

Last edited by Lone_Wolf (2020-03-22 11:44:55)

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them


#3 2020-03-22 12:25:28

Registered: 2020-03-22
Posts: 2

Re: [SOLVED] Using Vulkan/AMDGPU-Pro with an AMD Radeon HD 7850

Hey there!

I didn't plan much in terms of "which distro am I going to support". My goal is to get it running at all on linux
and later on think about which distros/package managers to look into.

However, before this leads to confusion. This is not about the game engine, but about getting Vulkan to run at all on my device.


Board footer

Powered by FluxBB