You are not logged in.

#1 2020-03-24 09:37:01

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 697
Website

[UPSTREAM BUG] TigerVNC: Unknown parameter PasswordFile

I am trying to setup a VNC viewer configuration for TigerVNC as per https://tigervnc.org/doc/vncviewer.html.
The configuration manual states:

https://tigervnc.org/doc/vncviewer.html wrote:

−passwd, −PasswordFile password-file

If you are on a filesystem which gives you access to the password file used by the server, you can specify it here to avoid typing it in. It will usually be "~/.vnc/passwd".

[…]

$HOME/.vnc/default.tigervnc

Default configuration options. This file must have a "magic" first line of "TigerVNC Configuration file Version 1.0" (without quotes), followed by simple <setting>=<value> pairs of your choosing. The available settings are those shown in this man page.

My current configuration is

$ cat ~/.vnc/default.tigervnc 
TigerVNC Configuration file Version 1.0

ServerName=REDACTED
X509CA=
X509CRL=
SecurityTypes=X509Plain,TLSPlain,X509Vnc,TLSVnc,X509None,TLSNone,VncAuth,None
DotWhenNoCursor=1
AutoSelect=1
FullColor=1
LowColorLevel=2
PreferredEncoding=Tight
CustomCompressLevel=0
CompressLevel=2
NoJPEG=0
QualityLevel=8
FullScreen=1
FullScreenAllMonitors=1
DesktopSize=
RemoteResize=1
ViewOnly=0
Shared=0
AcceptClipboard=1
SendClipboard=1
SendPrimary=1
MenuKey=F8
FullscreenSystemKeys=1
PasswordFile=~/.vnc/passwd

Upon connection, I get the warning that the Parameter PasswordFile is unknown, though it should be recognized as described in the manual.

$ LANG=C vncviewer 1017.terminals.homeinfo.intra

TigerVNC Viewer 64-bit v1.10.1
Built on: 2019-12-27 09:17
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Tue Mar 24 10:21:56 2020
 Parameters:  Unknown parameter PasswordFile on line 27 in file
              /home/rne/.vnc/default.tigervnc
 DecodeManager: Detected 8 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       Connected to host 1017.terminals.homeinfo.intra port 5900
 CConnection: Server supports RFB protocol version 3.3
 CConnection: Using RFB protocol version 3.3
 CConn:       Connection failed: Too many security failures

I'd then manually have to enter the password.
Beware that the Connection failed: Too many security failures is due to too many aborted connection attempts and is not the issue here.

How do I correctly tell vncviewer via the configuration file to use that password file?

Update
This seems to be an upstream issue.
I opened a bug report: https://github.com/TigerVNC/tigervnc/issues/983

Last edited by schard (2020-03-24 10:06:09)

Offline

Board footer

Powered by FluxBB