You are not logged in.

#1 2020-05-22 23:10:26

r4yman
Member
Registered: 2020-05-22
Posts: 4

[SOLVED] Youtube weird Video Player in Chromium

Hey fellow tech lovers,

Explanation of the problem

I am using chromium as my web browser and I very quickly realized that youtube does not use the "normal" video player (very simple one, with black backgrounds and white buttons) but instead what I think might be the default HTML5 video player. Now I wouldn't mind, but by default it does not show any controls and I have to right click the video and click "Show Controls" so that I, for an example, can pause a video just so the controls are hidden again. I have to repeat this process every time I want to control (change volume, play/pause, skip to certain time) the video and that I think its understandably annoying and does not seem normal.

What I tried to fix this issue

- I read through the Arch Linux Wiki on different Topics (e.g. Chromium, Video Codecs, ...)
- I extensively searched google for this problem (but none of the described issues matched mine)
- I searched in this forum (but I could not find a matching thread)

Technical/Debug Information

I am using an up to date arch linux system and the chromium package from the offical repos. I also have the chromium-widevine extension from AUR installed, but I dont think this has to do anything with this problem.
Sadly I have no real debug information because technically its working. I installed Firefox and tried it there, and its working like expected in Firefox. If you need more information, please just I ask for it and I will try to provide it.

Thanks for any help in advance!

Last edited by r4yman (2020-06-08 18:38:04)

Offline

#2 2020-05-23 14:21:03

xerxes_
Member
Registered: 2018-04-29
Posts: 290

Re: [SOLVED] Youtube weird Video Player in Chromium

I haven't seen on youtube that player you mentioned; just standard player which don't have option "Show Controls" and displays controls when mouse is moved.

However you can try keyboard shortcuts:
f - for toggle full screen on and off
space / k - play / pause video
right arrow / l - 10 seconds forward
left arrow / j - 10 seconds backward
up & down arrow to change sound loudness
m - mute sound

Offline

#3 2020-05-23 23:26:58

r4yman
Member
Registered: 2020-05-22
Posts: 4

Re: [SOLVED] Youtube weird Video Player in Chromium

xerxes_ wrote:

I haven't seen on youtube that player you mentioned; just standard player which don't have option "Show Controls" and displays controls when mouse is moved.

However you can try keyboard shortcuts:
f - for toggle full screen on and off
space / k - play / pause video
right arrow / l - 10 seconds forward
left arrow / j - 10 seconds backward
up & down arrow to change sound loudness
m - mute sound

unfortunately these shortcuts also dont seem to work D:

Offline

#4 2020-05-28 23:14:19

cactus.ed
Member
From: The lonesome crowded west
Registered: 2007-08-11
Posts: 32

Re: [SOLVED] Youtube weird Video Player in Chromium

Same issue here. Seems to only happen on YouTube. Controls aren't visible on the videos, hot keys don't seem to work either. If I want to skip back 30 seconds because I missed something, I have to right click the video, click "show controls", seek to desired point (player seeks back, pauses, automatically hides controls again), right click the video again, click "show controls", then click play. It's pretty annoying. Not sure what the issue is.

Offline

#5 2020-06-01 10:35:46

r4yman
Member
Registered: 2020-05-22
Posts: 4

Re: [SOLVED] Youtube weird Video Player in Chromium

I actually found the problem myself. It seems like if you happen to use the command line flag --disable-reading-from-canvas to disable canvas fingerprinting, youtube does not seem to like that. It worked normally for me when I started chromium without this flag. @cactus.ed if this fixes the problem for you please tell me, so I can mark this as solved.

Offline

#6 2020-06-06 20:07:29

Jason P.
Member
Registered: 2015-02-26
Posts: 130

Re: [SOLVED] Youtube weird Video Player in Chromium

r4yman wrote:

I actually found the problem myself. It seems like if you happen to use the command line flag --disable-reading-from-canvas to disable canvas fingerprinting, youtube does not seem to like that. It worked normally for me when I started chromium without this flag. @cactus.ed if this fixes the problem for you please tell me, so I can mark this as solved.

I'm having the same problem also with videos on this site https://www.arte.tv/en/arte-concert/. Does it happen to you?

I'm not sure if there's any alternative to completely removing the flag...

Offline

#7 2020-06-06 20:36:46

r4yman
Member
Registered: 2020-05-22
Posts: 4

Re: [SOLVED] Youtube weird Video Player in Chromium

Jason P. wrote:

I'm having the same problem also with videos on this site https://www.arte.tv/en/arte-concert/. Does it happen to you?

I'm not sure if there's any alternative to completely removing the flag...

Yes videos on this site also dont work for me. But in contrast to YouTube they dont play at all. But after starting chromium without the mentioned flag it does work.

I have no clue on why some sites do not work with this flag enabled, I guess a deeper look for this would be required.

Offline

Board footer

Powered by FluxBB