You are not logged in.

#1 2020-06-30 01:04:16

minecraft2048
Member
Registered: 2017-06-22
Posts: 5

[SOLVED] TL-WN722N USB wifi interface not showing up after upgrade

After I finished updating my laptop, suddenly my USB wifi adapter is not showing up on either KDE NetworkManager applet or ip link. Here is the output of dmesg:

 [Jun30 11:04] usb 1-4: new high-speed USB device number 12 using xhci_hcd
[  +0.160470] usb 1-4: New USB device found, idVendor=0cf3, idProduct=9271, bcdDevice= 1.08
[  +0.000003] usb 1-4: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[  +0.000002] usb 1-4: Product: USB2.0 WLAN
[  +0.000002] usb 1-4: Manufacturer: ATHEROS
[  +0.000001] usb 1-4: SerialNumber: 12345
[  +0.002315] usb 1-4: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[  +0.280912] usb 1-4: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[  +0.251880] ath9k_htc 1-4:1.0: ath9k_htc: HTC initialized with 33 credits 

then there is nothing in dmesg after that. Here is the output of ip link:

minato@konoha ~ [SIGINT]> ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether d8:cb:8a:84:4e:73 brd ff:ff:ff:ff:ff:ff
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default 
    link/ether 02:42:e2:cb:0a:8b brd ff:ff:ff:ff:ff:ff 

To rule out that the adapter is broken, I plugged this into my Ubuntu 20.04 LTS computer and it works just fine, and here is the dmesg output:

[ +20.842585] usb 1-1: new high-speed USB device number 45 using xhci_hcd
[  +0.164627] usb 1-1: New USB device found, idVendor=0cf3, idProduct=9271, bcdDevice= 1.08
[  +0.000006] usb 1-1: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[  +0.000003] usb 1-1: Product: USB2.0 WLAN
[  +0.000003] usb 1-1: Manufacturer: ATHEROS
[  +0.000003] usb 1-1: SerialNumber: 12345
[  +0.090494] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[  +0.000035] usbcore: registered new interface driver ath9k_htc
[  +0.287235] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[  +0.251728] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[  +0.264254] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.4
[  +0.000006] ath9k_htc 1-1:1.0: FW RMW support: On
[  +0.000005] ath: EEPROM regdomain: 0x809c
[  +0.000001] ath: EEPROM indicates we should expect a country code
[  +0.000003] ath: doing EEPROM country->regdmn map search
[  +0.000002] ath: country maps to regdmn code: 0x52
[  +0.000003] ath: Country alpha2 being used: CN
[  +0.000002] ath: Regpair used: 0x52
[  +0.005933] ieee80211 phy1: Atheros AR9271 Rev:1
[  +0.018219] ath9k_htc 1-1:1.0 wlxe8de271a9f72: renamed from wlan0
[  +1.990613] wlxe8de271a9f72: authenticate with bc:30:d9:ba:ad:95
[  +0.170584] wlxe8de271a9f72: send auth to bc:30:d9:ba:ad:95 (try 1/3)
[  +0.001671] wlxe8de271a9f72: authenticated
[  +0.002546] wlxe8de271a9f72: associate with bc:30:d9:ba:ad:95 (try 1/3)
[  +0.006130] wlxe8de271a9f72: RX AssocResp from bc:30:d9:ba:ad:95 (capab=0x1411 status=0 aid=1)
[  +0.008523] wlxe8de271a9f72: associated
[  +0.035977] IPv6: ADDRCONF(NETDEV_CHANGE): wlxe8de271a9f72: link becomes ready

EDIT: If I use

 Bus 001 Device 009: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter 

wifi works just fine

EDIT2: Latest kernel breaks TL-WN722N support, more info at this link: https://bbs.archlinux.org/viewtopic.php?id=256977

Last edited by minecraft2048 (2020-06-30 03:54:37)

Offline

#2 2020-06-30 01:24:03

loqs
Member
Registered: 2014-03-06
Posts: 11,206

Re: [SOLVED] TL-WN722N USB wifi interface not showing up after upgrade

Offline

#3 2020-06-30 03:05:54

minecraft2048
Member
Registered: 2017-06-22
Posts: 5

Re: [SOLVED] TL-WN722N USB wifi interface not showing up after upgrade

Thanks for the link, can someone close this thread?

Offline

#4 2020-06-30 03:11:50

loqs
Member
Registered: 2014-03-06
Posts: 11,206

Re: [SOLVED] TL-WN722N USB wifi interface not showing up after upgrade

You can marked it solved by editing your first post and prepending [SOLVED] to the title or you can use the Report link to request a moderator delete the topic.

Offline

Board footer

Powered by FluxBB