You are not logged in.

#1 2020-07-02 13:00:21

Registered: 2020-06-27
Posts: 2

[SOLVED] Thinkpad T495s: usb ports disappearing (power off)

Hi, I own a Thinkpad T495s and having a problem: while on AC everything works fine, on battery USB ports (both type A and type C) stop working and never come back.

My problem is somewhat similar to, but since it's a year old I was wondering if there's something else I can do.

I also found out this discussion: … ing_after/.
I tried setting "iommu=pt" like OP but my computer became insanely slow so I reverted that and wasn't able to tell if the problem was solved or not.

If you have some ideas to try it'd be great.
Thank you!

EDIT. also found … on-battery
I originally tried to disable tlp using

$ systemctl disable tlp
$ reboot

but apprently that wasn't enough.

I got it working following one of the answer in the previous link:

I re-enabled tlp:

$ systemctl enable tlp

Then found my two controllers:

$ lspci | grep USB

05:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
05:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1

and blacklisted them in "/etc/tlp.conf":

RUNTIME_PM_BLACKLIST="05:00.3 05:00.4"

rebooted, and they're working now!

Last edited by zaphodias (2020-07-02 13:26:59)


Board footer

Powered by FluxBB