You are not logged in.

#1 2020-02-20 04:26:48

c9fc3432bfae80280blinders
Member
Registered: 2020-02-20
Posts: 2

[SOLVED] Audio not working, soundcard not detected

Hi,

I have a Thinkpad X1 and I'm new to archlinux and trying to get audio and the microphone working. I had audio working previously, but then in the process of trying to get the microphone to work I caused the output audio to also fail.

Not sure if this should be posted here or in the Newbie's corner.

I'm posted the debug information that was requested in similar threads below.

pactl list sinks

Sink #0
	State: SUSPENDED
	Name: auto_null
	Description: Dummy Output
	Driver: module-null-sink.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 13
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: auto_null.monitor
	Latency: 0 usec, configured 0 usec
	Flags: DECIBEL_VOLUME LATENCY 
	Properties:
		device.description = "Dummy Output"
		device.class = "abstract"
		device.icon_name = "audio-card"
	Formats:
		pcm
pacman -Q linux

linux 5.5.4.arch1-1
uname -a

Linux abalakum 5.5.4-arch1-1 #1 SMP PREEMPT Sat, 15 Feb 2020 00:36:29 +0000 x86_64 GNU/Linux
aplay -lL

null
    Discard all samples (playback) or generate zero samples (capture)
default
    Default ALSA Output (currently PulseAudio Sound Server)
aplay: device_list:272: no soundcards found...
sudo fuser -v /dev/snd/*
dmesg | grep snd

[    2.992747] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.996595] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
pulseaudio -vvv

I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 13.0
D: [pulseaudio] main.c: Compilation host: x86_64
D: [pulseaudio] main.c: Compilation CFLAGS: Not yet supported on meson
D: [pulseaudio] main.c: Running on host: Linux x86_64 5.5.4-arch1-1 #1 SMP PREEMPT Sat, 15 Feb 2020 00:36:29 +0000
D: [pulseaudio] main.c: Found 8 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Running from build tree: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: All asserts enabled.
I: [pulseaudio] main.c: Machine ID is cd5d8979e24e401b97716e4826afdb3f.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/ambarish/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-13.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Thanks for taking the time to help.

Last edited by c9fc3432bfae80280blinders (2020-02-20 16:53:04)

Offline

#2 2020-02-20 08:13:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,144

Re: [SOLVED] Audio not working, soundcard not detected

https://bbs.archlinux.org/viewtopic.php … 5#p1887925
https://bbs.archlinux.org/viewtopic.php … 6#p1888046

If that isn't sufficient you might be more interested in reading the following thread and in particular the linked reply: https://bbs.archlinux.org/viewtopic.php … 2#p1887142

Last edited by V1del (2020-02-20 08:15:59)

Offline

#3 2020-02-20 16:55:21

c9fc3432bfae80280blinders
Member
Registered: 2020-02-20
Posts: 2

Re: [SOLVED] Audio not working, soundcard not detected

Thanks so much the first two links were sufficient to get output to work. It did not fix the microphone though.

Offline

#4 2020-07-18 01:25:33

ThinkPad
Member
Registered: 2019-01-29
Posts: 52

Re: [SOLVED] Audio not working, soundcard not detected

This was also the issue and fix for Thinkpad T14s.

Offline

Board footer

Powered by FluxBB