You are not logged in.

#1 2020-07-19 16:06:40

Registered: 2020-07-19
Posts: 1

iPhone USB tethering not working

I have followed the instructions on the iPhone tethering page on the wiki and my phone shows in the list of network devices when running 'networkctl list'.
The phone shows that the computer is connected to the hotspot with a blue indicator in the top left corner of the screen and I can get a response when pinging the phones public IP address from the command line.
Any other ping request times out and i have tried pinging both web addresses and IP's such as
Internet works fine on the phone and the computer is fully able to connect to the internet when using a wired ethernet connection.
I have tried rebooting both the phone and the computer and can successfully mount the phone to view files using ifuse.

Output of 'ip addr':

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 18:31:bf:4c:09:d7 brd ff:ff:ff:ff:ff:ff
9: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 42:98:ad:98:42:2a brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute eth0
       valid_lft 85252sec preferred_lft 85252sec
    inet6 fe80::c33e:ddf:a8ea:673a/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

Output of 'ip route'

default via dev eth0 proto dhcp metric 20100 dev eth0 proto kernel scope link src metric 100


Board footer

Powered by FluxBB