You are not logged in.

#1 2020-07-30 16:20:10

nero
Member
Registered: 2013-08-06
Posts: 9

Nvidia 440.82 modules not being installed.

Hi all, I am posting from another machine as I am unable to get my arch linux  5.7.10-arch1-1 to boot into kde.

I have narrowed it down to the nvidia driver not being placed in dkms, I have rebooted and uninstalled- reinstalled nvidia nvidia-utils many times with no success, I must be doing something simple incorrectly, just hoping someone can point my in the correct direction.

Offline

#2 2020-07-30 16:25:19

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: Nvidia 440.82 modules not being installed.

Logs? Did you read the optional deps of the dkms package when it was installed?

Edit: wait, you mention dkms, but then mention the nvidia package. Which is it?

Last edited by Scimmia (2020-07-30 16:25:55)

Offline

#3 2020-07-30 16:38:46

ArchWilly
Member
Registered: 2020-07-24
Posts: 5

Re: Nvidia 440.82 modules not being installed.

Hi nero,
First of all, sorry for my english skills...
That's just an idea, but do you have blacklist (or uninstall) nouveau driver and do you have add nvidia module in the mkinitcpio.conf?
Your X config will logically ask for nvidia driver, but if another driver is loaded before, it will crash...

Offline

#4 2020-07-30 18:15:50

nero
Member
Registered: 2013-08-06
Posts: 9

Re: Nvidia 440.82 modules not being installed.

Scimmia - thanks for the reply, I am having issues with getting nvidia mdules, I have in the past used dkms to install the modules (think this is correct) i.e dkms autoinstall or dkms install -m nvidia -v XXXXX, but when I look in the /var/lib/dkms older version of nvidia are there but no the most recent version.

As said I am posting these from another machine, but will try and pull xorg logs from the machine, however these only say NVIDIA Failed to initialise please see the system kernal logs, journalctl doesnt show any issues with nvidia, so I am a bit stumped.

ArchWilly I have checked for nouveau being blacklisted and it is in the config file /usr/lib/modprobe.d/nividia.conf file.

edit -- Have now tried to add nvidia modules to the initramfs, and on running mkinitcpio -p linux i get ERROR Module not found: 'nvidia' sad

Last edited by nero (2020-07-30 19:00:11)

Offline

#5 2020-07-30 20:12:57

seth
Member
Registered: 2012-09-03
Posts: 17,188

Re: Nvidia 440.82 modules not being installed.

Check the links in my signature on how to boot w/o GUI and how to upload text files.
The most interesting bit will be your /var/log/pacman.log

Offline

#6 2020-07-30 21:17:06

nero
Member
Registered: 2013-08-06
Posts: 9

Re: Nvidia 440.82 modules not being installed.

Hey Finally got around to doing the logs, any advice appreciated.

5.7.10-arch1-1
nvidia 440.82-18
linux 5.7.10.arch1-1

Pacman.log
https://pastebin.com/jbg1KAf9

Xorg
https://pastebin.com/Hq2wtRpQ

Offline

#7 2020-07-30 21:30:42

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,076
Website

Re: Nvidia 440.82 modules not being installed.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#8 2020-07-30 22:02:38

ArchWilly
Member
Registered: 2020-07-24
Posts: 5

Re: Nvidia 440.82 modules not being installed.

Nero, what returns the command :

lsmod | grep -i nv

Otherwise, why do you use dkms drivers? Apparently, you are using the current kernel, so the standard nvidia driver will probably work better, won't it?

Offline

#9 2020-07-30 23:03:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: Nvidia 440.82 modules not being installed.

nero wrote:

Hey Finally got around to doing the logs, any advice appreciated.

5.7.10-arch1-1
nvidia 440.82-18
linux 5.7.10.arch1-1

So you're using the binary nvidia package, not nvidia-dkms, so your dkms checks are invalid.

The version of nvidia for that kernel was 450.57-4, why are you trying to use an old version? Of course it doesn't work.

Offline

#10 2020-07-31 06:23:02

seth
Member
Registered: 2012-09-03
Posts: 17,188

Re: Nvidia 440.82 modules not being installed.

[2020-07-29T21:27:20+0100] [ALPM-SCRIPTLET] ==> dkms install nvidia/440.82 -k 5.7.10-arch1-1
[2020-07-29T21:27:28+0100] [ALPM-SCRIPTLET] Error! Bad return status for module build on kernel: 5.7.10-arch1-1 (x86_64)
[2020-07-29T21:27:28+0100] [ALPM-SCRIPTLET] Consult /var/lib/dkms/nvidia/440.82/build/make.log for more information.
[2020-07-29T21:27:28+0100] [ALPM-SCRIPTLET] ==> dkms install nvidia/435.21 -k 5.7.10-arch1-1
[2020-07-29T21:27:32+0100] [ALPM-SCRIPTLET] Error! Bad return status for module build on kernel: 5.7.10-arch1-1 (x86_64)
[2020-07-29T21:27:32+0100] [ALPM-SCRIPTLET] Consult /var/lib/dkms/nvidia/435.21/build/make.log for more information.

I assume because of - he tries to pin a certain driver version, this failed w/ dkms and instead of looking into the make.log as told, he went for the futile approach to install an old package.
=> Inspect /var/lib/dkms/nvidia/440.82/build/make.log on why this failed…

Offline

#11 2020-07-31 06:32:16

nero
Member
Registered: 2013-08-06
Posts: 9

Re: Nvidia 440.82 modules not being installed.

HI All,

Scimmia/Seth,  this is the version that pacman in pulling down., I have tried multiple ways of getting nividia to work, and in the past dkms has worked,  how can I pull down the newer version.


ArchWilly lsmod | grep -i nv returns nothing.

Offline

#12 2020-07-31 06:38:09

seth
Member
Registered: 2012-09-03
Posts: 17,188

Re: Nvidia 440.82 modules not being installed.

Please post the output of

pacman -Syuv nvidia

Last edited by seth (2020-07-31 06:38:43)

Offline

#13 2020-07-31 08:02:25

nero
Member
Registered: 2013-08-06
Posts: 9

Re: Nvidia 440.82 modules not being installed.

Hey All,

Thanks for your help, following the hints from Scimmia that I wasn't on the latest drivers, I have installed the nvidia-beta drivers from aur. After some issues with sddm, I have now got it all working.

For any one else steps taken were.

 
sudo pacman -R nvidia nvidia-utils nvidia-settings 
youart -S nvidia-beta nvidia-utils-beta nvidia-settings-beta 
rm /etc/X11/xorg.conf /etc/X11/xorg.conf.d
rm ~/.xinitrc
reboot

Issue now no idea how to mark as solved, (have note to pre append '[solved]' to name, but can seem to edit it. sad

Last edited by nero (2020-07-31 08:10:38)

Offline

#14 2020-07-31 10:08:40

ondoho
Member
Registered: 2013-04-30
Posts: 684
Website

Re: Nvidia 440.82 modules not being installed.

^ That's not a solution, it's a workaround at best.


However studied and stilted your rant, it can never hide the base and primitve emotion that inspired it.
There's no objectivity.

Offline

#15 2020-07-31 10:49:06

seth
Member
Registered: 2012-09-03
Posts: 17,188

Re: Nvidia 440.82 modules not being installed.

ondoho wrote:

^ That's not a solution, it's a workaround at best terrible.

ftfy.

This is complete nonsense:

rm /etc/X11/xorg.conf /etc/X11/xorg.conf.d
rm ~/.xinitrc

If this fixes anything for you, the nvidia driver wasn't the issue itfp.
Your xinitrc either has not been used or you now damaged your setup and you possibly also deleted some innocent config files for your input devices or whatnot.
(Well, you would - if "rm /path/to/dir" was a thing…)

youart -S nvidia-beta nvidia-utils-beta nvidia-settings-beta

"youart" was actually "yaourt" and "was" because it's discontinued and abandoned and has always been a terrible AUR helper (not that there're many non-terrible ones to begin with)
Also nvidia-beta is currently at 450.57-2, the repo version is at 450.57-5.

If 440.82-18 "is the version that pacman in pulling down", there's a problem with either one of your repos (assuming this is some arch derivate) or the mirror you use is 2 months outdated (but somehow provides you w/ a recent kernel - unlikely)
Not addressing that MASSIVE issue, but glossing over it w/ pulling in some AUR package is at very best adding more trouble down the road.


=> Post the output of "pacman -Syuv nvidia" as previously asked for so that we can see what's going on, leading to the version mismatch.

Offline

#16 2020-07-31 10:51:36

ondoho
Member
Registered: 2013-04-30
Posts: 684
Website

Re: Nvidia 440.82 modules not being installed.

^ Oops, I should've looked a little closer.

seth wrote:

deleted some innocent config files

Nice.


However studied and stilted your rant, it can never hide the base and primitve emotion that inspired it.
There's no objectivity.

Offline

Board footer

Powered by FluxBB