You are not logged in.

#1 2020-09-06 17:01:05

dcaspar
Member
Registered: 2020-08-12
Posts: 21

Automounting Windows share via fstab

Hey all,

I'm having some issues auto-mounting a remote windows directory on boot.
I've added the following to my fstab file

//192.168.0.3/Users /mnt/x280 cifs _netdev,username=mywindowsuser,password=thepassword 0 0

It seems to be working, as if I run sudo mount -a -v I can see the windows directory being successfully mounted and I'm able to navigate to it at my mount point.

It is not automounting on boot though. The filesystem does not show until I run mount.
I have enabled both systemd-networkd-wait-online.service and NetworkManager-wait-online.service as suggested in the wiki page.

Any clues on how to troubleshoot this would be great.
Thanks.

Offline

#2 2020-09-19 05:45:28

Sffred
Member
Registered: 2020-08-30
Posts: 17

Re: Automounting Windows share via fstab

Maybe you can use dmesg to see system journals since startup and look for logs about fsck.

Offline

#3 2020-09-19 23:55:27

cowlick
Member
From: Alliance College
Registered: 2013-10-13
Posts: 43

Re: Automounting Windows share via fstab

https://forums.linuxmint.com/viewtopic.php?t=276519/

Last edited by cowlick (2020-09-19 23:56:32)


Gfys

Offline

#4 2020-09-20 12:24:16

loqs
Member
Registered: 2014-03-06
Posts: 11,696

Re: Automounting Windows share via fstab

dcaspar wrote:

I have enabled both systemd-networkd-wait-online.service and NetworkManager-wait-online.service as suggested in the wiki page.

You have both systemd-networkd and NetworkManager enabled?

dcaspar wrote:

Any clues on how to troubleshoot this would be great.

Systemd#Checking_status works with .mount units.
Systemd/Journal

Offline

Board footer

Powered by FluxBB