You are not logged in.

#1 2020-09-09 21:34:51

Registered: 2020-04-05
Posts: 4

[SOLVED] 2.4 GHz Wi-Fi associating timing out

Connecting to a 2.4 GHz access point broke at some point of updating (don't remember exactly where, either kernel or iw update). When connecting associating times out and the whole connection process is cancel after few tries. 5 GHz access points still work normally as expected. 
I tried several different distributions (Fedora 32, Pop!_OS 20.04, Ubuntu 20.04) and all of them have the exact same issue (I run them in a live environment). 
The only distro that worked was Elementary OS 5.1. I assume that it is because it's based on Ubuntu 18.04 with older kernel and iw (linux 5.3.0, iw 4.14). 
Bellow are my specs and a `dmesg` log when trying to connect to the 2.4 GHz access point. 

Laptop: Thinkpad T540p
Wifi card: Intel Corporation Wireless 7260 (rev 83)
Router/Access Point: TP-Link Archer C6 v2.0 (don't think this is the issue, works fine for other devices)
Kernel: 5.8.7-arch1-1
iw --version: 5.8
wpa_supplicant -v: v2.9

[  452.449105] wlan0: authenticate with 0c:80:63:xx:xx:xx
[  452.452141] wlan0: send auth to 0c:80:63:xx:xx:xx (try 1/3)
[  452.457298] wlan0: authenticated
[  452.460765] wlan0: associate with 0c:80:63:xx:xx:xx (try 1/3)
[  452.564113] wlan0: associate with 0c:80:63:xx:xx:xx (try 2/3)
[  452.667437] wlan0: associate with 0c:80:63:xx:xx:xx (try 3/3)
[  452.770826] wlan0: association with 0c:80:63:xx:xx:xx timed out

Last edited by vojtechh (2020-09-10 23:33:44)


#2 2020-09-10 23:33:19

Registered: 2020-04-05
Posts: 4

Re: [SOLVED] 2.4 GHz Wi-Fi associating timing out

Solved by applying

options iwlwifi i11n_disable=1

to /etc/modprobe.d/iwlwifi.conf


Board footer

Powered by FluxBB