You are not logged in.

#1 2020-09-16 07:59:01

Registered: 2019-03-11
Posts: 58

[Solved] Lenovo Ideapad 330s - No sound from microphone


internal microphone on my laptop stopped working. No idea when it worked last, but I did no configuration change apart from updating. However reverting kernel to 5.8.5 didn't help.

When I look at pulseaudio pavucontrol, I see very slight noise in the microphone output, but no matter how much do I scream into the computer, the noise level remains the same.

It is not hardware issue, it works on other system.

I have no idea how to properly debug this, but I ran … 8e36f1ada1

I'd be glad for any information or ideas on how to debug this or provide more information.


Last edited by Soptik (2020-09-17 09:31:17)


#2 2020-09-16 09:08:17

Forum Moderator
Registered: 2012-10-16
Posts: 10,439

Re: [Solved] Lenovo Ideapad 330s - No sound from microphone

The noise you see is likely the mic boost that is enabled use

amixer -c0 'Mic Boost',0 0 #0 to disable the boost, up to 3 for various levels of boost

to toggle this. What are you using for attempting to record? does

arecord -Dhw:0 test.wav

work? What's your output for

pacmd list-cards
#During active recording
pacmd list-sources
pacmd list-source-outputs


#3 2020-09-16 09:48:12

Registered: 2019-03-11
Posts: 58

Re: [Solved] Lenovo Ideapad 330s - No sound from microphone

The amixer command to disable mic boost complained that the command doesn't exist, and disabling mic boost via alsamixer tui didn't seem to do anything.

Arecord (while specifying -Dhw:0) complained that sample format is not available and I had to specify one of S16_LE or S32_LE via -f. After I specified the format, it complained that channel count is not available. When I specified -c 2 (-c 1 didn't work), it complained that rate is not accurate, but started recording.

The recording didn't have anything that could be heard, altough I've seen the same noise that have been visible in microphone output (via pavucontrol).

Furthermore, I had to reboot before recording, as during testing, I often encountered `audio open error: Device of resource busy`. This only happened when specifying device, `arecord test.wav` works all the time.

Using arecord without specifying device works flawlessly without any configuration (albeit still there is no sound to be heard).

Previously, I tested everything by looking at pavucontrol mic output volume, and discord voice test. But the end result is the same when recording via arecord.


list-sources (while recording & specifying device):

list-source-outputs (while recording & specifying device):

0 source output(s) available.

list-source-outputs while *not* recording:

list-source-outputs while recording but only via `arecord test.wav`, so not specifying device:

Last edited by Soptik (2020-09-16 09:54:25)


#4 2020-09-17 08:07:36

Registered: 2019-03-11
Posts: 58

Re: [Solved] Lenovo Ideapad 330s - No sound from microphone

Workaround: use LTS kernel.


#5 Today 09:04:16

Registered: 2019-12-21
Posts: 3

Re: [Solved] Lenovo Ideapad 330s - No sound from microphone

I'm having the exact issue with a lenovo ideapad 330-15ikb laptop and installing the LTS kernel for me didn't change anything for me.


Board footer

Powered by FluxBB