You are not logged in.

#1 2020-10-09 11:24:44

LibraSubtilis
Member
Registered: 2020-10-08
Posts: 3

[SOLVED] connect to wlan after installation

Hello,                                                                         
                                                                               
I installed Arch on my laptop and have a similar issue, then Blackmorse ([SOLVED] Connect to internet after installation). I was able to connect to the internet while installing Arch, but I am not able to connect to it with the installed system. I possibly need to install packages and/or configure them. But which packages and/or how to configure them? I already spent 15 hours trying to figure out the reason and I am very frustrated (-.-) Please, help me.


$iw dev | grep -A 10 wlan0                                                      
        Interface wlan0                                                            
                ifindex 3                                                       
                wdev 0x2                                                        
                addr 5a:ba:05:8f:07:d6                                          
                type managed                                                       
                txpower 0.00 dBm                                                
                multicast TXQ:                                                     
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
$iw dev wlan0 link                                                                 
Not connected.                                                                  
$ip link show wlan0                                                                
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DORMANT group default qlen 1000
    link/ether 5a:ba:05:8f:07:d6 brd ff:ff:ff:ff:ff:ff permaddr 80:c5:f2:24:ec:7b
$ip link set wlan0 up                                                           
$systemctl start iwd.service                                                    
$iwctl device list                                                              
                                    Devices                                    
--------------------------------------------------------------------------------
  Name                Address             Powered   Adapter   Mode      
--------------------------------------------------------------------------------
  wlan0               5a:ba:05:8f:07:d6   on        phy0      station              
                                                                                
$iwctl station wlan0 scan                                                       
$iwctl station wlan0 get-networks | grep o2-WLAN15                                 
    o2-WLAN15                       psk       ****                    
$iwctl --passphrase=**************** station wlan0 connect o2-WLAN15               
Operation failed

Last edited by LibraSubtilis (2020-10-22 15:17:36)

Offline

#2 2020-10-09 11:27:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,781

Re: [SOLVED] connect to wlan after installation

If you did forget to install linux-firmware that would explain this. This is however quite clearly stated in the Installation guide, which instructions did you use to install your system?

Edit: Please wrap outputs in [ code ] [ /code ] tags without spaces, and post

sudo journalctl -b

after such a failed connection attempt.

Last edited by V1del (2020-10-09 11:28:41)

Offline

#3 2020-10-09 12:00:17

LibraSubtilis
Member
Registered: 2020-10-08
Posts: 3

Re: [SOLVED] connect to wlan after installation

V1del wrote:

If you did forget to install linux-firmware that would explain this. This is however quite clearly stated in the Installation guide, which instructions did you use to install your system?

linux-firmware is installed. I followed DistroTubes example, but he doesn't cover wireless network. I also searched for a solution in the installation guide in the wiki, but without success.

V1del wrote:

Edit: Please wrap outputs in [ code ] [ /code ] tags without spaces, and post

sudo journalctl -b

after such a failed connection attempt.

the shortened output of "sudo jounalctl -b":

Oct 09 13:39:40 asus login[364]: LOGIN ON tty1 BY librasubtilis
Oct 09 13:39:42 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:39:42 asus systemd[1]: systemd-hostnamed.service: Succeeded.
Oct 09 13:39:42 asus audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Oct 09 13:39:43 asus audit: BPF prog-id=10 op=UNLOAD
Oct 09 13:39:43 asus audit: BPF prog-id=9 op=UNLOAD
Oct 09 13:39:43 asus dbus-daemon[232]: [system] Activating via systemd: service name='org.freedesktop.PolicyKit1' unit='polkit.service' requested by ':1.11' (uid=1000 pid=437 comm="/usr/bin/pkttyagent --notify-fd 5 --fallback ")
Oct 09 13:39:43 asus systemd[1]: Starting Authorization Manager...
Oct 09 13:39:44 asus polkitd[440]: Started polkitd version 0.118
Oct 09 13:39:44 asus polkitd[440]: Loading rules from directory /etc/polkit-1/rules.d
Oct 09 13:39:44 asus polkitd[440]: Loading rules from directory /usr/share/polkit-1/rules.d
Oct 09 13:39:44 asus polkitd[440]: Finished loading, compiling and executing 2 rules
Oct 09 13:39:44 asus dbus-daemon[232]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
Oct 09 13:39:44 asus polkitd[440]: Acquired the name org.freedesktop.PolicyKit1 on the system bus
Oct 09 13:39:44 asus systemd[1]: Started Authorization Manager.
Oct 09 13:39:44 asus audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=polkit comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Oct 09 13:39:44 asus polkitd[440]: Registered Authentication Agent for unix-process:435:3631 (system bus name :1.11 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale C)
Oct 09 13:39:49 asus audit[449]: USER_AUTH pid=449 uid=1000 auid=1000 ses=1 msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="librasubtilis" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=asus addr=? terminal=tty1 res=success'
Oct 09 13:39:49 asus kernel: kauditd_printk_skb: 8 callbacks suppressed
Oct 09 13:39:49 asus kernel: audit: type=1100 audit(1602243589.106:45): pid=449 uid=1000 auid=1000 ses=1 msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="librasubtilis" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=asus addr=? terminal=tty1 res=success'
Oct 09 13:39:49 asus dbus-daemon[232]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.14' (uid=0 pid=449 comm="/usr/lib/polkit-1/polkit-agent-helper-1 librasubti")
Oct 09 13:39:49 asus dbus-daemon[232]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Oct 09 13:39:49 asus polkit-agent-helper-1[449]: pam_systemd_home(polkit-1:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Oct 09 13:39:49 asus kernel: audit: type=1101 audit(1602243589.110:46): pid=449 uid=1000 auid=1000 ses=1 msg='op=PAM:accounting grantors=pam_permit,pam_time acct="librasubtilis" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
Oct 09 13:39:49 asus audit[449]: USER_ACCT pid=449 uid=1000 auid=1000 ses=1 msg='op=PAM:accounting grantors=pam_permit,pam_time acct="librasubtilis" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
Oct 09 13:39:49 asus polkitd[440]: Operator of unix-process:435:3631 successfully authenticated as unix-user:librasubtilis to gain TEMPORARY authorization for action org.freedesktop.systemd1.manage-units for system-bus-name::1.13 [systemctl start iwd.service] (owned by unix-user:librasubtilis)
Oct 09 13:39:49 asus polkitd[440]: Unregistered Authentication Agent for unix-process:435:3631 (system bus name :1.11, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale C) (disconnected from bus)
Oct 09 13:39:50 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:39:54 asus kernel: wlan0: authenticate with e4:3e:d7:d3:41:2b
Oct 09 13:39:54 asus kernel: wlan0: send auth to e4:3e:d7:d3:41:2b (try 1/3)
Oct 09 13:39:54 asus kernel: wlan0: e4:3e:d7:d3:41:2b denied authentication (status 112)
Oct 09 13:39:54 asus kernel: wlan0: authenticate with e4:3e:d7:d3:41:2f
Oct 09 13:39:54 asus kernel: wlan0: send auth to e4:3e:d7:d3:41:2f (try 1/3)
Oct 09 13:39:54 asus kernel: wlan0: authenticated
Oct 09 13:39:54 asus kernel: wlan0: associate with e4:3e:d7:d3:41:2f (try 1/3)
Oct 09 13:39:54 asus kernel: wlan0: RX AssocResp from e4:3e:d7:d3:41:2f (capab=0x511 status=0 aid=13)
Oct 09 13:39:54 asus kernel: wlan0: associated
Oct 09 13:39:54 asus kernel: wlan0: disassociated from e4:3e:d7:d3:41:2f (Reason: 1=UNSPECIFIED)
Oct 09 13:39:54 asus wpa_supplicant[405]: wlan0: No network configuration found for the current AP
Oct 09 13:39:54 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-DISCONNECTED bssid=e4:3e:d7:d3:41:2f reason=3 locally_generated=1
Oct 09 13:39:54 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.1430] device (wlan0): supplicant interface state: disconnected -> associated
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.1431] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> associated
Oct 09 13:39:54 asus iwd[235]: Received Deauthentication event, reason: 1, from_ap: true
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.1449] device (wlan0): supplicant interface state: associated -> disconnected
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.1449] device (p2p-dev-wlan0): supplicant management interface state: associated -> disconnected
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.2485] device (wlan0): supplicant interface state: disconnected -> scanning
Oct 09 13:39:54 asus NetworkManager[233]: <info>  [1602243594.2486] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> scanning
Oct 09 13:40:00 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:40:04 asus NetworkManager[233]: <info>  [1602243604.9283] device (wlan0): supplicant interface state: scanning -> disconnected
Oct 09 13:40:04 asus NetworkManager[233]: <info>  [1602243604.9284] device (p2p-dev-wlan0): supplicant management interface state: scanning -> disconnected
Oct 09 13:40:05 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:40:09 asus NetworkManager[233]: <info>  [1602243609.7647] device (wlan0): supplicant interface state: disconnected -> inactive
Oct 09 13:40:09 asus NetworkManager[233]: <info>  [1602243609.7648] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> inactive
Oct 09 13:40:12 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:40:16 asus wpa_supplicant[405]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Oct 09 13:40:19 asus audit[459]: USER_AUTH pid=459 uid=1000 auid=1000 ses=1 msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="librasubtilis" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus kernel: audit: type=1100 audit(1602243619.030:47): pid=459 uid=1000 auid=1000 ses=1 msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="librasubtilis" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus dbus-daemon[232]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.20' (uid=0 pid=459 comm="sudo journalctl -b ")
Oct 09 13:40:19 asus dbus-daemon[232]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Oct 09 13:40:19 asus sudo[459]: pam_systemd_home(sudo:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Oct 09 13:40:19 asus sudo[459]: librasubtilis : TTY=tty1 ; PWD=/home/librasubtilis ; USER=root ; COMMAND=/usr/bin/journalctl -b
Oct 09 13:40:19 asus audit[459]: USER_ACCT pid=459 uid=1000 auid=1000 ses=1 msg='op=PAM:accounting grantors=pam_permit,pam_time acct="librasubtilis" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus audit[459]: CRED_REFR pid=459 uid=0 auid=1000 ses=1 msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus audit[459]: USER_START pid=459 uid=0 auid=1000 ses=1 msg='op=PAM:session_open grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus sudo[459]: pam_unix(sudo:session): session opened for user root(uid=0) by librasubtilis(uid=0)
Oct 09 13:40:19 asus kernel: audit: type=1101 audit(1602243619.033:48): pid=459 uid=1000 auid=1000 ses=1 msg='op=PAM:accounting grantors=pam_permit,pam_time acct="librasubtilis" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus kernel: audit: type=1110 audit(1602243619.033:49): pid=459 uid=0 auid=1000 ses=1 msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'
Oct 09 13:40:19 asus kernel: audit: type=1105 audit(1602243619.036:50): pid=459 uid=0 auid=1000 ses=1 msg='op=PAM:session_open grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=asus addr=? terminal=/dev/tty1 res=success'

Last edited by LibraSubtilis (2020-10-09 12:16:04)

Offline

#4 2020-10-21 15:24:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,781

Re: [SOLVED] connect to wlan after installation

Sorry that one drowned a bit, you have iwd and networkmanager (... with wpa_supplicant as the WPA backend) enabled. That doesn't work, decide for networkmanager OR iwd (... or configure networkmanager to actually use iwd ) and disable the other daemon, they run into a fight for the networkcontroller otherwise

Offline

#5 2020-10-22 15:14:58

LibraSubtilis
Member
Registered: 2020-10-08
Posts: 3

Re: [SOLVED] connect to wlan after installation

You found the problem! I was using multiple tutorials and installed both without knowing the consequence. Thank you very much (^.^)

Offline

Board footer

Powered by FluxBB