You are not logged in.

#1 2020-08-01 07:21:38

alexmaras
Member
Registered: 2020-08-01
Posts: 1

Lenovo Ideapad 14ARE05 - Internal Microphone not detected/recording

My Lenovo Ideapad 14ARE05 is having trouble identifying the microphone correctly.
`pavucontrol` shows "microphone (unplugged)" and alsamixer shows "Capture" and "Mic Boost" meters, both of which I've pushed up to full (and ensured are active).
I've tried recording in audacity, which seems to just fail - having trouble with sample rate - and `arecord`, which just seems to record nothing.

I've run alsa-info.sh with results here: http://alsa-project.org/db/?f=cdc89e314 … 3317d2cc2b

Speakers work fine, no issues there. I've tried completely disabling pulseaudio before attempting `arecord` (using `systemctl --user stop pulseaudio.socket` and `systemctl --user stop pulseaudio`, and the process is stopped).

Any help is appreciated - the arch wiki entry shows that audio works OOTB with pulseaudio. I'm updated on the `linux` kernal package, and I've also tried `linux-mainline` (currently 5.8rc7) with the same issue.

Thanks!

EDIT: Submitted an ALSA driver bug here: https://bugzilla.kernel.org/show_bug.cgi?id=208763

Last edited by alexmaras (2020-08-01 08:09:44)

Offline

#2 2020-09-04 15:56:14

saint613
Member
Registered: 2020-06-25
Posts: 11

Re: Lenovo Ideapad 14ARE05 - Internal Microphone not detected/recording

Are the audio meters moving? if so unlock the channels, reduce the right channel to zero and set the left channel to about 40% and test recording. using skype make sure to make the changes under that software.

Offline

#3 2020-09-22 09:54:41

fivexthree
Member
Registered: 2020-09-22
Posts: 1

Re: Lenovo Ideapad 14ARE05 - Internal Microphone not detected/recording

I have the same issue with Lenovo ideapad.  A program like Audacity can record from and play back to any device that is connected (internal mic, USB webcam, USB headset), but pulseaudio does not list them.  This is affecting any conferencing app, like Skype, MS Teams (yuck I know but work makes us), or any web based app that needs the microphone.  I see a tiny movement in the "Internal Microphone" monitor bar of pavucontrol Input Devices tab if I slam my hand on the desk to make a large noise.  At the same time I am monitoring in Audacity, which shows the audio slamming into clipping, so there is a gain setting between the two apps that is different(?)

I tried to update to pulseaudio-git as recommended in this thread (https://bbs.archlinux.org/viewtopic.php?id=257433), but could not due to the mentioned dependency errors on Manjaro:

https://aur.archlinux.org/packages/pulseaudio-git/

System particulars:

$ uname -r
5.4.64-1-MANJARO

$ pulseaudio --version
pulseaudio 13.0

$ pavucontrol --version
pavucontrol 4.0

Offline

#4 2020-09-22 17:29:06

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,076
Website

Re: Lenovo Ideapad 14ARE05 - Internal Microphone not detected/recording

fivexthree, you were told when you registered that these forums are for Arch Linux only. Please ask on the Manjaro forums if you need assistance.

https://bbs.archlinux.org/misc.php?action=rules


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2020-11-09 12:13:20

roselove
Member
Registered: 2020-11-09
Posts: 1

Re: Lenovo Ideapad 14ARE05 - Internal Microphone not detected/recording

Sorry about this, as I'm also a manjaro user (did have Arch for 3 years btw), it seems I have the same kinda bug since last kernel update on my `Lenovo Legion 5-15ARH05 Type 82B5` which have the same audio controller smile

I posted on a manjaro forum here :

https://forum.manjaro.org/t/microphone- … ed/27487/4

This message is only here to help those like me that have the same problem and are looking for answers

Offline

Board footer

Powered by FluxBB