You are not logged in.

#1 2020-11-15 18:05:04

ssri
Member
Registered: 2010-02-16
Posts: 216

[SOLVED] Wifi works with pacman and DE programs but not with ping

After updating the kernel to 5.9 a few weeks ago, I noticed that pinging google resulted in 100% packet loss. This result was also the case when I started up X and my KDE session. However, in my KDE session, pacman updated from its mirror (-Syu) and redownloaded its package list (-Syy) just fine, I could curl google's homepage, but lynx didn't work immediately (attempting to visit google's homepage as well as arch's frontpage). With lynx, it gets stuck in "Making https connection" for several minutes before a page is brought up. The same webpage quickly and predictably opens up when using firefox or chromium.

When I noticed this happening, I had the dhcpcd service running along with NetworkManager and read that an upstream update earlier this year rendered dhcpcd to be incompatible with NetworkManger. So, I disabled dhcpcd and rebooted. Same result. A subsequent kernel 5.9.x update brought things back to normal but then a later kernel 5.9.x update brought me back to square one. I have been running NetworkManager fine for a couple of years before this.

Are there any additional services that I need activate to have wifi work in the console?

  alsa-restore.service
  bluetooth.service
  bumblebeed.service
  cpupower.service
  dbus.service
  getty@tty1.service
  kmod-static-nodes.service
  ldconfig.service
  lvm2-lvmetad.service
  lvm2-monitor.service
  NetworkManager.service
  ntpd.service
  packagekit.service
  polkit.service
  rtkit-daemon.service
  systemd-backlight@backlight:intel_backlight.service
  systemd-fsck@dev-disk-by\x2dpartuuid-09c6b4b8\x2d27f1\x2d425e\x2d91b0\x2dbee6aa0726ad.service
  systemd-fsck@dev-disk-by\x2dpartuuid-c56c3317\x2dce0f\x2d47e3\x2d92c5\x2d0e526753e2ba.service
  systemd-fsck@dev-disk-by\x2dpartuuid-fb265e64\x2d9b91\x2d4cc6\x2d8990\x2d4bbefa2cb3f6.service
  systemd-hwdb-update.service
  systemd-journal-catalog-update.service
  systemd-journal-flush.service
  systemd-journald.service
  systemd-logind.service
  systemd-modules-load.service
  systemd-random-seed.service
  systemd-remount-fs.service
  systemd-sysctl.service
  systemd-sysusers.service
  systemd-timesyncd.service
  systemd-tmpfiles-setup-dev.service
  systemd-tmpfiles-setup.service
  systemd-udev-trigger.service
  systemd-udevd.service
  systemd-update-done.service
  systemd-update-utmp.service
  systemd-user-sessions.service
  udisks2.service
  upower.service
  user-runtime-dir@1000.service
  user@1000.service
  wpa_supplicant.service
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Sun 2020-11-15 09:31:18 PST; 5min ago
       Docs: man:NetworkManager(8)
   Main PID: 462 (NetworkManager)
      Tasks: 3 (limit: 19067)
     Memory: 16.2M
     CGroup: /system.slice/NetworkManager.service
             └─462 /usr/bin/NetworkManager --no-daemon

Nov 15 09:31:24 hosthost NetworkManager[462]: <info>  [1605461484.4820] device (wlp3s0): Activation: successful, device activated.
Nov 15 09:31:25 hosthost NetworkManager[462]: <info>  [1605461485.0356] manager: NetworkManager state is now CONNECTED_GLOBAL
Nov 15 09:31:26 hosthost NetworkManager[462]: <info>  [1605461486.0663] dhcp6 (wlp3s0): activation: beginning transaction (timeout in 45 seconds)
Nov 15 09:31:26 hosthost NetworkManager[462]: <info>  [1605461486.0682] policy: set 'hubhub' (wlp3s0) as default for IPv6 routing and DNS
Nov 15 09:31:26 hosthost NetworkManager[462]: <info>  [1605461486.4146] dhcp6 (wlp3s0): option dhcp6_name_servers   => '9999:999:9f::99 9999:999:9f:9::99'
Nov 15 09:31:26 hosthost NetworkManager[462]: <info>  [1605461486.4147] dhcp6 (wlp3s0): state changed unknown -> bound
Nov 15 09:31:26 hosthost NetworkManager[462]: <info>  [1605461486.4948] manager: startup complete
Nov 15 09:32:42 hosthost NetworkManager[462]: <info>  [1605461562.8127] agent-manager: agent[blahblah,:1.41/org.kde.plasma.networkmanagement/1000]: agent registered
Nov 15 09:33:26 hosthost NetworkManager[462]: <info>  [1605461606.1592] audit: op="statistics" arg="refresh-rate-ms" pid=684 uid=1000 result="success"
Nov 15 09:34:05 hosthost NetworkManager[462]: <info>  [1605461645.9776] audit: op="statistics" arg="refresh-rate-ms" pid=684 uid=1000 result="success"
● wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; vendor preset: disabled)
     Active: active (running) since Sun 2020-11-15 09:31:21 PST; 5min ago
   Main PID: 493 (wpa_supplicant)
      Tasks: 1 (limit: 19067)
     Memory: 4.4M
     CGroup: /system.slice/wpa_supplicant.service
             └─493 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant

Nov 15 09:31:21 hosthosthost systemd[1]: Started WPA supplicant.
Nov 15 09:31:21 hosthosthost wpa_supplicant[493]: Successfully initialized wpa_supplicant
Nov 15 09:31:21 hosthosthost wpa_supplicant[493]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_supplicant1.Interface.P2PDevice dbus_property=P2PDeviceConfig getter failed
Nov 15 09:31:23 hosthosthost wpa_supplicant[493]: wlp3s0: SME: Trying to authenticate with "macaddress" (SSID='hubhub' freq=2427 MHz)
Nov 15 09:31:23 hosthosthost wpa_supplicant[493]: wlp3s0: Trying to associate with "macaddress" (SSID='hubhub' freq=2427 MHz)
Nov 15 09:31:24 hosthosthost wpa_supplicant[493]: wlp3s0: Associated with "macaddress"
Nov 15 09:31:24 hosthosthost wpa_supplicant[493]: wlp3s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Nov 15 09:31:24 hosthosthost wpa_supplicant[493]: wlp3s0: WPA: Key negotiation completed with "macaddress" [PTK=CCMP GTK=CCMP]
Nov 15 09:31:24 hosthosthost wpa_supplicant[493]: wlp3s0: CTRL-EVENT-CONNECTED - Connection to "macaddress" completed [id=0 id_str=]
Nov 15 09:31:24 hosthosthost wpa_supplicant[493]: wlp3s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-36 noise=9999 txrate=6500

Last edited by ssri (2020-11-16 07:40:28)

Offline

#2 2020-11-15 18:15:58

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,627
Website

Re: [SOLVED] Wifi works with pacman and DE programs but not with ping

You should not run wpa_supplicant service and network manager.  Pick one and disable the other(s).

But I have a hunch from that output that perhaps you have ipv6 only.  What do you get from pinging only one or the other (and lets also rule out dns issues at the same time:

ping -4 google.com
ping -4 172.217.4.46
ping -6 google.com
ping -6 2607:f8b0:4009:801::200e

"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2020-11-15 18:18:54

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 432

Re: [SOLVED] Wifi works with pacman and DE programs but not with ping

Also..

cat /etc/NetworkManager/conf.d/wifi_backend.conf

Offline

#4 2020-11-15 19:14:45

ssri
Member
Registered: 2010-02-16
Posts: 216

Re: [SOLVED] Wifi works with pacman and DE programs but not with ping

Trilby wrote:

You should not run wpa_supplicant service and network manager.  Pick one and disable the other(s).

But I have a hunch from that output that perhaps you have ipv6 only.  What do you get from pinging only one or the other (and lets also rule out dns issues at the same time:

ping -4 google.com
ping -4 172.217.4.46
ping -6 google.com
ping -6 2607:f8b0:4009:801::200e

Thanks for your help. I prefer network manager, so I tried disabling wpa_supplicant's service via

# systemctl disable wpa_supplicant

However, d-bus keeps restarting it, even after reboot. Also, masking wpa_supplicant via systemctl, which creates a symlink for the service file > /dev/null), removes my wifi connection completely (my wireless hub no longer shows up in nmtui), so I removed the symlink and brought wpa_supplicant back.

From your ping suggestions, the ipv4 address works fine, but not the ipv6 addresses. "ip a" brings up (edited out the ipv6 and mac addresses):

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether "MAC address" brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether "MAC address" brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.10/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 85541sec preferred_lft 85541sec
    inet6 9999:9999:9999:56d:9999:9999:9999:9999/64 scope global dynamic noprefixroute 
       valid_lft 8544sec preferred_lft 8544sec
    inet6 9999::9999:9999:9999:9999/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
Zod wrote:

Also..

cat /etc/NetworkManager/conf.d/wifi_backend.conf

Hi, thanks. The file does not exist. In fact, the directory is empty.

Last edited by ssri (2020-11-15 19:15:51)

Offline

#5 2020-11-15 19:27:53

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 432

Re: [SOLVED] Wifi works with pacman and DE programs but not with ping

NetworkManager, by default, use's wpa_supplicant so it needs to be there just not enabled (NM will call it if it needs it).

You probably need to sort out if your gateway device supports ipv6, if it does *not* then you might consider disabling ipv6..
https://wiki.archlinux.org/index.php/IPv6#Disable_IPv6

That will make it so that it's not even a choice.

If your gateway device does support ipv6 then further troubleshooting is required.

Offline

#6 2020-11-15 20:55:42

ssri
Member
Registered: 2010-02-16
Posts: 216

Re: [SOLVED] Wifi works with pacman and DE programs but not with ping

Zod wrote:

NetworkManager, by default, use's wpa_supplicant so it needs to be there just not enabled (NM will call it if it needs it).

You probably need to sort out if your gateway device supports ipv6

You're correct on both counts. It appears that my ISP-provided static IPv6 DNS Addresses expired, and now they should be automatically fetched. I don't know if the work they did in my area a few weeks ago effectuated this change. Anyways, changing my ipv6 settings on my router to autofetch the ipv6 DNS from my ISP resolved this issue. Thanks.

Last edited by ssri (2020-11-15 23:17:11)

Offline

Board footer

Powered by FluxBB