You are not logged in.

#1 2020-12-13 13:21:02

babolivier
Member
From: London
Registered: 2020-12-13
Posts: 3
Website

Wine can't open graphical apps anymore

Hey there,

Up until a few weeks ago, I was using Wine to play some Windows games on Arch, and it was working pretty well. The only issue I had is that keyboard support in one of these games wasn't working so, following advice from this reddit comment, I changed the Windows version to Windows 10 and enabled "Emulate virtual desktop", but that's the only bits of custom config I've got.

A bit over 3w ago (probably following a system update (i.e. pacman -Syu)) Wine stopped being able to open graphical applications. When I try to run one after ~/.wine has been removed/renamed (I saw other posts suggesting that might fix it as it forces wine to start with a fresh config), it says the following in the terminal:

0024:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002

After which it hangs a bit (Ctrl+C doesn't immediately terminate it), and then terminates (after hitting Ctrl+C) with:

0024:err:seh:NtRaiseException Unhandled exception code c000013a flags 0 addr 0xf7fd0549
0050:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0050:err:winediag:nodrv_CreateWindow Unknown error (998).
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 14007
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x800736b7
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x800736b7
0050:err:ole:apartment_get_local_server_stream Failed: 0x800736b7
0050:err:ole:start_rpcss Failed to open RpcSs service

If I try running it after that first time, it only shows the following:

0024:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002

I looked around a bit for solutions and stumbled upon things like https://forum.artixlinux.org/index.php/ … 671.0.html or https://bbs.archlinux.org/viewtopic.php?id=230199, but none of the solutions mentioned fixed it for me. I've also tried removing/renaming my ~/.wine directory and calling winecfg again to start again with a fresh config but that also didn't work.

Does anyone have any idea that could help me fix this issue?

Offline

#2 2020-12-13 14:14:17

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,908

Re: Wine can't open graphical apps anymore

Try running a very simple graphics application :

wine winemine

Are you using wine or wine-staging ?
What WM/DE are you using ?
please post lspci -k


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2020-12-13 16:37:12

babolivier
Member
From: London
Registered: 2020-12-13
Posts: 3
Website

Re: Wine can't open graphical apps anymore

Lone_Wolf wrote:

Try running a very simple graphics application :

wine winemine
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002

It then hangs there until I sigterm it. If I do that right after deleting my ~/.wine the following lines appear after I sigterm it:

0050:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0050:err:winediag:nodrv_CreateWindow Unknown error (998).
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 14007
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x800736b7
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x800736b7
0050:err:ole:apartment_get_local_server_stream Failed: 0x800736b7
0050:err:ole:start_rpcss Failed to open RpcSs service
Lone_Wolf wrote:

Are you using wine or wine-staging ?

I was initially running wine-staging (and the issue appeared with staging) but in my previous attempts to fix it I uninstalled it and installed wine (and renamed ~/.wine to avoid staging writing config wine might not support) so I'm now using wine.

Lone_Wolf wrote:

What WM/DE are you using ?

Gnome shell

Lone_Wolf wrote:

please post lspci -k

$ lspci -k
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
	Subsystem: Dell Device 0905
	Kernel driver in use: skl_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
	DeviceName:  Onboard IGD
	Subsystem: Dell Device 0905
	Kernel driver in use: i915
	Kernel modules: i915
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
	Subsystem: Dell Device 0905
	Kernel driver in use: proc_thermal
	Kernel modules: processor_thermal_device
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
	Subsystem: Dell Device 0905
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
	Subsystem: Dell Device 0905
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: ahci
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #17 (rev f0)
	Kernel driver in use: pcieport
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #1 (rev f0)
	Kernel driver in use: pcieport
00:1c.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #5 (rev f0)
	Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Cannon Lake LPC Controller (rev 10)
	Subsystem: Dell Device 0905
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
	Subsystem: Dell Device 0905
	Kernel driver in use: intel-spi
	Kernel modules: intel_spi_pci
01:00.0 3D controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
	Subsystem: Hewlett-Packard Company Device 8601
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia
02:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
	Kernel driver in use: pcieport
03:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
	Kernel driver in use: pcieport
03:01.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
	Kernel driver in use: pcieport
03:02.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
	Kernel driver in use: pcieport
04:00.0 System peripheral: Intel Corporation JHL6340 Thunderbolt 3 NHI (C step) [Alpine Ridge 2C 2016] (rev 02)
	Subsystem: Dell Device 0905
	Kernel driver in use: thunderbolt
	Kernel modules: thunderbolt
3a:00.0 USB controller: Intel Corporation JHL6340 Thunderbolt 3 USB 3.1 Controller (C step) [Alpine Ridge 2C 2016] (rev 02)
	Subsystem: Dell Device 0905
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
3b:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
	Subsystem: Bigfoot Networks, Inc. Device 1654
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
3c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
	Subsystem: Dell Device 0905
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci
3d:00.0 Non-Volatile memory controller: SK hynix Device 1639
	Subsystem: SK hynix Device 1639
	Kernel driver in use: nvme

Last edited by babolivier (2020-12-13 16:37:45)

Offline

#4 2020-12-13 21:34:37

babolivier
Member
From: London
Registered: 2020-12-13
Posts: 3
Website

Re: Wine can't open graphical apps anymore

I've somewhat figured it out. It's due to my nvidia drivers misbehaving, which I also need to figure out but is probably another issue entirely, so I'll investigate that one and open another thread if I can't figure it out on my own.

Last edited by babolivier (2020-12-13 21:34:48)

Offline

#5 2020-12-21 10:14:49

sincomil
Member
Registered: 2018-02-13
Posts: 96

Re: Wine can't open graphical apps anymore

I can confirm that something was broken in wine-5.22, because after update to 5.22 from 5.21 this two games become broken/not working:
* EVE Online (crashing before login screen appears)
* World of Tanks (hangs on login screen)
Both with DXVK(1.7.3) on Radeon 5700XT/amdgpu(opensource)+mesa

wine-staging-5.21 - also working, but wine-staging-5.22 - not working too.

Offline

#6 2021-01-04 15:56:20

k44
Member
Registered: 2013-03-30
Posts: 22

Re: Wine can't open graphical apps anymore

I have the same issue. Did someone figure it out ?

Offline

#7 2021-01-04 22:31:32

Ttz_ztT
Member
Registered: 2015-10-03
Posts: 15

Re: Wine can't open graphical apps anymore

I suddenly couldn't start some games with dxvk + wine-staging 5.22. After some trial and error, I installed wine (without staging), which didn't really help (other errors).
But after reinstalling wine staging 5.22 (wine-staging -> wine -> wine-staging), everything works as expected again ?

I had most problems with SKSE (Skyrim / Enderal) which "Couldn't inject .dll".

Offline

#8 2021-01-04 22:35:28

k44
Member
Registered: 2013-03-30
Posts: 22

Re: Wine can't open graphical apps anymore

Because I need this for work, I've downgraded wine to 5.10 and it's ok for now (found on another forum thread)

Offline

#9 2021-02-01 17:59:50

iamzimy
Member
Registered: 2019-10-24
Posts: 7

Re: Wine can't open graphical apps anymore

Still having this problem in Wine 6.1.1, the only solution for now is to downgrade.

Offline

#10 2021-02-10 21:00:28

penitentliar
Member
Registered: 2021-01-03
Posts: 2

Re: Wine can't open graphical apps anymore

Same here, since 6.1.1 nothing works

Offline

Board footer

Powered by FluxBB