You are not logged in.

#26 2006-08-25 19:25:10

From: 1992
Registered: 2006-08-08
Posts: 1,581

Re: No GUI

imo u have to read ALL wiki entries starting with the how-to's before posting in the forums.all the info u need to get started is there.

There shouldn't be any reason to learn more editor types than emacs or vi -- mg (1)
[You learn that sarcasm does not often work well in international forums.  That is why we avoid it. -- ewaller (arch linux forum moderator)


#27 2006-09-19 16:58:34

Registered: 2006-09-19
Posts: 51

Re: No GUI

I am setting mine up right now, but am confused.  The Wiki says:


hwd is a tool written by users in the Arch Linux community. It's basically a hardware detection tool that has multiple uses, one of which is setting up an X server. Fortunately, hwd is much more streamlined than xorgconf and doesn't require any input at all.

First, you need to install it:

pacman -S hwd

But here you say not to use that?  So how do I use MOD_AUTOLOAD instead?

Sorry, I couldn't find it in the Wiki.


#28 2006-09-19 22:13:07

From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: No GUI

Udev is now used for module loading:

will activate autoloading modules during boot process
+ autoloading of modules after boot
(aka cold/hotplugging)

MOD_BLACKLIST=(moduleA moduleB) and MODULES=(!moduleA !moduleB) is the same now!
Udev will not load the module for you if autoloading is activated!

Please remove the OSS compatibility modules from
else your soundcard may fail to load!


#29 2006-09-19 22:59:27

Registered: 2006-09-19
Posts: 51

Re: No GUI

ok, thanks.  I already had that.  I have tried so many things trying to get this to work that I can't even remember what I have done.

this is the video card I have:  ATI Technologies Inc Radeon Mobility 7000

I have installed the ATI drivers, that I found instructions for on a Wiki page (but now I can't find where that was).  I tried configureing the xorg.conf with xorgconfig, but that didn't work, so I used aticonfig, but it still does not work. 

When I run startx, it gives me:
(EE) No devices detected.

Fatal server error:
no screens found

Is this a problem with the xorg.conf file?  I have looked over it, but can't see what is wrong.

Edit:  One other thing, Xorg -configure gives me a fatal server error:  caught signal 11. server aborting



Board footer

Powered by FluxBB