You are not logged in.

#26 2021-01-13 16:11:31

seth
Member
Registered: 2012-09-03
Posts: 18,269

Re: [Solved] Boot stuck at "starting version 247.2-1-arch"

       696:	file=libgpg-error.so.0 [0];  generating link map
       696:	  dynamic: 0x00007f2a154a4a60  base: 0x00007f2a1547f000   size: 0x00000000000261d0
       696:	    entry: 0x00007f2a15484040  phdr: 0x00007f2a1547f040  phnum:                  9
       696:	
       696:	checking for version `GCC_3.0' in file /usr/lib/libgcc_s.so.1 [0] required by file /usr/lib/polkit-1/polkitd [0]
       696:	checking for version `CXXABI_1.3.9' in file /usr/lib/libstdc++.so.6 [0] required by file /usr/lib/polkit-1/polkitd [0]
       696:	checking for version `GLIBCXX_3.4' in file /usr/lib/libstdc++.so.6 [0] required by file /usr/lib/polkit-1/polkitd [0]
       696:	checking for version `CXXABI_1.3' in file /usr/lib/libstdc++.so.6 [0] required by file /usr/lib/polkit-1/polkitd [0]
       696:	checking for version `LIBSYSTEMD_213' in file /usr/lib/libsystemd.so.0 [0] required by file /usr/lib/polkit-1/polkitd [0]
       696:	checking for version `LIBSYSTEMD_209' in file /usr/lib/libsystemd.so.0 [0] required by file /usr/lib/polkit-1/polkitd [0]
pacman -Qikk systemd-libs

Offline

#27 2021-01-13 16:36:26

gdeshors
Member
Registered: 2015-01-22
Posts: 34

Re: [Solved] Boot stuck at "starting version 247.2-1-arch"

Here it is : http://ix.io/2LUW

Offline

#28 2021-01-13 20:56:54

seth
Member
Registered: 2012-09-03
Posts: 18,269

Re: [Solved] Boot stuck at "starting version 247.2-1-arch"

*grumpf* (ie. there're no issues)

'key, the next check here would be

297250:     checking for version `mozjs_78' in file /usr/lib/libmozjs-78.so [0] required by file /usr/lib/polkit-1/polkitd [0]

So ler's assume that's the one triggering the segfault (and compromising the stack and so the debug doesn't get print or whatever…)

pacman -Qikk js78

and maybe just force-reinstall the package.

Offline

#29 2021-01-13 23:13:11

gdeshors
Member
Registered: 2015-01-22
Posts: 34

Re: [Solved] Boot stuck at "starting version 247.2-1-arch"

Ok, just for fun : http://ix.io/2LXh

I reinstalled it with pacman -S js78, reset the default target, rebooted and it works again ! Thanks so much. Do you have an idea what happened and could you please explain the commands you had me type ?

Offline

#30 2021-01-13 23:22:41

seth
Member
Registered: 2012-09-03
Posts: 18,269

Re: [Solved] Boot stuck at "starting version 247.2-1-arch"

pacman -Qikk prints the package info and checks its integrity.
There're no errors so the files on disk matched the package expections.
The only explanation I have is that the package must have been compromised either during the download or on disk, you should probably check https://wiki.archlinux.org/index.php/Smart

----

strace logs system calls, ldd prints the linker resolution (which libraries are used by an executable)

"LC_ALL=C LD_DEBUG=all /usr/lib/polkit-1/polkitd > ~/very.big.ld.debug.file 2>&1"
"LC_ALL=C" - english, please tongue
"LD_DEBUG=all" - have ld (where stuff crashes) print all possible debug info
"/usr/lib/polkit-1/polkitd" - well, polkitd…
"> ~/very.big.ld.debug.file" - output redirection
"2>&1" - direct stderr to stdout to catch stderr in the stdout redirection (ie. very.big.ld.debug.file)

Offline

Board footer

Powered by FluxBB