You are not logged in.

#1 2020-12-24 10:52:48

Registered: 2015-10-20
Posts: 3

IPv6 address disappear suddenly on Home Network

I booted my archlinux box. It can get IPv6 address from my ASUS router.  The IPv6 address will disappear suddenly. I had tried to turn the ip6tables off but it does not help.

I did not see any system log related to this issue. How can I debug this problem?


#2 2021-01-09 13:59:13

Registered: 2010-11-12
Posts: 21

Re: IPv6 address disappear suddenly on Home Network

It's possible your router is suffering from the issue described here (Assuming everything on your router and your archlinux box is configured correctly, which I'm guessing is the case, since you have an IPv6 address to start.)

You can verify this is or isn't the issue by using a packet sniffer to check if the router is sending unsolicited RA's every few seconds or not. If it's not sending the RA's, then toggling "Enable Router Advertisement" as described in that thread, or simply rebooting the router, fixes this issue. It happens so infrequently for me that I haven't dug any further into it.


#3 2021-01-09 15:50:15

Registered: 2018-10-30
Posts: 161

Re: IPv6 address disappear suddenly on Home Network

I've suffered from this in the past, too.  Toggling "Enable RA" or rebooting the router fixed it.

For me, the main cause was my ISP was changing my PD at least every 6 hours.  They've finally got their IPv6 issues sorted out, and I've not seen this for almost a year, now.

It's a big club...and you ain't in it -- George Carlin
Eenie meenie, chili beanie, the spirits are about to speak -- Bullwinkle J. Moose
Registered Linux user #149839
perl -e 'print$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10); '


#4 2021-01-24 03:42:48

Registered: 2014-06-10
Posts: 1

Re: IPv6 address disappear suddenly on Home Network

Thank you very much, after rebooting the router, IPv6 is back. Worked like a charm.


Board footer

Powered by FluxBB