You are not logged in.

#1 2006-09-19 17:31:53

LaoTzuTao
Member
From: Eugene, OR
Registered: 2006-05-24
Posts: 20

Samba not working in Arch, works in FreeBSD

My Samba hasn't been working for quite some time now in Arch. I play around with a few other distros and also FreeBSD so I haven't bothered trying to fix it yet, but now its really getting to be a problem. I get this error when trying to connect to my share.

[2006/09/19 10:16:57, 0] smbd/service.c:make_connection_snum(911)
  '/home/john/share' does not exist or permission denied when connecting to [archshare] Error was Permission denied

/home/john/share does exist, and here it is...

drwxrwxrwx 11 john wheel      288 2006-08-18 20:48 share

smb.comf -

#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
   server string =

# Security mode. Defines in which mode Samba will operate. Possible
# values are share, user, server, domain and ads. Most people will want
# user level security. See the Samba-HOWTO-Collection for details.
   security = share

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
;   hosts allow = 192.168.1. 192.168.2. 127.

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
   load printers = yes

# you may wish to override the location of the printcap file
;   printcap name = /etc/printcap

# on SystemV system setting printcap name to lpstat should allow
# you to automatically obtain a printer list from the SystemV spool
# system
;   printcap name = lpstat

# It should not be necessary to specify the print system type unless
# it is non-standard. Currently supported print systems include:
# bsd, cups, sysv, plp, lprng, aix, hpux, qnx
;   printing = cups

# Uncomment this if you want a guest account, you must add this to /etc/passwd
# otherwise the user "nobody" is used
;  guest account = pcguest

# this tells Samba to use a separate log file for each machine
# that connects
#   log file = /var/log/samba/log.%m

# Put a capping on the size of the log files (in Kb).
   max log size = 50

# Use password server option only with security = server
# The argument list may include:
#   password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
# or to auto-locate the domain controller/s
#   password server = *
;   password server = <NT>

# Use the realm option only with security = ads
# Specifies the Active Directory realm the host is part of
;   realm = MY_REALM

# Backend to store user information in. New installations should
# use either tdbsam or ldapsam. smbpasswd is available for backwards
# compatibility. tdbsam requires no further configuration.
;   passdb backend = tdbsam

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting.
# Note: Consider carefully the location in the configuration file of
#       this line.  The included file is read at that point.
;   include = /usr/local/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See the chapter 'Samba performance issues' in the Samba HOWTO Collection
# and the manual pages for details.
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
;   socket options = TCP_NODELAY

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
;   interfaces = 192.168.12.2/24 192.168.13.2/24

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
;   local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
;   os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
;   preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
;   domain logons = yes

# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
;   logon script = %m.bat
# run a specific logon batch file per username
;   logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
#        %L substitutes for this servers netbios name, %U is username
#        You must uncomment the [Profiles] share below
;   logon path = \%LProfiles%U

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
;   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#    Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one    WINS Server on the network. The default is NO.
;   wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The default is NO.
   dns proxy = no

# Charset settings
;   display charset = koi8-r
;   unix charset = koi8-r
;   dos charset = cp866

# Use extended attributes to store file modes
;    store dos attributes = yes
;    map hidden = no
;    map system = no
;    map archive = no

# Use inherited ACLs for directories
;    nt acl support = yes
;    inherit acls = yes
;    map acl inherit = yes

# These scripts are used on a domain controller or stand-alone
# machine to add or delete corresponding unix accounts
;  add user script = /usr/sbin/useradd %u
;  add group script = /usr/sbin/groupadd %g
;  add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
;  delete user script = /usr/sbin/userdel %u
;  delete user from group script = /usr/sbin/deluser %u %g
;  delete group script = /usr/sbin/groupdel %g


#============================ Share Definitions ==============================

# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes


[archshare]
path=/home/john/share
read only = no
browseable = yes
available = yes
guest ok = yes


I've tried tweaking little settings here and there, nothing has worked so far. So I just copied my smb.conf from my FreeBSD partition which is running the same version of Samba (samba 3.0.23C-1). And I still get the exact same error. Any ideas?

Offline

#2 2006-09-19 19:09:34

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Samba not working in Arch, works in FreeBSD

I have never used SHARE level security before.
I hear some clients have problems with it.. like sp2 XP clients.

I always use user level security.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2006-09-20 05:17:42

LaoTzuTao
Member
From: Eugene, OR
Registered: 2006-05-24
Posts: 20

Re: Samba not working in Arch, works in FreeBSD

I use share level with all my samba servers, I only have this problem with Arch. For giggles I did change it to user, same error.

Offline

#4 2006-09-21 21:21:14

LaoTzuTao
Member
From: Eugene, OR
Registered: 2006-05-24
Posts: 20

Re: Samba not working in Arch, works in FreeBSD

So I've still been trying to get this to work. I've uninstalled, and reinstalled samba, I've deleted every samba file and config file I could find, and reinstalled, nothing is working. I'm assuming this is something simple I'm just missing, but it's interesting how the same config works in FreeBSD and not in Arch. Both are fairly vanilla packages, same exact version of Samba. I assume most everyone else is also using 3.0.23C-1. Can anyone else post a working config file for a simple shared dir in their /home/user? Thanks

Offline

#5 2006-09-21 21:26:42

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Samba not working in Arch, works in FreeBSD

Have you check the config file with testparm? here ist samba up and running without problems


Have you tried to turn it off and on again?

Offline

#6 2006-09-21 21:36:14

LaoTzuTao
Member
From: Eugene, OR
Registered: 2006-05-24
Posts: 20

Re: Samba not working in Arch, works in FreeBSD

Never heard of that, but here it is -

$ testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[archshare]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        server string =
        security = SHARE
        log file = /var/log/samba/log.%m
        max log size = 50
        dns proxy = No

[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

[archshare]
        path = /home/john/share/
        read only = No
        guest ok = Yes

Offline

#7 2006-09-22 06:44:30

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Samba not working in Arch, works in FreeBSD

is your user known by samba?
you ahve to add the user to samba too, imho

Offline

#8 2006-09-22 19:24:03

LaoTzuTao
Member
From: Eugene, OR
Registered: 2006-05-24
Posts: 20

Re: Samba not working in Arch, works in FreeBSD

Well, usually clients connect as the user nobody, which does exist on my system.

nobody:x:99:99:nobody:/:/bin/false

I've never had to do anything specific to let users connect. The share folder is read/write for all users.

drwxrwxrwx 11 john wheel      288 2006-08-18 20:48 share

[archshare]
path=/home/john/share/
read only = no
browseable = yes
guest ok = yes

Guest ok is set to yes, which should make unspecified users connect as user nobody, which is how it used to work.

So I can see my box in the list of samba shares. So I connect to arch, no problem. I can see my share listed, archshare, no problem. I go to connect to archshare, and I get the "Archshare could not be found, perhaps it was recently deleted" error. So I check the syslog on my arch box, and thats where I find the syslog error -

[2006/09/22 12:19:00, 0] smbd/service.c:make_connection_snum(911)
  '/home/john/share' does not exist or permission denied when connecting to [archshare] Error was Permission denied

Ok, so the folder does exist, its set to read/write for world, why would permission be denied? There must be something simple I'm missing...any other ideas?

Offline

Board footer

Powered by FluxBB