You are not logged in.

#1 2021-02-23 00:43:25

juiocc
Member
Registered: 2021-02-22
Posts: 1

LibreOffice autocorrect works only after pressing Enter

Hello Arch users.

Recently I've installed Arch as my main desktop distro and everything was fine until I started using LibreOffice.
Firstly I noticed that hyphens weren't replaced with dashes even though it was enabled in AutoCorrect options. Then I discovered that only the last hyphen in paragraph is replaced (after I press Enter key). Next I found out not only hyphen replacement worked in such manner but all items in the replacement table worked the same way.

I'm typing:

aaa - bbb - ccc - ddd

Not a single hyphen is replaced with n-dash (–). If then I press Enter:

aaa - bbb - ccc - ddd<Enter>

text cursor moves to the next line and the last line become:

aaa - bbb - ccc – ddd

(note: only last hyphen was replaced)
Normally every hyphen should be replaced with a dash after typing any word-separating character (space, punctuation mark) after the word following the hyphen:

aaa - bbb<space>

=>

aaa – bbb 

If I add a new item in the replacement table (for example to change all aaa to bbb) or use the existing one (for example :_a: to get small letter alpha), it works the same way.
I'm typing:

aaa aaa aaa

Nothing is replaced. Then I press Enter:

aaa aaa aaa<Enter>

This line transforms to:

aaa aaa bbb

Normally every aaa should be replaced with bbb after typing any word-separating character after the last letter a in aaa.

Both libreoffice-fresh (7.1.0.3) and libreoffice-still (7.0.4.2) behave the same way. hunspell, hunspell-en_US, hyphen, hyphen-en, libmythes, mythes-en and even Java runtime are installed.
Moreover from the LibreOffice website I downloaded deb-packages of libreoffice versions 7.0.4, 7.1.0 and installed it on the fresh install of Arch Linux and Xubuntu in VirtualBox. On Arch autocorrect is broken, on Xubuntu works as expected. All LibreOffice options are the same.

Offline

#2 2021-03-01 21:58:56

zilverling
Member
From: Bennekom, Netherlands
Registered: 2009-08-19
Posts: 74

Re: LibreOffice autocorrect works only after pressing Enter

I experience the same issue. Have been using LibreOffice on Arch for many years and autocorrect worked fine. Not sure when it started, but it must have been relatively recently, as I experience it as quite annoying and will have noticed it quite soon.

Not sure if this is an issue with the archlinux package or if the problem comes from upstream. I have just filed a bug for this issue at https://bugs.archlinux.org/task/69848?p … ened=28556

Last edited by zilverling (2021-03-01 21:59:48)

Offline

#3 2021-03-02 09:51:55

zilverling
Member
From: Bennekom, Netherlands
Registered: 2009-08-19
Posts: 74

Re: LibreOffice autocorrect works only after pressing Enter

I received a reply to my bug report from the LibreOffice packager Andread Radke (thanks, Andreas!):

 Comment by Andreas Radke (AndyRTR) - Tuesday, 02 March 2021, 06:23 GMT
Seems to work well here. Please check your hunspell library and dictionary to be properly installed. Do you use AUR packages? Maybe starting fro command line shows up something.

Check:

Hunspell properly installed:

$ sudo pacman -Qs hunspell
local/hunspell 1.7.0-3
    Spell checker and morphological analyzer library and program
local/hunspell-de 20161207-6
    German hunspell dictionaries
local/hunspell-en_GB 2020.12.07-1
    GB English hunspell dictionaries
local/hunspell-en_US 2020.12.07-1
    US English hunspell dictionaries
local/hunspell-fr 7.0-1
    French (classic/modern) hunspell dictionaries
local/hunspell-nl 2.20.19-1
    Dutch hunspell dictionaries

AUR packages installed:

$ pacman -Qm
downgrade 9.0.0-1
evince-no-gnome 3.38.2-1
flashplugin 32.0.0.465-1
jamulus 3.6.2-1
magic-wormhole 0.12.0-2
microsoft-edge-dev-bin 90.0.803.0-1
package-query 1.11-1
pamac-aur 10.0.4-1
pgmodeler 3:0.9.3-1
python-hkdf 0.0.3-5
python-spake2 0.8-6
python-txtorcon 20.0.0-2
skypeforlinux-stable-bin 8.69.0.77-1
spectre-meltdown-checker 0.44-1
spotify 1:1.1.42.622-2
tor-browser 10.0.12-1
yay 10.1.2-2
zettlr-bin 1.8.7-1
zoom 5.5.2-1
zotero 5.0.96-1

Starting LibreOffice from the command line generates no error messages...

I get the same strange behaviour when typing aaa - bbb - ccc - ddd: only the last hyphen gets converted to a n-dash after hitting <enter>
When I select the full line and choose  Tools -> Autocorrect -> Apply, the other hyphens are converted to n-dashes and the very first a is capitalised.

Last edited by zilverling (2021-03-02 10:01:48)

Offline

#4 Yesterday 06:54:00

anark10n
Member
Registered: 2012-10-13
Posts: 171

Re: LibreOffice autocorrect works only after pressing Enter

Also have the same problem, autocorrect only works when pressing Return key, but not Spacebar. Hunspell installed correctly and everything. This started happening after an update to 7.1.0.3.

Offline

Board footer

Powered by FluxBB