You are not logged in.

#1 2021-02-22 09:13:57

SigmaR
Member
Registered: 2021-02-15
Posts: 9

[SOLVED] Ethernet not getting any internet

For the last two days, I cannot get any internet connection. I think I have a lead now, but I don't know where to go from there. Oh, and Arch is my first linux distribution, ever, so bare with me. (I dont know how to post logs and whatnot, either)

I initially had my system working just fine, the only work I really did regarding networking was using Network Manager, specifically "nmtui" hell, I didnt even have dhcpcd installed, and everything was working fine. I got around to installing steam, but it wouldnt connect to steam servers for some reason. I ended up doing something (???) that just made my internet not work entirely. I uninstalled steam thinking that would do something. Of course, surprising no one, it didnt. And neither did installing dhcpcd from a usb stick. [sudo pacman -U /mnt/packagenamefromofficialarchpackagespage] and attempted to set it up properly. Well, I set it up properly, but it didnt solve my issue.

I can ping 8.8.8.8 and my router, but not any site, nor use a web browser. I also booted up a bootable Manjaro linux usb, and ethernet worked out of the box, so my router is definitely not the issue.

From here, I suspected checking the logs would give me something useful. It didnt. However, [sudo systemctl status dhcpcd] and [sudo systemctl status NetworkManager] showed me two consistent errors though:

systemctl status dhcpcd: Orange text saying "enp24s0: no IPv6 Routers avaible"
systemctl status NetworkManager: Orange text saying "<warn> [1613981993.3693] ndisc[0x55f28c8ee840,"enp24s0"]: solicit: failure sending router solicitation: Cannot assign requested address (99)"

Both services are running, and when I edited /etc/dhcpcd.conf, I commented out "noipv4ll", rebooted, removed the comment, rebooted. Both times nothing had changed. I've disabled each, both together, and separately, not giving any different results.

Any tips?

Last edited by SigmaR (2021-02-24 07:51:20)

Offline

#2 2021-02-22 12:41:17

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,887

Re: [SOLVED] Ethernet not getting any internet

This sounds like you have a name resolution issue, but let's get some info first.


find /etc/systemd -type l -exec test -f {} \; -print | sort

Added :

since you don't have fully working internet on that system, append > systemd-services.txt .
copy systemd-services.txt to an usb drive, and post the content from a system with internet.

Last edited by Lone_Wolf (2021-02-22 12:44:21)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-02-22 13:28:25

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

Thanks for the reply, heres the command output:

[sg@iusearchbtw /]$ find /etc/systemd -type l -exec test -f {} \; -print | sort
/etc/systemd/system/dbus-org.freedesktop.nm-dispatcher.service
/etc/systemd/system/getty.target.wants/getty@tty1.service
/etc/systemd/system/multi-user.target.wants/dhcpcd.service
/etc/systemd/system/multi-user.target.wants/NetworkManager.service
/etc/systemd/system/multi-user.target.wants/remote-fs.target
/etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service
/etc/systemd/user/sockets.target.wants/dirmngr.socket
/etc/systemd/user/sockets.target.wants/gpg-agent-browser.socket
/etc/systemd/user/sockets.target.wants/gpg-agent-extra.socket
/etc/systemd/user/sockets.target.wants/gpg-agent.socket
/etc/systemd/user/sockets.target.wants/gpg-agent-ssh.socket
/etc/systemd/user/sockets.target.wants/p11-kit-server.socket
 

I actually have a live environment, so I assume just copy and pasting the contents onto a generic .txt file will deliver the same output, or is that incorrect?

Last edited by SigmaR (2021-02-22 13:29:16)

Offline

#4 2021-02-23 13:40:48

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

Heres some more logs I got, these two commands werent far apart time wise, only by about a second.

[sg@iusearchbtw ~]$ ping archlinux.org
ping: archlinux.org: Temporary failure in name resolution
[sg@iusearchbtw ~]$ journalctl -f
-- Journal begins at Fri 2021-02-19 23:01:38 EST. --
Feb 23 08:22:36 iusearchbtw systemd[1]: Finished Cleanup of Temporary Directories.
Feb 23 08:22:36 iusearchbtw audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 23 08:22:36 iusearchbtw audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 23 08:22:36 iusearchbtw kernel: audit: type=1130 audit(1614086556.990:70): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 23 08:22:36 iusearchbtw kernel: audit: type=1131 audit(1614086556.990:71): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 23 08:25:08 iusearchbtw kernel: [drm] perform_link_training_with_retries: Link training attempt 1 of 4 failed
Feb 23 08:25:08 iusearchbtw kernel: [drm] perform_link_training_with_retries: Link training attempt 2 of 4 failed
Feb 23 08:25:08 iusearchbtw kernel: [drm] perform_link_training_with_retries: Link training attempt 3 of 4 failed
Feb 23 08:25:08 iusearchbtw kernel: [drm] enabling link 1 failed: 15
Feb 23 08:25:23 iusearchbtw kernel: [drm] perform_link_training_with_retries: Link training attempt 1 of 4 failed

Offline

#5 2021-02-23 14:04:08

seth
Member
Registered: 2012-09-03
Posts: 18,808

Re: [SOLVED] Ethernet not getting any internet

/etc/systemd/system/multi-user.target.wants/dhcpcd.service
/etc/systemd/system/multi-user.target.wants/NetworkManager.service

Unless you keep the controlled NICs apart, those are conflicting services. Assuming you want to use NM, stao & disable dhcpcd.

Then restart NM and post the output of "cat /etc/resolv.conf"

Offline

#6 2021-02-23 14:07:10

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,887

Re: [SOLVED] Ethernet not getting any internet

drm link training has to do with graphics connections, but shouldn't occur in normal operation.

Is this a laptop that connects to internet / monitors through some kind of docking station ?



I actually have a live environment, so I assume just copy and pasting the contents onto a generic .txt file will deliver the same output, or is that incorrect?

yes, although c/p can't handle some things (f.e. loooong lines) that redirection can.

If there is a working internet connection using a pastebin client tends to be the easiest way to get something online.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#7 2021-02-23 16:30:25

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

seth wrote:

Then restart NM and post the output of "cat /etc/resolv.conf"

I've restarted NetworkManager, but I get an error when executing that command:

cat: /etc/resolv.conf: No such file or directory

Despite the directory and file showing up with tab auto complete, and even doing it with sudo. Whats even weirder is that in my text editor, it just says "New File"

Lone_Wolf wrote:

Is this a laptop that connects to internet / monitors through some kind of docking station ?

No, its a normal desktop using onboard ethernet.

Offline

#8 2021-02-23 16:32:06

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: [SOLVED] Ethernet not getting any internet

what does `file /etc/resolv.conf` show?

Offline

#9 2021-02-23 17:05:39

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

[sg@iusearchbtw ~]$ file /etc/resolv.conf 
/etc/resolv.conf: broken symbolic link to /run/systemd/resolve/stub-resolv.conf

Offline

#10 2021-02-23 17:12:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: [SOLVED] Ethernet not getting any internet

Why did you make that symlink?

Offline

#11 2021-02-23 17:57:17

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

I dont recall making anything like that? I would assume some program would, but its not like I would know of it. If I had to guess, it would be steam or whatnot, but I have that same file on my laptop with manjaro, its something generated by NetworkManager, with my routers gateway on it. And clearly, since Im posting this, I would assume this is what should also be on my desktop, right?

# Generated by NetworkManager
search my gateway
nameserver my ip adress

Offline

#12 2021-02-23 18:32:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: [SOLVED] Ethernet not getting any internet

That symlink is not made automatically by anything on Arch. It's specific to setting up systemd-resolved, and must be done manually.

Offline

#13 2021-02-23 18:45:03

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

Should I remove it? Sorry, I'm not too familiar with this part of arch, still trying to grasp it.

Offline

#14 2021-02-23 18:51:59

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: [SOLVED] Ethernet not getting any internet

If you're not using systemd-resolved, yes, it should be a text file instead of a symlink.

Offline

#15 2021-02-23 20:49:32

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

Is there any command to turn it into a text file directly, or do I just unlink it and then just create a new text file with that name?

Offline

#16 2021-02-23 20:53:38

seth
Member
Registered: 2012-09-03
Posts: 18,808

Re: [SOLVED] Ethernet not getting any internet

Just delete the file and restart NM. It'll create a text file with usable content for you.

Offline

#17 2021-02-24 07:51:04

SigmaR
Member
Registered: 2021-02-15
Posts: 9

Re: [SOLVED] Ethernet not getting any internet

For some reason it wouldnt come back after deleting and restarting NetworkManager, only after rebooting, but it would still be a symlink, but I guess it just started working after this. Thanks for the help Lone_Wolf, seth, and Scimmia. For future reference:

sudo rm /etc/resolv.conf
sudo systemctl restart NetworkManager

If it doesnt work initially, reboot, and do the commands again. This initially had me confused, but it should start working again after the first or second reboot.

Offline

#18 2021-02-24 07:54:02

seth
Member
Registered: 2012-09-03
Posts: 18,808

Re: [SOLVED] Ethernet not getting any internet

Only if you're somehow using resolved, for actual future reference: https://wiki.archlinux.org/index.php/Sy … figuration

Offline

Board footer

Powered by FluxBB