You are not logged in.

#1 2021-02-24 07:15:27

disconsented
Member
Registered: 2015-06-27
Posts: 4

USB sound card missing pulse audio profiles and no microphone input

I'd been waiting for 5.11 to roll around on hopes that my issue was https://bbs.archlinux.org/viewtopic.php?id=254097 but little has changed.


 pacmd list-source-outputs
0 source output(s) available.

~ via ? v3.9.1
❯ pacmd list-sources
6 source(s) available.
  * index: 0
	name: <alsa_input.hw_2>
	driver: <module-alsa-source.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 100.14 ms
	module: 5
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC1220 Analog"
		alsa.id = "ALC1220 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "2"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfe800000 irq 77"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:28:00.3"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:28:00.3/sound/card2"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "1457"
		device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.string = "hw:2"
		device.buffering.buffer_size = "17664"
		device.buffering.fragment_size = "2944"
		device.access_mode = "mmap"
		device.description = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.icon_name = "audio-input-microphone-pci"
    index: 1
	name: <alsa_output.usb-ASUS_Xonar_U7_MKII-00.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 1040
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	monitor_of: 0
	card: 1 <alsa_card.usb-ASUS_Xonar_U7_MKII-00>
	module: 8
	properties:
		device.description = "Monitor of Xonar U7 MKII Analog Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "Xonar U7 MKII"
		alsa.long_card_name = "ASUS Xonar U7 MKII at usb-0000:27:00.3-1, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:27:00.3-usb-0:1:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:07.1/0000:27:00.3/usb3/3-1/3-1:1.0/sound/card0"
		udev.id = "usb-ASUS_Xonar_U7_MKII-00"
		device.bus = "usb"
		device.vendor.id = "0b05"
		device.vendor.name = "ASUSTek Computer, Inc."
		device.product.id = "183f"
		device.product.name = "Xonar U7 MKII"
		device.serial = "ASUS_Xonar_U7_MKII"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
    index: 2
	name: <compressor.monitor>
	driver: <module-ladspa-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 1000
	volume: front-left: 65115 /  99% / -0.17 dB,   front-right: 65115 /  99% / -0.17 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	monitor_of: 1
	module: 24
	properties:
		device.description = "Monitor of LADSPA Plugin SC4 mono on Xonar U7 MKII Analog Stereo"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
    index: 3
	name: <alsa_output.hw_0_2.monitor>
	driver: <module-alsa-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 1000
	volume: front-left: 65533 / 100% / -0.00 dB,   front-right: 65533 / 100% / -0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	monitor_of: 2
	module: 25
	properties:
		device.description = "Monitor of Xonar U7 MKII"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
    index: 4
	name: <alsa_output.hw_2_0.monitor>
	driver: <module-alsa-sink.c>
	flags: DECIBEL_VOLUME LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 100.14 ms
	monitor_of: 3
	module: 26
	properties:
		device.description = "Monitor of Family 17h (Models 00h-0fh) HD Audio Controller"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
    index: 5
	name: <alsa_input.hw_2_2>
	driver: <module-alsa-source.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9030
	volume: front-left: 65533 / 100% / -0.00 dB,   front-right: 65533 / 100% / -0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 100.14 ms
	module: 33
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC1220 Alt Analog"
		alsa.id = "ALC1220 Alt Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "2"
		alsa.card = "2"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfe800000 irq 77"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:28:00.3"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:28:00.3/sound/card2"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "1457"
		device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.string = "hw:2,2"
		device.buffering.buffer_size = "17664"
		device.buffering.fragment_size = "2944"
		device.access_mode = "mmap"
		device.description = "Family 17h (Models 00h-0fh) HD Audio Controller"
		device.icon_name = "audio-input-microphone-pci"
❯ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: MKII [Xonar U7 MKII], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Generic [HD-Audio Generic], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Generic [HD-Audio Generic], device 2: ALC1220 Alt Analog [ALC1220 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So the device shows up in arecord fine, but there are no microphone options in pavucontrol.

With pulse audio reporting:

D: [pulseaudio] alsa-util.c: Trying hw:0,0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0,0: No such file or directory
E: [pulseaudio] module.c: Failed to load module "module-alsa-source" (argument: "device=hw:0,0"): initialization failed.

I have needed to load in my sinks for this card manually as well

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <[url]http://www.gnu.org/licenses/[/url]>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

# xonar mic manual fix
load-module module-alsa-source device=hw:2

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

#https://github.com/gotbletu/shownotes/blob/master/pulseaudio-dynamic-range-compression.md
.ifexists module-ladspa-sink.so
.nofail
load-module module-ladspa-sink sink_name=compressor plugin=sc4m_1916 label=sc4m control=1,1.5,401,-30,20,5,12
.fail
.endif

#manual xonar fix
load-module module-alsa-sink device=hw:0,2
load-module module-alsa-sink device=hw:2,0
load-module module-alsa-sink device=hw:0,0
load-module module-alsa-sink device=hw:2,2
load-module module-alsa-sink device=hw:1,0

load-module module-alsa-source device=hw:0,2
load-module module-alsa-source device=hw:2,0
load-module module-alsa-source device=hw:0,0
load-module module-alsa-source device=hw:2,2
load-module module-alsa-source device=hw:1,0

#load-module module-alsa-source device=hw:2,0
# the line above should be somewhere before the line below
#.ifexists module-udev-detect.so

It used to work but I am stumpped as to what is stuck, any ideas?

Last edited by disconsented (2021-02-24 08:13:13)

Offline

#2 2021-02-24 08:10:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,698

Re: USB sound card missing pulse audio profiles and no microphone input

Please use [ code ]  rather than [ quote ] for sharing file contents.

These manual loading attempts just read random to me are you absolutely certain you need them in the way you are adding them? I suggest you remove all of these and then look at the udev detected state first. Also we make a jump from card 0 to card 2, is this intentional? Do you have modprobe config files? Post them if so.

Can you record via

arecord -Dhw:0 test.wav

Maybe also post

pacmd list-cards

Last edited by V1del (2021-02-24 08:12:51)

Online

#3 2021-02-24 08:20:13

disconsented
Member
Registered: 2015-06-27
Posts: 4

Re: USB sound card missing pulse audio profiles and no microphone input

Swapped out those quotes in the op.

I know it is silly however they're necessary for audio to consistently work removing all of them I get no audio.

Device 2 is an attempt at throwing things at a wall and seeing what sticks.

❯ pacmd list-cards
2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_26_00.1>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "1"
		alsa.card_name = "HDA ATI HDMI"
		alsa.long_card_name = "HDA ATI HDMI at 0xfe960000 irq 75"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:26:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1002"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
		device.product.id = "aac8"
		device.product.name = "Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]"
		device.string = "1"
		device.description = "Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: unknown)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
		output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: no)
		output:hdmi-surround-extra5: Digital Surround 5.1 (HDMI 6) Output (priority 600, available: no)
		output:hdmi-surround71-extra5: Digital Surround 7.1 (HDMI 6) Output (priority 600, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.usb-ASUS_Xonar_U7_MKII-00>
	driver: <module-alsa-card.c>
	owner module: 8
	properties:
		alsa.card = "0"
		alsa.card_name = "Xonar U7 MKII"
		alsa.long_card_name = "ASUS Xonar U7 MKII at usb-0000:27:00.3-1, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:27:00.3-usb-0:1:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:07.1/0000:27:00.3/usb3/3-1/3-1:1.0/sound/card0"
		udev.id = "usb-ASUS_Xonar_U7_MKII-00"
		device.bus = "usb"
		device.vendor.id = "0b05"
		device.vendor.name = "ASUSTek Computer, Inc."
		device.product.id = "183f"
		device.product.name = "Xonar U7 MKII"
		device.serial = "ASUS_Xonar_U7_MKII"
		device.string = "0"
		device.description = "Xonar U7 MKII"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	profiles:
		output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
		output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.usb-ASUS_Xonar_U7_MKII-00.analog-stereo/#0: Xonar U7 MKII Analog Stereo
	sources:
		alsa_output.usb-ASUS_Xonar_U7_MKII-00.analog-stereo.monitor/#1: Monitor of Xonar U7 MKII Analog Stereo
	ports:
		analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
			properties:
				
		iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
❯ cat /etc/modprobe.d/alsa-base.conf
───────┬───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       │ File: /etc/modprobe.d/alsa-base.conf
───────┼───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   │ options snd-usb-audio ignore_ctl_error=1
───────┴───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
❯ arecord -Dhw:0 file_example_WAV_10MG.wav
arecord: main:830: audio open error: No such file or directory

At the moment loading in just device 0,2 allows for audio out

Last edited by disconsented (2021-02-24 08:30:06)

Offline

#4 2021-04-12 00:08:55

disconsented
Member
Registered: 2015-06-27
Posts: 4

Re: USB sound card missing pulse audio profiles and no microphone input

So uh, I may be an idiot. The sound card features a dipswitch for moving between USB-1 and USB-2 mode, flick it to USB-2 and it.. works...

Offline

Board footer

Powered by FluxBB