You are not logged in.

#1 2021-06-02 10:58:05

mergin
Member
Registered: 2021-06-02
Posts: 2

libalpm error

hello everyone.
i tried to launch pamac and it didnt work. so i tried to check on terminal with whats going on. so i checked and there was a problem with libalpm
so i removed pamac and tried to re-install but problems still exist. i removed almost everything package-query, pamac, and other neccessary dependencies.
but now i cant even install that and now whenever i try to install anything, i face same problem.
here is a output when i try to install one of the gui for pacman.

Edit: Im new in this forum. i fixed code tags. thanks for suggestions

➜  alpm_octopi_utils git:(master) ✗ makepkg PKGBUILD
ls
==> Making package: alpm_octopi_utils 1.0.2-2 (Wed 02 Jun 2021 01:53:21 PM EEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found 2bb9349507f8155155c9b5f12b1f30e60e157d30.tar.gz
==> Validating source files with sha256sums...
    2bb9349507f8155155c9b5f12b1f30e60e157d30.tar.gz ... Passed
==> Extracting sources...
  -> Extracting 2bb9349507f8155155c9b5f12b1f30e60e157d30.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
sed -e 's|@libdir@|/usr/lib|g' \
	-e 's|@includedir@|/usr/include|g' \
	<src/libalpm_octopi_utils.pc.in >src/libalpm_octopi_utils.pc
cd src && make
make[1]: Entering directory '/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src'
valac	-o libalpm_octopi_utils.so \
		-X -fPIC \
		-X --shared \
		-H alpm_octopi_utils.h \
		--vapi=alpm_octopi_utils.vapi \
		--library=libalpm_octopi_utils \
		--save-temps -X -w --pkg=libalpm --pkg=gio-2.0 --pkg=posix --vapidir=../vapi -X -D_FILE_OFFSET_BITS=64 \
		alpm_config.vala alpm_octopi_utils.vala
/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c: In function ‘alpm_utils_search_all_dbs’:
/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:270:18: error: too few arguments to function ‘alpm_db_search’
  270 |         _tmp8_ = alpm_db_search (_tmp6_, _tmp7_);
      |                  ^~~~~~~~~~~~~~
In file included from /home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:24:
/usr/include/alpm.h:1413:5: note: declared here
 1413 | int alpm_db_search(alpm_db_t *db, const alpm_list_t *needles,
      |     ^~~~~~~~~~~~~~
/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:298:35: error: too few arguments to function ‘alpm_db_search’
  298 |                         _tmp18_ = alpm_db_search (_tmp16_, _tmp17_);
      |                                   ^~~~~~~~~~~~~~
In file included from /home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:24:
/usr/include/alpm.h:1413:5: note: declared here
 1413 | int alpm_db_search(alpm_db_t *db, const alpm_list_t *needles,
      |     ^~~~~~~~~~~~~~
/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:307:35: error: too few arguments to function ‘alpm_db_search’
  307 |                         _tmp21_ = alpm_db_search (_tmp19_, _tmp20_);
      |                                   ^~~~~~~~~~~~~~
In file included from /home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src/alpm_octopi_utils.c:24:
/usr/include/alpm.h:1413:5: note: declared here
 1413 | int alpm_db_search(alpm_db_t *db, const alpm_list_t *needles,
      |     ^~~~~~~~~~~~~~
error: cc exited with status 256
Compilation failed: 1 error(s), 0 warning(s)
make[1]: *** [Makefile:18: libalpm_octopi_utils.so] Error 1
make[1]: Leaving directory '/home/osman/git/octopi/alpm_octopi_utils/src/alpm_octopi_utils-2bb9349507f8155155c9b5f12b1f30e60e157d30/src'
make: *** [Makefile:11: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
 

also output of pacman

➜  alpm_octopi_utils git:(master) ✗ pacman --version

 .--.                  Pacman v6.0.0 - libalpm v13.0.0
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2021 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

➜  alpm_octopi_utils git:(master) ✗ 

Last edited by mergin (2021-06-02 18:34:24)

Offline

#2 2021-06-02 11:00:31

loqs
Member
Registered: 2014-03-06
Posts: 13,467

Re: libalpm error

https://aur.archlinux.org/packages/octo … ent-810609 for octopi
Edit:
https://bbs.archlinux.org/viewtopic.php?id=266821 for pamac

Last edited by loqs (2021-06-02 11:01:27)

Offline

#3 2021-06-02 11:54:30

mergin
Member
Registered: 2021-06-02
Posts: 2

Re: libalpm error

problem is if a program sue libalpm it wont be installed. i read tons of forums and answers. there is no correct answer yet

Offline

#4 2021-06-02 13:35:13

a821
Member
Registered: 2012-10-31
Posts: 260

Re: libalpm error

The correct answer is to wait till those programs that depend on libalpm get updated/fixed. If you do not want to wait, you either fix them yourself (and report the fixes upstream) or uninstall them (and reinstall them later). Remember that those programs are unofficial/unsupported

Offline

#5 2021-06-02 13:40:41

seth
Member
Registered: 2012-09-03
Posts: 21,313

Re: libalpm error

The correct answer is that a couple of aur helpers/pacman wrappers is incompatible w/ the recvent libalpm update and need a patches.
In the meantime, use pacman and makepkg.
There's nothing else you can do about this situation  (except the questionable approach to downgrade and stall archlinux as suggested in the thread loqs linked)

Online

#6 2021-06-02 15:23:56

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,337
Website

Re: libalpm error

Please use code tags for terminal output.

https://gitlab.archlinux.org/archlinux/ … s-and-code

Mod note: Moving to AUR Issues

Last edited by WorMzy (2021-06-02 15:28:51)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

Board footer

Powered by FluxBB