You are not logged in.

#1 2021-06-02 15:23:55

diosama
Member
Registered: 2021-06-02
Posts: 3

Corrupted and missplaced texts in KDE applications

The problem is mostly noted when I'm hovering with the cursor over long listed plasma application menus and panes, or scrolling the scrollbar, like the application launch widget, or system settings, which have many listed entries on them.
The text get 'missrendered' like the picture below:
https://imgur.com/wOOnxri/

I always noticed it happening on the desktop panel when the cursor is idle for some minutes, some other times the texts from the panel just 'vanishes':
https://imgur.com/DpJ7MWX/

and in applications that refreshes text periodically, like sysmonitor:
https://imgur.com/SIL9Iej/

Interestingly, it does not occur in sysguard application. Neither in any other application that are not KDE'S (like long listed folders in dolphin). The text gets correctly rendered and placed when the cursor or scrollbar gets idle for some seconds  (2-3). I've verified ksyslog, nothing there. I have tried many configuration settings for fonts(dpi and anti-antialising settings), compositor and desktop effects, I've tried to install and reinstall both AMD drivers, xorg, qt and plasma.  Actually, it started some weeks ago, I decided to make a fresh installation of Arch+KDE, for other reasons, and thought that this problem would go with it, it didn't. I currently have ttf-dejavu and ttf-liberation installed. The problem occurred again as soon as launched plasma after the fresh installation. I have a MSI R7 360 graphic card, and it is working very well. I have a secondary monitor, and it exhibits the same glitch.
Output of xrandr -q:

 Screen 0: minimum 320 x 200, current 2688 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+768+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x960      60.00  
   1360x768      60.02  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DVI-0 connected 768x1024+0+0 right (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  

I really searched for anything that could be related, it looks like a text rendering problem with kapplicatitons (qt maybe?) but I'm out of clues, I really would like to give you  more information, but I really don't know what could be helpful, if somebody could give me ANY directions to correct this, I really like KDE, but this is not just a minor inconvenience, it really interferes with my experience with KDE environment.
Versions from KDE system settings info:
Operating System: Arch Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.12.9-arch1-1
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 11.7 GiB of RAM
Graphics Processor: AMD Bonaire Series
Thanks in advance.

Last edited by diosama (2021-06-07 20:56:43)

Offline

#2 2021-06-05 20:47:45

KirkyD
Member
Registered: 2015-02-21
Posts: 5

Re: Corrupted and missplaced texts in KDE applications

I'm experiencing the same type of stuff with my panel. If I mouse over the 'blurred' text it gets redrawn and clears up, but comes back if I launch a new app for instance. closing an app clears it back up???

I've tried creating a new user and logging in to that account and get the same results, so doesn't seem to be a user config issue.

here's a couple of pics
Desktop snaps

here's my xrandr -q output:

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
DVI-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1600x1200     60.00 
   1680x1050     59.88 
   1280x1024     75.02 
   1440x900      59.90 
   1280x960      60.00 
   1152x864      75.00 
   1280x720      60.00 
   1024x768      75.03    60.00 
   832x624       74.55 
   800x600       75.00    60.32 
   640x480       75.00    59.94 
   720x400       70.08

here's some more info:
qdbus org.kde.KWin /KWin org.kde.KWin.supportInformation

looks like someone else with the same issue:
forum post

Last edited by KirkyD (2021-06-05 21:12:01)

Offline

#3 2021-06-07 20:56:30

diosama
Member
Registered: 2021-06-02
Posts: 3

Re: Corrupted and missplaced texts in KDE applications

Yes, closing an app do clears it back up, actually any mouse click does it, or simply hovering the corrupted text and also:
-The fonts do not get corrupted in the application launcher and panels (but remains in other kde applications like system settings) when I start the plasma session with wayland. I tried using xf86-input-evdev because it was similar to this bug: https://bugs.kde.org/show_bug.cgi?id=358472, but it didn't change anything.
- The issue does not seem to be within KWin, as I started a session using openbox as WM and the problem remained

Last edited by diosama (2021-06-07 20:57:01)

Offline

#4 2021-06-08 06:44:59

MasterGeek.MX
Member
From: Mexico City, America, Earth.
Registered: 2019-09-16
Posts: 25

Re: Corrupted and missplaced texts in KDE applications

Same here, but the problem creeps out to OpenGL apps and games like Team Fortress 2. Have a look: https://imgur.com/I9vvWtH.mp4

For the record, I have a Radon R7 360 with amdgpu driver instead of radeon.

I managed to postergate the issue by reverting mesa (and lib32-mesa) to version 21.0.3-3, but I cannot longer do that because doing that breaks other stuff (steam and VLC won't launch for example).

Revisiting upstream I found a thread for solving it, but I lack the technical expertise to help further: https://gitlab.freedesktop.org/mesa/mesa/-/issues/4764


I don't need to say BTW I use Arch, just BTW I use GNU/Linux, because everyone here are windows heads.

Offline

#5 Today 19:04:43

diosama
Member
Registered: 2021-06-02
Posts: 3

Re: Corrupted and missplaced texts in KDE applications

Nice, I couldn't revert it without messing with kde applications, but thanks a lot, at least I  know now where the problem resides, hopefully it gets fixed in the next mesa update...

Offline

Board footer

Powered by FluxBB