You are not logged in.

#1 2021-08-26 00:54:23

Registered: 2018-09-30
Posts: 88

[SOLVED] Anbox "anbox0" bridged device - how to unblock from UFW?

I can't for the life of me figure out how to get networking in anbox to work without shutting down ufw. I'm unsure of what rule to set to just allow the bridged network device to work.

I'm using the systemd-networkd solution to make the network actually bridge, listed here: … d-networkd

No matter what I try to allow in ufw, I keep getting errors like this in dmesg:

[  803.551000] [UFW BLOCK] IN=anbox0 OUT=wlan0 MAC=2a:5a:13:8e:fa:86:ca:c8:3c:e9:38:c3:08:00 SRC= DST= LEN=75 TOS=0x00 PREC=0x00 TTL=63 ID=24980 DF PROTO=UDP SPT=61778 DPT=53 LEN=55 

Any ideas?

** EDIT **

Solved. Note that in this case the bridged (SRC here) is the pseudo network device with an IP address of What I did was add the following stanza to /etc/ufw/before.rules:

# allow anbox

Note that I placed this stanza directly above the "COMMIT" line. Hopefully this can help some other people with similar issues.

Last edited by cloverskull (2021-08-26 01:15:19)


#2 2021-11-25 05:17:58

From: Birckala, Finland
Registered: 2019-09-16
Posts: 17

Re: [SOLVED] Anbox "anbox0" bridged device - how to unblock from UFW?

Thanks for the perfect solution, I had just been wrestling with the same issue for the last few days big_smile

This should definitely be added to the Arch anbox wiki. I might even do it myself if I can figure out how to edit the wiki...


Board footer

Powered by FluxBB