You are not logged in.

#1 2021-08-24 20:39:19

jamdox
Member
Registered: 2015-05-02
Posts: 46

HDMI audio sped up, AMD RX580/Gnome

This seems to be an existing problem.  At "4k@60hz" resolution, attempting to output audio over HDMI leads to multimedia playback at what appears to be double speed.  Audio coming from the motherboard via SPDIF is fine.  Any help appreciated.

Offline

#2 2021-08-25 04:33:52

jamdox
Member
Registered: 2015-05-02
Posts: 46

Re: HDMI audio sped up, AMD RX580/Gnome

I moved from pulseaudio to pipewire/pipewire-pulse.  Now HDMI prevents media from playing and causes firefox to crash.

Offline

#3 2021-08-25 21:10:13

jamdox
Member
Registered: 2015-05-02
Posts: 46

Re: HDMI audio sped up, AMD RX580/Gnome

Updating makes it so it just doesn't output over HDMI, even when visible and selected.  Is this a video card question?

Offline

#4 2021-09-13 03:12:09

jamdox
Member
Registered: 2015-05-02
Posts: 46

Re: HDMI audio sped up, AMD RX580/Gnome

I did a full reinstall.  For the record, I also have an NVIDIA 1060 in my second PCIe slot for compute using the proprietary drivers.  When booting without early KMS, Gnome forces X rather than Wayland and gives my 580 a max refresh rate of 30Hz on my 60Hz screen, but the HDMI audio plays at the correct speed.  Enabling early KMS for AMD (amdgpu) allows the normal 60Hz refresh rate but HDMI audio is sped up again.

Offline

#5 2021-09-13 08:04:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,057

Re: HDMI audio sped up, AMD RX580/Gnome

You probably want to report this with as many details as you can gather in: https://gitlab.freedesktop.org/drm/amd/-/issues

Have you  tried the LTS kernel? Can you reduce the rate manually and does that fix it?

Offline

Board footer

Powered by FluxBB