You are not logged in.

#1 2021-09-23 10:03:11

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

[SOLVED] Unstable Wi-Fi connection

My Wi-Fi keeps disconnecting & reconnecting and I have no idea why. I thought that the issue was caused by power management as it's written in the wiki. My previous topic here, I will duplicate some information from it for convenience.

After I created the udev rule:

$ cat /etc/udev/rules.d/81-wifi-powersave.rules
ACTION=="add", SUBSYSTEM=="net", KERNEL=="wl*", RUN+="/usr/bin/iw dev $name set power_save off"

And set these options:

$ cat /etc/modprobe.d/iwlwifi.conf
options iwlwifi power_save=0
options iwlmvm power_scheme=1

It still sometimes disconnects and reconnects again leading to VPN (forticlient) connection drop. I still need to remove /run/wpa_supplicant manually, then set down the interface after reboot.

$ iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"Dungeon Router 2.4GHz"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: F0:2F:74:38:D0:28   
          Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-31 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:30   Missed beacon:0

docker0   no wireless extensions.

vethee3a57e  no wireless extensions.
$ lspci -knn | grep -A2 Network
02:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
	Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:0010]
	Kernel driver in use: iwlwifi

Full here.

$ journalctl -u netctl@DungeonRouter.service
. . .
-- Boot 90b2ffdc05de42a08385139417e8d846 --
Sep 23 11:48:12 arch systemd[1]: Starting The Wi-Fi at the Dungeon...
Sep 23 11:48:12 arch network[364]: Starting network profile 'DungeonRouter'...
Sep 23 11:48:12 arch network[375]: Failed to initialize control interface '/run/wpa_supplicant'.
Sep 23 11:48:12 arch network[375]: You may have another wpa_supplicant process already running or the file was
Sep 23 11:48:12 arch network[375]: left by an unclean termination of wpa_supplicant in which case you will need
Sep 23 11:48:12 arch network[375]: to manually remove this file before starting wpa_supplicant again.
Sep 23 11:48:13 arch network[364]: The WPA supplicant did not start for interface 'wlan0'
Sep 23 11:48:13 arch network[364]: Failed to bring the network up for profile 'DungeonRouter'
Sep 23 11:48:13 arch systemd[1]: netctl@DungeonRouter.service: Main process exited, code=exited, status=1/FAILURE
Sep 23 11:48:13 arch systemd[1]: netctl@DungeonRouter.service: Failed with result 'exit-code'.
Sep 23 11:48:13 arch systemd[1]: Failed to start The Wi-Fi at the Dungeon.
Sep 23 11:49:39 arch systemd[1]: Starting The Wi-Fi at the Dungeon...
Sep 23 11:49:39 arch network[2005]: Starting network profile 'DungeonRouter'...
Sep 23 11:49:39 arch network[2014]: nl80211: Could not set interface 'p2p-dev-wlan0' UP
Sep 23 11:49:39 arch network[2014]: p2p-dev-wlan0: Failed to initialize driver interface
Sep 23 11:49:39 arch systemd[1]: Started The Wi-Fi at the Dungeon.
Sep 23 11:49:43 arch dhcpcd[2154]: dhcpcd-9.4.0 starting
Sep 23 11:49:43 arch dhcpcd[2157]: DUID 00:04:b2:2e:00:47:b8:35:75:43:b3:f5:ba:f7:47:49:c8:a0
Sep 23 11:49:43 arch dhcpcd[2157]: wlan0: connected to Access Point: Dungeon Router 5GHz
. . .

Last edited by mydeadvictoria (2021-09-28 11:48:23)

Offline

#2 2021-09-23 14:14:02

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

Sep 23 11:48:12 arch network[375]: You may have another wpa_supplicant process already running or the file was
Sep 23 11:48:12 arch network[375]: left by an unclean termination of wpa_supplicant in which case you will need
Sep 23 11:48:12 arch network[375]: to manually remove this file before starting wpa_supplicant again.

https://bbs.archlinux.org/viewtopic.php … 9#p1992709

Online

#3 2021-09-23 14:24:00

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

bluetooth.service                        | bluetooth.target.wants
dbus-org.bluez.service                   | system
dbus-org.freedesktop.resolve1.service    | system
dbus-org.freedesktop.timesync1.service   | system
dirmngr.socket                           | sockets.target.wants
display-manager.service                  | system
docker.service                           | multi-user.target.wants
getty@tty1.service                       | getty.target.wants
gpg-agent-browser.socket                 | sockets.target.wants
gpg-agent-extra.socket                   | sockets.target.wants
gpg-agent.socket                         | sockets.target.wants
gpg-agent-ssh.socket                     | sockets.target.wants
netctl@DungeonRouter.service             | multi-user.target.wants
netctl@wlan0\x2dDungeon\x20Router\x205GHz.service | multi-user.target.wants
ntpd.service                             | multi-user.target.wants
p11-kit-server.socket                    | sockets.target.wants
pipewire.socket                          | sockets.target.wants
pulseaudio.socket                        | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
systemd-resolved.service                 | multi-user.target.wants
systemd-timesyncd.service                | sysinit.target.wants

Offline

#4 2021-09-23 14:28:29

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

netctl@DungeonRouter.service             | multi-user.target.wants
netctl@wlan0\x2dDungeon\x20Router\x205GHz.service | multi-user.target.wants

Do those operate on the same NIC? (guess so…)
Is there a purpose or do you have duplicates by accident?
Did you mean to use netctl-auto?

Online

#5 2021-09-23 15:18:28

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

seth wrote:
netctl@DungeonRouter.service             | multi-user.target.wants
netctl@wlan0\x2dDungeon\x20Router\x205GHz.service | multi-user.target.wants

Do those operate on the same NIC? (guess so…)
Is there a purpose or do you have duplicates by accident?

Yes. I have duplicates because my router exposes two AP (or whatever it's called) - 5GHz and 2.4GHz. So usually I use the 5Ghz one, but I tested 2.4Ghz to see if it also disconnects & reconnects (it does). 2.4GHz netctl profile is disabled

seth wrote:

Did you mean to use netctl-auto?

I guess no. Doesn't even know what it is

Offline

#6 2021-09-23 15:29:45

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

2.4GHz netctl profile is disabled

Then why are there two services enabled?

Doesn't even know what it is

https://wiki.archlinux.org/title/Netctl#Wireless
"Use 5GHz while I'm in range, then resort to 2.4GHz" (or other known networks in range)

Online

#7 2021-09-23 17:07:29

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

seth wrote:

Then why are there two services enabled?

Even if I disable it, it still shows up through your command.

rsY8izs.png

Offline

#8 2021-09-23 19:31:18

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

Please replace the oversized image w/ a link and actually don't post images of text, but post the text.

You disabled some …2.4GHz.service but the active ones are a more generic "netctl@DungeonRouter.service" and "netctl@wlan0\x2dDungeon\x20Router\x205GHz.service"

Online

#9 2021-09-24 06:52:59

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

seth wrote:

You disabled some …2.4GHz.service but the active ones are a more generic "netctl@DungeonRouter.service" and "netctl@wlan0\x2dDungeon\x20Router\x205GHz.service"

~ » netctl list                                                                                                                                                                                                                 helveticau@arch
* DungeonRouter
  wlan0-Dungeon Router 2.4GHz
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
~ » sudo systemctl status netctl@wlan0\x2dDungeon\x20Router\x205GHz.service                                                                                                                                                     helveticau@arch
[sudo] password for helveticau: 
○ netctl@wlan0x2dDungeonx20Routerx205GHz.service - Networking for netctl profile wlan0x2dDungeonx20Routerx205GHz
     Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static)
     Active: inactive (dead)
       Docs: man:netctl.profile(5)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
~ » sudo systemctl disable netctl@wlan0\x2dDungeon\x20Router\x205GHz.service                                                                                                                                                3 ↵ helveticau@arch
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
~ » find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f                                                                                                  helveticau@arch
bluetooth.service                        | bluetooth.target.wants
dbus-org.bluez.service                   | system
dbus-org.freedesktop.resolve1.service    | system
dbus-org.freedesktop.timesync1.service   | system
dirmngr.socket                           | sockets.target.wants
display-manager.service                  | system
docker.service                           | multi-user.target.wants
getty@tty1.service                       | getty.target.wants
gpg-agent-browser.socket                 | sockets.target.wants
gpg-agent-extra.socket                   | sockets.target.wants
gpg-agent.socket                         | sockets.target.wants
gpg-agent-ssh.socket                     | sockets.target.wants
netctl@DungeonRouter.service             | multi-user.target.wants
netctl@wlan0\x2dDungeon\x20Router\x205GHz.service | multi-user.target.wants
ntpd.service                             | multi-user.target.wants
p11-kit-server.socket                    | sockets.target.wants
pipewire.socket                          | sockets.target.wants
pulseaudio.socket                        | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
systemd-resolved.service                 | multi-user.target.wants
systemd-timesyncd.service                | sysinit.target.wants
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
~ »  

Offline

#10 2021-09-24 07:01:31

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

Check the directory, there's likely some  /etc/systemd/system/multi-user.target.wants/netctl@wlan0\x2dDungeon\x20Router\x205GHz.service that does NOT link /dev/null
Get rid of that (well, first check what it is, what it links and what the contents are…)
Reboot.

Online

#11 2021-09-24 07:20:13

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

seth wrote:

Check the directory, there's likely some  /etc/systemd/system/multi-user.target.wants/netctl@wlan0\x2dDungeon\x20Router\x205GHz.service that does NOT link /dev/null
Get rid of that (well, first check what it is, what it links and what the contents are…)
Reboot.

$ ls -la /etc/systemd/system/multi-user.target.wants/netctl@wlan0\\x2dDungeon\\x20Router\\x205GHz.service
lrwxrwxrwx 1 root root 39 May 18 13:37 '/etc/systemd/system/multi-user.target.wants/netctl@wlan0\x2dDungeon\x20Router\x205GHz.service' -> /usr/lib/systemd/system/netctl@.service

Offline

#12 2021-09-24 07:21:57

mydeadvictoria
Member
Registered: 2021-09-13
Posts: 9

Re: [SOLVED] Unstable Wi-Fi connection

$ cat /usr/lib/systemd/system/netctl@.service
[Unit]
Description=Networking for netctl profile %I
Documentation=man:netctl.profile(5)
After=network-pre.target
Before=network.target netctl.service
Wants=network.target

[Service]
Type=notify
NotifyAccess=exec
RemainAfterExit=yes
ExecStart=/usr/lib/netctl/network start %I
ExecStop=/usr/lib/netctl/network stop %I

Offline

#13 2021-09-24 07:31:35

seth
Member
Registered: 2012-09-03
Posts: 23,978

Re: [SOLVED] Unstable Wi-Fi connection

seth wrote:

Get rid of that
Reboot.

Online

Board footer

Powered by FluxBB