You are not logged in.

#1 2021-09-27 14:57:25

knille
Member
Registered: 2014-02-24
Posts: 22

[Solved] mariadb 10.6.4-1 config directory /etc/my.cnf.d/ ignored

hi everybody,

on my system i use the regular arch mariadb package and i have the issue that config files from directory /etc/my.cnf.d/ are not recognized by mariadbd. however the package contains

etc/my.cnf.d/client.cnf
etc/my.cnf.d/enable_encryption.preset
etc/my.cnf.d/mysql-clients.cnf
etc/my.cnf.d/s3.cnf
etc/my.cnf.d/server.cnf
etc/my.cnf.d/spider.cnf

and the arch wiki says the directory should be included: https://wiki.archlinux.org/title/MariaD … tion_files

is this a package issue or is it just a problem of my system?
you can check the config files in use by doing:

user@device:~$ mysqld --help --verbose | less
mysqld  Ver 10.6.4-MariaDB-log for Linux on x86_64 (Arch Linux)
Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Starts the MariaDB database server.

Usage: mysqld [OPTIONS]

Default options are read from the following files in the given order:
/etc/my.cnf ~/.my.cnf
The following groups ...

Last edited by knille (2021-10-15 11:07:55)

Offline

#2 2021-10-12 14:55:52

knille
Member
Registered: 2014-02-24
Posts: 22

Re: [Solved] mariadb 10.6.4-1 config directory /etc/my.cnf.d/ ignored

i filed a bug report about the issue:

https://bugs.archlinux.org/task/72405?p … ng=mariadb

Offline

#3 2021-10-12 19:05:52

loqs
Member
Registered: 2014-03-06
Posts: 13,968

Re: [Solved] mariadb 10.6.4-1 config directory /etc/my.cnf.d/ ignored

Adding the following to the server category of /etc/my.cnf.d/server.cnf

wait-timeout=14400

wait-timeout is changed from its default of 28000 to 14400 as produced by `mariadbd --help --verbose`

What changes have you tested that did not work?  What is the contents of /etc/my.cnf ?

Offline

#4 2021-10-15 11:06:56

knille
Member
Registered: 2014-02-24
Posts: 22

Re: [Solved] mariadb 10.6.4-1 config directory /etc/my.cnf.d/ ignored

ok, thanks to Christian Hesse (eworm) i was able to identify the problem. by default the config file /etc/my.cnf of arch only contains

[client-server]
!includedir /etc/my.cnf.d

and all the configuration is done is separate files in /etc/my.cnf.d/. but on my system all configuration was in /etc/my.cnf and the includedir command from above was missing.

Offline

Board footer

Powered by FluxBB