You are not logged in.

#1 2021-11-17 10:53:27

ebanashka
Member
Registered: 2021-11-17
Posts: 3

[resolved] No internet on wifi, Dell XPS 9370, QCA6174

Hi

After a system upgrade with `yay` internet stopped working.

I can connect to any wifi network but it won't ping the gateway. Shows 100% packet loss with no errors.

Here's the ip addr output:

2: wlp2s0: ‹BROADCAST,MULTICAST, UP, LOWER_UP> mtu 1500 qdise noqueue state UP group default qlen 1000
link/ether 9c:b6:do:90:ab:7b brd ff:ff:ff:ff:ff:ff
inet 192.168.0.72/24 br 192.168.0.255 scope global dynamic noprefixroute wlp2s®
valid_lft 604088sec preferred_lft 604088sec
inet6 2a02:8109:8880:118c:9eb6:dOff: fe90: ab7b/64 scope global dynamic mngtmpaddr
valid_lft 85693sec preferred_lft 42493sec
inet6 fe80::9eb6: doff: fe90:ab7b/64 scope link noprefixroute
valid_lft forever preferred_lft forever


I've tried to downgrade the linux firmware package to no avail. I am dualbooting with Windows and everything is working there.

Thanks

Last edited by ebanashka (2021-11-17 16:24:34)

Offline

#2 2021-11-17 12:48:42

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: [resolved] No internet on wifi, Dell XPS 9370, QCA6174

Check dmesg for errors.
Also, how do you manage the network? NM scanning around and altering the MAC on the run is a frequent source of trouble, https://wiki.archlinux.org/title/Networ … domization
In doubt, please post the entire system journal.

dualbooting with Windows and

ceterum censeo: 3rd link below.

Offline

#3 2021-11-17 13:44:38

ebanashka
Member
Registered: 2021-11-17
Posts: 3

Re: [resolved] No internet on wifi, Dell XPS 9370, QCA6174

seth wrote:

Check dmesg for errors.
Also, how do you manage the network? NM scanning around and altering the MAC on the run is a frequent source of trouble, https://wiki.archlinux.org/title/Networ … domization
In doubt, please post the entire system journal.

dualbooting with Windows and

ceterum censeo: 3rd link below.

Network Manager. I've noticed that internet does work for a couple of seconds after the boot but then stops working. Please see dmesg here https://pastebin.com/JFTAvRxg . I couldn't see any relevant errors there.

Thank you

Offline

#4 2021-11-17 13:54:56

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: [resolved] No internet on wifi, Dell XPS 9370, QCA6174

I've noticed that internet does work for a couple of seconds after the boot but then stops working

sudo journalctl -b
find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

There's some issue w/ the usb host controller, but unless the ath10k is on the same PCI as the USB, I don't see how this would interfere. Also it's 2.5 minutes into the boot,

Offline

#5 2021-11-17 14:09:49

ebanashka
Member
Registered: 2021-11-17
Posts: 3

Re: [resolved] No internet on wifi, Dell XPS 9370, QCA6174

Yes, sorry I left the computer on and the log is not right after the boot.

After executing the latter command I saw that there was a nordvpnd service installed. The internet started working after I stopped that service.

Thank you Seth, your help is much appreciated.

Offline

#6 2021-11-17 14:32:24

seth
Member
Registered: 2012-09-03
Posts: 25,086

Re: [resolved] No internet on wifi, Dell XPS 9370, QCA6174

Great.

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

Board footer

Powered by FluxBB