You are not logged in.

#1 2021-11-23 12:02:58

diana
Member
Registered: 2021-11-23
Posts: 9

PCIe Bus Error

error:

 kernel: pcieport PCIe Bus Error: severity=Corrected, type=Physical Layer 

this gets spammed in my journalctl -b   on every boot.
i know i can use the kernel parameter “pcie_aspm=off” but then the problem isn’t actually completely fixed as this happens on all systemd operating systems that i've tried

i fixed this error delaying reboot/shut down by enabling ASPM in bios, but on boot this message just doesn’t stop and can be up to thousands of error messages

Last edited by diana (2021-11-23 12:18:04)

Offline

#2 2021-11-23 13:52:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

It's a corrected error so technically not really worrysome. In any case for giving any useful advice you need to post the full message and maybe check lspci to know which actual bus/device is producing the errors. You can disable ASPM targeted towards a specific problematic device/bus. Alternatively if you just want to silence the logs without actually checking the problem nor taking the power drawback of disabling aspm you can use the

pci=noaer

kernel parameter

Last edited by V1del (2021-11-23 13:54:43)

Offline

#3 2021-11-23 14:06:42

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

when i turn aspm off completely, i have a delayed reboot/shutdown of around 2 minutes.

i'm happy to completely turn it off but it seems if i do that without a kernel parameter i get spammed with that message, also, this error is coming from a "root port" it seems when i use the vendor/device id to check

if there's no fix for this, how would i go about disabling aspm for 1 thing in particular?

Last edited by diana (2021-11-23 14:08:25)

Offline

#4 2021-11-23 14:29:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

As mentioned, the noaer parameter just disables the logging, without any of the normal drawbacks you'd have from disabling aspm completely.

you need to find which device is on said root port, usual candidates are controllers for some realtek ethernet or samsung ssd/nvmes, sometimes you have a targeted kernel module option to influence this, otherwise you can disable on the specific port directly which is for example explained in: https://wiki.archlinux.org/title/Power_ … Management

Again we/I could give you better suggestions if we had the actual error message/lspci -k output available here.

Offline

#5 2021-11-23 14:42:14

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

okay, the device output, from "lspci -k" for what is making this corrected error appear is "Intel Corporation Cannon Lake PCH PCI Express Root", i seen in other threads people having this error because of ssds and stuff but that doesn't seem to be what is causing mine from the name

Last edited by diana (2021-11-23 14:42:42)

Offline

#6 2021-11-23 15:11:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

Not really no. The error will always be visible on the root hub since that's what's handling whatever causes the error. It's much more likely that an actual device that is attached to this specific root hub is generating the error, maybe additionally check lspci -tv so you see which devices are connected.  Please post these outputs at least in addition to your own interpretations so people can actually check exactly what you are seeing: https://bbs.archlinux.org/viewtopic.php?id=57855 you could of course just disable the entire root node but that will simply lead to aspm being disabled for every single device, which will bring you back to the  delay problem.

Offline

#7 2021-11-23 15:20:46

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

okay, i know you asked for the output of that command but i have found what it is coming from so i can make it easier, its coming from my wireless network adapter. knowing this, do you still need the output of anything?

Offline

#8 2021-11-23 15:26:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

Yes still everything, at the very least which wifi chipset so we can check whether it has relevant module options, but maybe additionally

lspci -k
modinfo $wifimodulenamehere$
sudo dmesg | grep $insertwifimodulenamehere$

replace the marked parts  with the actual wifi module name (e.g. modinfo iwlwifi ).

Offline

#9 2021-11-23 16:04:55

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

realtek RTL8192EE,
in lspci -k, it says the correct kernel module is in use, rtl8192ee.

 Network controller: RTL8192EE PCIe Wireless Network Adapter
 modules: rtl8192ee 

Last edited by diana (2021-11-23 16:05:12)

Offline

#10 2021-11-23 16:25:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

Add a file in /etc/modprobe.d/disableRealtekAspm.conf

options rtl8192ee aspm=0 #potentially additionally, but shouldn't be necessary if we assume that just aspm is the problem: fwpls=0 ips=0

and reboot

Last edited by V1del (2021-11-23 16:28:10)

Offline

#11 2021-11-23 16:28:57

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

would there be any way to do this in a way so that if i ever for example, reinstalled arch i could have it on by default?

Offline

#12 2021-11-23 16:40:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,444

Re: PCIe Bus Error

You could update your UEFI and hope it was a known issue that your laptop vendor was able to fix in firmware.

Otherwise you know that you have broken hardware and  can add the parameter. You can't generically fix broken hardware. You can hope/report bugs so that the issue gets fixed (either by actually fixing the underlying issue or by adding your specific HW to a quirk list that unconditionally disables aspm)  and no one needs to adjust things like that manually.

On a more general scope. realtek wifi cards are notorious and have been for years for a variety of issues and you are unlikely the first to experience or report issues here. If you want to avoid this altogether, you'll need to buy different HW. If the HW works safe for this issue that requires you to do one small edit in a config file you really shouldn't worry about it too much. If you really want to you could create your own package that sets this config up and install that whenever you do an Arch install.

Last edited by V1del (2021-11-23 16:45:11)

Offline

#13 2021-11-23 16:51:11

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

im not using a laptop. i had aspm off already which is why its so confusing, im getting aspm errors and i didnt even have it enabled

Offline

#14 2021-11-23 21:37:56

diana
Member
Registered: 2021-11-23
Posts: 9

Re: PCIe Bus Error

gonna use the fix i have, pcie_aspm=off kernel parameter, thanks for helping

Last edited by diana (2021-11-23 22:22:35)

Offline

Board footer

Powered by FluxBB