You are not logged in.

#1 2021-12-27 18:43:40

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Hey, I'm very new to arch-linux, and ever since I've installed I've had very slow internet speeds. I have made sure that all packages are up to date as of posting this (including linux-firmware). I use NetworkManager and IWD for wifi, here are their configs:
/etc/modprobe.d/iwlwifi.conf:

options iwlwifi llndisable=1 swcrypto=1 bt_xoex_active=0

/etc/NetworkManager/conf.d/wifi_backend.conf:

[device]
wifi.backend=iwd

Here's what I get under "Network Controller" when I run "sudo lspci -v":

05:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
        Subsystem: Rivet Networks Killer™ Wi-Fi 6 AX1650x (AX200NGW)
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at ec300000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Endpoint, MSI 00
        Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [14c] Latency Tolerance Reporting
        Capabilities: [154] L1 PM Substates
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi 

sudo dmesg | grep iwlwifi

[    2.449188] iwlwifi: unknown parameter 'llndisable' ignored
[    2.449190] iwlwifi: unknown parameter 'bt_xoex_active' ignored
[    2.449279] iwlwifi 0000:05:00.0: enabling device (0000 -> 0002)
[    2.452889] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-cc-a0-66.ucode failed with error -2
[    2.452901] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-cc-a0-65.ucode failed with error -2
[    2.452912] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-cc-a0-64.ucode failed with error -2
[    2.458341] iwlwifi 0000:05:00.0: api flags index 2 larger than supported by driver
[    2.458351] iwlwifi 0000:05:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[    2.458526] iwlwifi 0000:05:00.0: loaded firmware version 63.c04f3485.0 cc-a0-63.ucode op_mode iwlmvm
[    2.548469] iwlwifi 0000:05:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[    2.671732] iwlwifi 0000:05:00.0: Detected RF HR B3, rfid=0x10a100
[    2.736872] iwlwifi 0000:05:00.0: base HW address: 60:f2:62:b7:85:09 bt_xoe
[    2.750863] iwlwifi 0000:05:00.0: iwlmvm doesn't allow to disable HW crypto, check swcrypto module parameter
[   49.461135] iwlwifi 0000:05:00.0: Not associated and the session protection is over already...
[   50.500874] iwlwifi 0000:05:00.0: Not associated and the session protection is over already...
[   51.265289] iwlwifi 0000:05:00.0: Got NSS = 4 - trimming to 2 

My full dmesg here
Here is my  "iwctl device wlan0 show"                                 

Device: wlan0
--------------------------------------------------------------------------------
  Settable  Property            Value
--------------------------------------------------------------------------------
            Name                wlan0
         *  Mode                station
         *  Powered             on
            Address             60:f2:62:b7:85:09
            Adapter             phy0 

Here is my "iwctl station wlan0 show":

                                 Station: wlan0
--------------------------------------------------------------------------------
  Settable  Property            Value
--------------------------------------------------------------------------------
            Scanning            yes
            State               connected
            Connected network   I Dont Know
            IPv4 address        10.0.0.81
            IPv6 address        [REDACTED]
            IPv6 address        [REDACTED]
            ConnectedBss        48:4b:d4:6c:f2:ed
            Frequency           5785
            Security            WPA2-Personal
            RSSI                -60                  dBm
            AverageRSSI         -61                  dBm
            RxMode              802.11ax
            RxMCS               7
            TxBitrate           54000                Kbit/s
            RxBitrate           360300               Kbit/s

Here is my ip link, if it helps:

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:4e:01:ba:3c:1c brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 60:f2:62:b7:85:09 brd ff:ff:ff:ff:ff:ff 

Here is my journalctl -: Gist
If it helps, neofetch says my kernel version is "5.15.11-arch2-1"
I am dual-booting with WIndows 10, and I have made sure fast-boot is off.
My internet speed on Windows (download) is usually at 120-230 mbps, while on Arch I get 11-25 mbps (sometimes shows 50 mbps for a second, then drops down). I got these results from the speedtest on Fast.com
I am sorry if this is a very simple mistake, and if I forgot to provide some information, please ask and I will give it, as I am very new to this :). Thank you all in advance for the help :)

Last edited by Pollastre (2021-12-28 15:22:58)

Offline

#2 2021-12-27 19:31:18

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,070

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

options iwlwifi llndisable=1 swcrypto=1 bt_xoex_active=0

The first option is written wrong, it should be   11n_disable .

2nd option is written correctly, but

[    2.750863] iwlwifi 0000:05:00.0: iwlmvm doesn't allow to disable HW crypto, check swcrypto module parameter

are you sure you need swcrypto ?

The 3rd option is written wrong also , it must be bt_coex_active . Are you sure you want to disable bluetooth when wifi is used and viceversa ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-12-27 23:15:11

Zod
Member
From: Hoosiertucky
Registered: 2019-03-10
Posts: 539

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

I'm here to quibble and chew bubblegum!

And I'm all outa gum!

[device]
wifi.backend=iwd]

That ain't right.

Offline

#4 2021-12-28 15:40:48

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Sorry for the late reply, I wasn't awake until now

Zod wrote:
[device]
wifi.backend=iwd]

That ain't right.

Very sorry, that was a typo when I was typing out the post, I corrected in the original post with an edit, my /etc/NetworkManager/conf.d/wifi_backend.conf looks like this:

[device]
wifi.backend=iwd
Lone_Wolf wrote:
options iwlwifi llndisable=1 swcrypto=1 bt_xoex_active=0

The first option is written wrong, it should be   11n_disable .
2nd option is written correctly, but

[    2.750863] iwlwifi 0000:05:00.0: iwlmvm doesn't allow to disable HW crypto, check swcrypto module parameter

are you sure you need swcrypto ?
The 3rd option is written wrong also , it must be bt_coex_active . Are you sure you want to disable bluetooth when wifi is used and viceversa ?

Thank you for your input. I've now modified my /etc/modprobe.d/iwlwifi.conf to look like this:

optins iwlwifi 11ndisable=1

After restarting my computer because of the iwlwifi.conf change, I've noticed that immediately after starting my computer and doing a speedtest, I get the same speed I usually get on Windows (~150 mbps).
However, after a minute or two, my speeds drop down to what they usually are on Arch (11-25 mbps). Hopefully this information helps! :)

Offline

#5 2021-12-28 15:59:40

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Please post a complete system journal for that boot

sudo journalctl | curl -F 'f:1=<-' ix.io

Also

I have made sure fast-boot is off

Please confirm that you didn't disable some setting in the BIOS but actually in windows.

Finally, see https://wiki.archlinux.org/title/Power_ … _(iwlwifi)
Enable the feature in the driver and then deactivate it

iw dev wlan0 set power_save off

Edit:

optins iwlwifi 11ndisable=1

is still BS.

options iwlwifi 11n_disable=1

Last edited by seth (2021-12-28 16:00:58)

Offline

#6 2021-12-28 16:04:41

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,070

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

I think we need  fresh logs, preferably with a better noise / information ratio .

add audit=0 to your bootloader command line temporarily to suppress the audit messages.

reboot, login as root on console.

post dmesg and SYSTEMD_LESS=FRXMK journalctl -b output , also /etc/NetworkManager/NetworkManager.conf .

See https://wiki.archlinux.org/title/List_o … n_services for methods to post from terminal / wihout a gui .


P.S. Welcome to archlinux forums

Last edited by Lone_Wolf (2021-12-28 16:05:14)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#7 2021-12-28 16:09:56

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Also for reference, https://bbs.archlinux.org/viewtopic.php … 1#p1918191 (was a µcode crash, but hey…)

Offline

#8 2021-12-28 18:30:01

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Please confirm that you didn't disable some setting in the BIOS but actually in windows.

I can confirm that the fast boot setting i disabled was through Windows 10 power management.

seth wrote:

Edit:

optins iwlwifi 11ndisable=1

is still BS.

Sorry about that, I can now confirm that my /etc/modeprob.d/iwlwifi.conf is

 options iwlwifi 11n_disable=1 
Lone_Wolf wrote:

add audit=0 to your bootloader command line temporarily to suppress the audit messages.

reboot, login as root on console.

post dmesg and SYSTEMD_LESS=FRXMK journalctl -b output , also /etc/NetworkManager/NetworkManager.conf

Alright, my dmesg is right here and SYSTEMD_LESS=FRXMK journalctl -b is right here

seth wrote:

Also for reference, https://bbs.archlinux.org/viewtopic.php … 918191test (was a µcode crash, but hey…)

I tried the settings shown, and unfortunately it did not seem to have any effect on speed.

Offline

#9 2021-12-28 20:25:08

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Is this an issue w/o nordvpn?

Offline

#10 2021-12-29 00:02:25

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Is this an issue w/o nordvpn?

Yeah, these speeds are without using nordvpn.
edit: and iirc even without nordvpn installed I got these speeds

Last edited by Pollastre (2021-12-29 10:30:34)

Offline

#11 2021-12-30 17:08:40

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Bit of an update: I just tested it, and I get the expected download speeds (~200mbps) on Manjaro, hope this helps!

Offline

#12 2021-12-30 20:17:52

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Same kernel version?

Offline

#13 2021-12-30 20:28:20

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Same kernel version?

Nope, kernel version 5.15.12 on Arch, and kernel version 5.15.7-1 on Manjaro

Offline

#14 2021-12-30 20:29:03

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Have you tried the lts kernel on arch?

Offline

#15 2021-12-30 20:30:22

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Have you tried the lts kernel on arch?

Nope, but I'll try it now and report back.

Offline

#16 2021-12-30 20:47:54

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Pollastre wrote:
seth wrote:

Have you tried the lts kernel on arch?

Nope, but I'll try it now and report back.

Just did a speedtest with the 5.10.88-2-lts kernel, got the same speed of ~20mbps (using speedtest-cli, DE didn't work on lts kernel).

Offline

#17 2021-12-30 20:54:56

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Well, let's see the difference.

systool -vm iwlwifi
sudo journalctl -b

on manjaro and arch (w/ nordvpn disabled)

Offline

#18 2021-12-30 21:10:46

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Well, let's see the difference.

systool -vm iwlwifi
sudo journalctl -b

on manjaro and arch (w/ nordvpn disabled)

Alrighty, here's the systool on arch, and here's the journalctl -b on arch. Here's the systool on manjaro, and here's the journalctl -b on manjaro

Offline

#19 2021-12-30 21:23:17

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Manjaro doesn't have "11n_disable" and therefore also not

Dec 30 13:56:30 Alienware kernel: iwlwifi 0000:05:00.0: base HW address: 60:f2:62:b7:85:09
Dec 30 13:56:30 Alienware kernel: ------------[ cut here ]------------
Dec 30 13:56:30 Alienware kernel: WARNING: CPU: 1 PID: 377 at drivers/net/wireless/intel/iwlwifi/iwl-nvm-parse.c:698 iwl_init_he_hw_capab+0x30b/0x320 [iwlwifi]
Dec 30 13:56:30 Alienware kernel: Modules linked in: nvidia_drm(POE) pcc_cpufreq(-) nvidia_uvm(POE) nvidia_modeset(POE) acpi_cpufreq(-) intel_tcc_cooling x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel iwlmvm(+) iTCO_wdt dell_wmi ee1004 snd_hda_codec_realtek kvm intel_pmc_bxt dell_smbios ucsi_ccg(+) iTCO_vendor_support 8250_dw snd_hda_codec_generic dcdbas mei_hdcp typec_ucsi nvidia(POE) ledtrig_audio irqbypass typec roles mac80211 crct10dif_pclmul sparse_keymap alienware_wmi crc32_pclmul wmi_bmof dell_wmi_descriptor intel_wmi_thunderbolt mxm_wmi ghash_clmulni_intel snd_hda_codec_hdmi libarc4 snd_hda_intel aesni_intel snd_intel_dspcfg snd_intel_sdw_acpi crypto_simd cryptd rapl vfat intel_cstate iwlwifi i2c_i801 pcspkr intel_uncore snd_hda_codec fat i2c_smbus snd_hda_core intel_lpss_pci intel_lpss cfg80211 snd_hwdep alx idma64 snd_pcm mdio rfkill snd_timer mei_me i915 mei snd tpm_crb i2c_nvidia_gpu ttm soundcore intel_gtt tpm_tis video tpm_tis_core tpm wmi rng_core mac_hid acpi_tad acpi_pad sg
Dec 30 13:56:30 Alienware kernel:  crypto_user fuse bpf_preload ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 usbhid xhci_pci crc32c_intel xhci_pci_renesas
Dec 30 13:56:30 Alienware kernel: CPU: 1 PID: 377 Comm: modprobe Tainted: P           OE     5.15.12-arch1-1 #1 eeb185e1d4b23217f1216641b0351a46bd23d8bc
Dec 30 13:56:30 Alienware kernel: Hardware name: Alienware Alienware Aurora R9/0T76PD, BIOS 1.0.14 09/06/2021
Dec 30 13:56:30 Alienware kernel: RIP: 0010:iwl_init_he_hw_capab+0x30b/0x320 [iwlwifi]
Dec 30 13:56:30 Alienware kernel: Code: 44 89 20 0f b7 4b 5c 83 c2 01 48 83 c0 50 39 ca 7c ed e9 5c fd ff ff 48 8d 86 38 02 00 00 e9 8e fd ff ff 0f 0b e9 49 fd ff ff <0f> 0b e9 2f ff ff ff 0f 0b e9 46 ff ff ff e8 02 ae 00 e7 66 90 0f
…

But the screaming difference is that manjaro is using wpa_supplicant…

Offline

#20 2021-12-30 21:43:14

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

Manjaro doesn't have "11n_disable" and therefore also not

Dec 30 13:56:30 Alienware kernel: iwlwifi 0000:05:00.0: base HW address: 60:f2:62:b7:85:09
Dec 30 13:56:30 Alienware kernel: ------------[ cut here ]------------
Dec 30 13:56:30 Alienware kernel: WARNING: CPU: 1 PID: 377 at drivers/net/wireless/intel/iwlwifi/iwl-nvm-parse.c:698 iwl_init_he_hw_capab+0x30b/0x320 [iwlwifi]
Dec 30 13:56:30 Alienware kernel: Modules linked in: nvidia_drm(POE) pcc_cpufreq(-) nvidia_uvm(POE) nvidia_modeset(POE) acpi_cpufreq(-) intel_tcc_cooling x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel iwlmvm(+) iTCO_wdt dell_wmi ee1004 snd_hda_codec_realtek kvm intel_pmc_bxt dell_smbios ucsi_ccg(+) iTCO_vendor_support 8250_dw snd_hda_codec_generic dcdbas mei_hdcp typec_ucsi nvidia(POE) ledtrig_audio irqbypass typec roles mac80211 crct10dif_pclmul sparse_keymap alienware_wmi crc32_pclmul wmi_bmof dell_wmi_descriptor intel_wmi_thunderbolt mxm_wmi ghash_clmulni_intel snd_hda_codec_hdmi libarc4 snd_hda_intel aesni_intel snd_intel_dspcfg snd_intel_sdw_acpi crypto_simd cryptd rapl vfat intel_cstate iwlwifi i2c_i801 pcspkr intel_uncore snd_hda_codec fat i2c_smbus snd_hda_core intel_lpss_pci intel_lpss cfg80211 snd_hwdep alx idma64 snd_pcm mdio rfkill snd_timer mei_me i915 mei snd tpm_crb i2c_nvidia_gpu ttm soundcore intel_gtt tpm_tis video tpm_tis_core tpm wmi rng_core mac_hid acpi_tad acpi_pad sg
Dec 30 13:56:30 Alienware kernel:  crypto_user fuse bpf_preload ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 usbhid xhci_pci crc32c_intel xhci_pci_renesas
Dec 30 13:56:30 Alienware kernel: CPU: 1 PID: 377 Comm: modprobe Tainted: P           OE     5.15.12-arch1-1 #1 eeb185e1d4b23217f1216641b0351a46bd23d8bc
Dec 30 13:56:30 Alienware kernel: Hardware name: Alienware Alienware Aurora R9/0T76PD, BIOS 1.0.14 09/06/2021
Dec 30 13:56:30 Alienware kernel: RIP: 0010:iwl_init_he_hw_capab+0x30b/0x320 [iwlwifi]
Dec 30 13:56:30 Alienware kernel: Code: 44 89 20 0f b7 4b 5c 83 c2 01 48 83 c0 50 39 ca 7c ed e9 5c fd ff ff 48 8d 86 38 02 00 00 e9 8e fd ff ff 0f 0b e9 49 fd ff ff <0f> 0b e9 2f ff ff ff 0f 0b e9 46 ff ff ff e8 02 ae 00 e7 66 90 0f
…

I set 11n_disable to 0, restarted, and at first a speed test came up with 200+ mbps. After another restart (no settings changed) I get between 0.2 mbps and 40 mbps on a speed test.

Offline

#21 2021-12-30 21:52:54

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

But the screaming difference is that manjaro is using wpa_supplicant…

Also check for differences in the fast and slow boot journals (eg. whether it connects 5GHz / 2.4 GHz or so)

Offline

#22 2022-01-03 20:40:36

rcassani
Member
Registered: 2020-12-10
Posts: 1

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

@Pollastre, you could also check if there are differences in the power_scheme parameter used with the iwlmvm module

systool -v -m iwlmvm

In my case setting power_scheme to 1 solved the issue.
Described here: https://bbs.archlinux.org/viewtopic.php … 0#p1951800

Offline

#23 2022-05-17 05:30:08

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

Wasn't using arch for a while but now I'm back on it. I'm still having what seems to be the same issue. Since it's a new install, should I make a new thread?

Offline

#24 2022-05-17 15:47:54

seth
Member
Registered: 2012-09-03
Posts: 28,866

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

No. Nothing has changed.
DId you check on #21 and #22?

Offline

#25 2022-05-17 19:38:21

Pollastre
Member
Registered: 2021-12-27
Posts: 15

Re: Intel AX200 | 10x slower WI-FI speeds compared to windows 10

seth wrote:

No. Nothing has changed.
DId you check on #21 and #22?

#22 hasn't helped, my power_scheme is set to 1 and nothing has changed. Here's what my iwlwifi.conf currently looks like:

 options iwlwifi 11n_disable=1 swcrypto=0 bt_coex_active=0 power_save=0
options iwlmvm power_scheme=1
options iwlwifi d0i3_disable=1
options iwlwifi uapsd_disable=1
options iwlwifi lar_disable=1

For #21, I'm not sure what I'm exactly supposed to be looking for, sorry.

Offline

Board footer

Powered by FluxBB