You are not logged in.

#1 2022-01-14 15:52:15

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

[SOLVED] Rosegarden complains system timer resolution is too low

Hello,

Just wondering if anyone here knows the proper solution to this on Arch Linux? I'm using a realtime kernel (xanmod 5.15.12 rt) and I'm not sure what, if any, package provides something comparable to the snd-rtctimer module Rosegarden is looking for.

Thanks!

Edit: I have found the solution, look post #6

Last edited by Mezzy12 (2022-06-16 13:52:27)

Offline

#2 2022-01-14 17:09:52

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,398

Re: [SOLVED] Rosegarden complains system timer resolution is too low


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#3 2022-01-14 19:22:58

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

Re: [SOLVED] Rosegarden complains system timer resolution is too low

Came across that in my googling of the issue, unfortunately, it's most concerned with audio output of Rosegarden. The aur package which the OP installed that might be in relation to the kernel module no longer exists and I cannot find anything that would replace, if it even solved the issue in the first place.

Thanks anyways!

Offline

#4 2022-01-15 10:33:11

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,398

Re: [SOLVED] Rosegarden complains system timer resolution is too low

A search for rtctimer (links below) does suggest that the linux kernel did have such a module in the past .

The most recent mention I could find is from kernel 3.16 , http://lkml.iu.edu/hypermail/linux/kern … 03158.html

Please post the full error message you get from rosegarden, that should help to determine if those links are relevant (or a red herring)


https://how-to.fandom.com/wiki/How_to_c … sound/core
https://www.mail-archive.com/ubuntu-bug … 43684.html
https://bugs.archlinux.org/task/7313

Last edited by Lone_Wolf (2022-01-15 10:33:35)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#5 2022-01-19 20:43:47

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

Re: [SOLVED] Rosegarden complains system timer resolution is too low

Hello, sorry for the delay.

This is the relevant error message from Rosegarden. (Taken from terminal because the actual window displaying it doesn't allow for selecting/copying off text.)

[WarningWidget] WarningWidget::queueMessage( "<h3>System timer resolution is too low!</h3>" ,  "<p>Rosegarden was unable to find a high-resolution timing source for MIDI performance.</p><p>You may be able to solve this problem by loading the RTC timer kernel module.  To do this, try running <b>sudo modprobe snd-rtctimer</b> in a terminal window and then restarting Rosegarden.</p><p>Alternatively, check whether your Linux distributor provides a multimedia-optimized kernel.  See the <a style=\"color:gold\"  href=\"http://www.rosegardenmusic.com/wiki/low-latency_kernels\">Rosegarden website</a> for notes about this.</p>" )

I also found this, the actual log portion of the terminal output.

[AlsaDriver] setCurrentTimer(): WARNING: using system timer with only  500 Hz resolution!

Looks like the problem really is real, unfortunately sad

That link you posted in relation to kernel options would seem to imply that the current solution to this is to compile my own kernel, which would be less that ideal.

Thanks for your help so far smile

Offline

#6 2022-01-20 19:05:46

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

Re: [SOLVED] Rosegarden complains system timer resolution is too low

Okay, I've come to a conclusion. You DO need to get the system clock to 1000Hz/1kHz, and the kernel that provides this is linux-ck. For anyone else having the same issue and who wants accurate MIDI implementation on linux, I believe this is the place to start. On modern linux kernels, it would appear that there is no direct replacement for 'snd-rtctimer' and what you actually need is a proper implementation of the hrtimer, i.e. a clock at 1000Hz. Linux-ck is good enough for RT requirements for jack, as is any modern kernel, as long as you put 'threadirq' in your kernel parameters.

Hope this helps anyone else having this issue.

EDIT: Corrected a typo and capitalised the 'H' in Hz tongue

Last edited by Mezzy12 (2022-01-24 21:40:55)

Offline

#7 2022-01-20 19:33:28

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,755

Re: [SOLVED] Rosegarden complains system timer resolution is too low

1 kHz or 100 Hz?  I think one of those is a typo.   Any chance I can convince you to capitalize Hz ?  It is a personal pet peeve.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#8 2022-01-23 11:32:32

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,398

Re: [SOLVED] Rosegarden complains system timer resolution is too low

It should be 1000 Hz or 1 KHz .

https://wiki.archlinux.org/title/Profes … ime_kernel gives some more background.

Keep in mind that the timer frequency only matters for MIDI .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#9 2022-01-24 21:39:33

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

Re: [SOLVED] Rosegarden complains system timer resolution is too low

ewaller wrote:

1 kHz or 100 Hz?  I think one of those is a typo.   Any chance I can convince you to capitalize Hz ?  It is a personal pet peeve.

Sorry, I hadn't picked up on that typo! It is indeed 1000Hz, as Lone_Wolf points out. They also correctly point out that it is only good for MIDI accuracy, which is fine, because that's the issue I was looking to solve!

Offline

#10 2022-01-24 21:43:38

Mezzy12
Member
Registered: 2022-01-14
Posts: 13

Re: [SOLVED] Rosegarden complains system timer resolution is too low

Would it be a good idea to add some information about the 1kHz timer to the midi section on the JACK arch wiki page? Just gauging the opinions of others here.

Offline

#11 2022-01-25 10:26:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,398

Re: [SOLVED] Rosegarden complains system timer resolution is too low

More information / testing is needed.

It seems rosegarden can use either timidity or jack for midi .
Some testing shouild clarify if both those options need the 1000 Hz time or just one of them.


NB you may want to include the number of the post the solution is listed in the first post.

Last edited by Lone_Wolf (2022-01-25 10:28:38)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#12 2022-01-25 11:47:34

martinc2
Member
Registered: 2011-09-23
Posts: 51

Re: [SOLVED] Rosegarden complains system timer resolution is too low

FWIW, I don't get any timer complaints using Rosegarden (or Ardour) with linux-zen kernels.  I am flying a little blind here (only just starting to play with midi/audio) but what seemed to work for me was

  • ensure that the user is a member of the 'audio' group

  • following a post in the linux mint forums, add the following to '/etc/security/limits.conf'

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19

With these settings, everything seems to be working smoothly, as far as I can tell.

Offline

Board footer

Powered by FluxBB