You are not logged in.

#1 2004-03-27 09:05:15

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Openoffice + YYError

Hi,

yesterday and today I tried building Openofice 1.1.1rc3. Well the built broke with an YYError. According to the PKGBUILD it is necessary to patch a file.

How should I do this ? I tried putting the given sentences in the file, but it changed nothing.

Sarah31, any hints ? :-)

thanks

Kin

Offline

#2 2004-03-27 11:50:47

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Openoffice + YYError

no idea if your error has anything to do with the patching tha tneeds to be done to that one bison file.... as for patching that file. i just commented the lines out then uncommented thm later. i found that easier as i knew where the lines were.


AKA uknowme

I am not your friend

Offline

#3 2004-03-27 14:31:20

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Re: Openoffice + YYError

Hi,

I dont know whether it is the problem with bison.

So here is the ouput:

=============
Building project transex3
=============
/var/abs/extra/office/openoffice/src/oo_1.1.1_src/transex3/source
--- EXCEPTIONSFILES ---
`../unxlngi4.pro/obj/localize.obj' is up to date
--- EXCEPTIONSFILES OVER ---
------------------------------
Making: ../unxlngi4.pro/obj/cfg_yy.obj
gcc -fmessage-length=0 -c -I.  -I. -I../inc -I../inc -I../unx/inc -I../unxlngi4.
pro/inc -I. -I/var/abs/extra/office/openoffice/src/oo_1.1.1_src/solver/645/unxln
gi4.pro/inc/dont_use_stl -I/var/abs/extra/office/openoffice/src/oo_1.1.1_src/sol
ver/645/unxlngi4.pro/inc/external -I/var/abs/extra/office/openoffice/src/oo_1.1.
1_src/solver/645/unxlngi4.pro/inc -I/var/abs/extra/office/openoffice/src/oo_1.1.
1_src/solenv/unxlngi4/inc -I/var/abs/extra/office/openoffice/src/oo_1.1.1_src/so
lenv/inc -I/var/abs/extra/office/openoffice/src/oo_1.1.1_src/res -I/var/abs/extr
a/office/openoffice/src/oo_1.1.1_src/solver/645/unxlngi4.pro/inc/dont_use_stl -I
/var/abs/extra/office/openoffice/src/oo_1.1.1_src/solenv/inc/Xp31 -I/opt/j2sdk/i                               nclude -I/opt/j2sdk/include/linux -I/opt/j2sdk/include/native_threads/include -I                               /usr/X11R6/include     -I. -I../res -I. -O1   -pipe -mcpu=pentiumpro   -DLINUX -                               DUNX -DVCL -DGCC -DC300 -DINTEL -DGXX_INCLUDE_PATH=/usr/include/c++/3.3.3 -DCVER                               =C300 -D_USE_NAMESPACE -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_U                               SE_NAMESPACE=1 -DSTLPORT_VERSION=400 -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DSUPD=645                                -DBUILD=8762 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -                               DEXCEPTIONS_OFF -DCUI -DSOLAR_JAVA -DSRX645  -DYY_NEVER_INTERACTIVE=1 -DMULTITHR                               EAD   -o ../unxlngi4.pro/obj/cfg_yy.o ../unxlngi4.pro/misc/cfg_yy.c
../unxlngi4.pro/misc/cfg_yy.c: In function `yylex':
../unxlngi4.pro/misc/cfg_yy.c:1424: error: `yy_prev_more_offset' undeclared (fir                               st use in this function)
../unxlngi4.pro/misc/cfg_yy.c:1424: error: (Each undeclared identifier is report                               ed only once
../unxlngi4.pro/misc/cfg_yy.c:1424: error: for each function it appears in.)
dmake:  Error code 1, while making '../unxlngi4.pro/obj/cfg_yy.obj'
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making /var/abs/extra/office/openoffice/src/oo                               _1.1.1_src/transex3/source
dmake:  Error code 1, while making 'build_all'
---* TG_SLO.MK *---
==> ERROR: Build Failed.  Aborting...

Offline

#4 2004-03-27 16:27:09

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Openoffice + YYError

Sounds like a problem with the new flex package (it's not backward compatible either).  There's an old version still on the ftp, try downgrading and building openoffice.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#5 2004-03-27 19:20:28

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Re: Openoffice + YYError

Hi Xen,

I downgraded to the flex version of arch 0.5. The same problem occured...


Kin

Offline

#6 2004-03-28 09:10:46

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Re: Openoffice + YYError

I tried the OOO 1.1.0 source. It built without any problems.

Offline

#7 2004-03-29 17:08:33

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Re: Openoffice + YYError

According to http://www.ibiblio.org/pub/mirrors/open … ble/1.1.1/
1.1.1 is out, so let´s try also this one... :-)
Kin

Offline

#8 2004-04-05 15:06:19

eric
Member
From: under heaven
Registered: 2004-02-11
Posts: 113

Re: Openoffice + YYError

Just like Xentac said, there's a problem with the new version of flex. I dunno if this bug is also in the older versions. I've had problem with this bug when I tried to build xfree86.

You can read about this bug here:
http://sourceforge.net/tracker/index.ph … tid=533377

After installing a different flex ( ftp://ftp.gnu.org/gnu/non-gnu/flex/ ), everything build fine :-)

Offline

Board footer

Powered by FluxBB