You are not logged in.

#1 2022-03-26 23:50:17

quimkaos
Member
Registered: 2014-09-27
Posts: 53

[Solved][Fixed] PhpMyAdmin Can't export databases

I'm having trouble exporting mariaDB databases from inside PhpMyAdmin. I still can do it with the terminal by using mysqldump: mysqldump -u {user} -p database > database.sql . In PhpMyAdmin i can import, just not export. In Firefox i get an error that roughly translates to something like "the transfer failed because the source could not be read", and in chrome/brave i simply get a network error warning and the transfer fails. This happens if i'm in the machine where the LAMP stack is installed or accessing it from another machine. I'm not seeing any errors or warnings in my logs (journalctl -u httpd.service or journalctl -u mariadb.service). Since i was going nowhere trying to trace/searching the problem, i tried reinstalling everything in a virtual machine using the wiki (as always), but the behavior is the same. Has anyone ever faced a similar issue?
Can someone help me trace/fix this?

Thanks in advance!

{edit}
looks like this is an issue upstream:
https://github.com/phpmyadmin/phpmyadmin/issues/17445
https://github.com/phpmyadmin/phpmyadmin/pull/17447

{edit 2}
As a workaround, it's possible to export, using the personalized output and choosing as output, view output as text,  instead of using exporting to file. Then copy the resulting text to a .sql file. this can be problematic with big dumps...

{edit 3}
can be fixed by downloading phpMyAdmin 5.1.4-dev from github:
https://github.com/phpmyadmin/phpmyadmin/tree/QA_5_1

an then running to build packages/dependencies:
composer update --no-dev
yarn install --production

This will be fixed in the next point release

Last edited by quimkaos (2022-03-28 23:29:34)

Offline

Board footer

Powered by FluxBB